none
The Messaging Engine encountered errors while initializing the send adapter "SFTP". RRS feed

  • Question

  • Hi,

    I am currently facing issues with my SFTP Adapter which was working fine earlier.

    I have configured a SFTP Send Port with the filter set. But every time there are zip files to be picked from the receive location, I get the below two errors in the event log.

    1. Messaging Engine encountered errors while initializing the send adapter "SFTP".

    2. A message sent to adapter "BiztalkMessagingEngine" on send port "SendPortName" with URI "SFTPReceiveLocation" is suspended. 

     Error details: Unknown Error Description 

    Thanks in advance.

    Thursday, March 3, 2016 6:09 AM

Answers

  • Hello

    • Use WinSCP to connect to the Send location and attempt to send the message. 
    • Assuming WinSCP worked, Update your BizTalk SFTP Settings.
    • Check that you have Write permissions on the SFTP folder.
    • Be sure that you are not writing to the SFTP root folder.
    • I have seen a reboot help with Adapter hangups.
    • Check out this post: Microsoft BizTalk Server 2013 R2 SFTP Adapter Tricks and Pitfalls

    Let me know if you are still hung up.



    Jason Sauers

    • Proposed as answer by Angie Xu Friday, March 11, 2016 2:38 AM
    • Marked as answer by Angie Xu Sunday, March 13, 2016 7:44 AM
    Thursday, March 10, 2016 8:54 PM

All replies

  • Hi Vinay,

    Thank you for posting on MSDN forum.

    Which version of BizTalk Server are you using ?

    I would suggest please have a look into below article that have solved the same issue.

    http://mylifeismymessage.net/unknown-error-description-dynamic-ftp/


    Thanks,

    If my reply is helpful please mark as Answer or vote as Helpful.

    My blog | Twitter | LinkedIn

    This post is my own opinion and does not necessarily reflect the opinion or view of Microsoft, its employees, or other MVPs.

    Thursday, March 3, 2016 6:26 AM
  • Hi Kamlesh,

    Thank you for your reply.

    I am using BizTalk Server 2013 R2.

    I have unenlisted the send port. Also restarted the host instances and enlisted back the send port too. But the same results.

    Thursday, March 3, 2016 6:44 AM
  • Hello

    • Use WinSCP to connect to the Send location and attempt to send the message. 
    • Assuming WinSCP worked, Update your BizTalk SFTP Settings.
    • Check that you have Write permissions on the SFTP folder.
    • Be sure that you are not writing to the SFTP root folder.
    • I have seen a reboot help with Adapter hangups.
    • Check out this post: Microsoft BizTalk Server 2013 R2 SFTP Adapter Tricks and Pitfalls

    Let me know if you are still hung up.



    Jason Sauers

    • Proposed as answer by Angie Xu Friday, March 11, 2016 2:38 AM
    • Marked as answer by Angie Xu Sunday, March 13, 2016 7:44 AM
    Thursday, March 10, 2016 8:54 PM