locked
Update Error for Self-Hosted Integration Runtime RRS feed

  • Question

  • Getting the following error when trying to copy from a DB2 server which is connected to by a DB2 linked service.

    The version "3.18.7118.1" of Self-hosted Integration Runtime "integrationRuntime3" is lower than 3.19.7138.1, which is not supported for your dataset. Please upgrade to the latest version.

    Copy activities that are already created work fine. But when creating new copy activities the above error is obtained. 


    Monday, August 26, 2019 9:47 PM

Answers

  • Hi bwong9,

    Could you please try upgrading your Integration Runtime to latest and see if you still notice any issue while creating copy activities? 

    Latest version of IR can be downloaded from here: https://www.microsoft.com/en-us/download/details.aspx?id=39717

    This upgrade will not impact any of the existing activities.

    Let us know how it goes.


    Thank you

    If a post helps to resolve your issue, please click the "Mark as Answer" of that post and/or click Answered "Vote as helpful" button of that post. By marking a post as Answered and/or Helpful, you help others find the answer faster.

    Tuesday, August 27, 2019 3:46 AM
  • I was able to do the update properly by updating the msi file on the machine hosting the Self-Hosted Integration Runtime. Thanks
    • Marked as answer by bwong9 Wednesday, September 4, 2019 4:30 PM
    Wednesday, September 4, 2019 4:30 PM

All replies

  • Hi bwong9,

    Could you please try upgrading your Integration Runtime to latest and see if you still notice any issue while creating copy activities? 

    Latest version of IR can be downloaded from here: https://www.microsoft.com/en-us/download/details.aspx?id=39717

    This upgrade will not impact any of the existing activities.

    Let us know how it goes.


    Thank you

    If a post helps to resolve your issue, please click the "Mark as Answer" of that post and/or click Answered "Vote as helpful" button of that post. By marking a post as Answered and/or Helpful, you help others find the answer faster.

    Tuesday, August 27, 2019 3:46 AM
  • Hi bwong9,

    Just checking to see if your issue was resolved. If you still need assistance do let us know.


    Thank you

    If a post helps to resolve your issue, please click the "Mark as Answer" of that post and/or click Answered "Vote as helpful" button of that post. By marking a post as Answered and/or Helpful, you help others find the answer faster.

    Tuesday, August 27, 2019 9:29 PM
  • Just to clarify on the fix, the new Integration runtime has to be downloaded onto the machine currently hosting the integration runtime then configured to to connect with the Data Factory?
    Wednesday, August 28, 2019 3:59 PM
  • Hi bwong9,

    Yes, you are correct, please update the Integration Runtime on the machine that is currently hosting the IR and then try using the latest IR in ADF pipelines.

    Let us know how it goes. 


    Thank you

    If a post helps to resolve your issue, please click the "Mark as Answer" of that post and/or click Answered "Vote as helpful" button of that post. By marking a post as Answered and/or Helpful, you help others find the answer faster.

    Wednesday, August 28, 2019 5:47 PM
  • Hi bwong9,

    Just checking in to see if the above suggestion was helpful. If this answers your query, please consider to click “Mark as Answer” and Up-Vote, as it might be beneficial to other community members reading this thread. And, if you have any further query do let us know.


    Thank you

    If a post helps to resolve your issue, please click the "Mark as Answer" of that post and/or click Answered "Vote as helpful" button of that post. By marking a post as Answered and/or Helpful, you help others find the answer faster.

    Thursday, August 29, 2019 5:45 PM
  • Hi there,

    Following up to see if your issue was resolved? If you have any further query, do let us know.


    Thank you

    If a post helps to resolve your issue, please click the "Mark as Answer" of that post and/or click Answered "Vote as helpful" button of that post. By marking a post as Answered and/or Helpful, you help others find the answer faster.

    Friday, August 30, 2019 9:44 PM
  • I was able to do the update properly by updating the msi file on the machine hosting the Self-Hosted Integration Runtime. Thanks
    • Marked as answer by bwong9 Wednesday, September 4, 2019 4:30 PM
    Wednesday, September 4, 2019 4:30 PM