locked
Blend 4 Trigger rendering not working RRS feed

  • Question

  • Ive got a really frustrating bug going on with Blend 4, when i edt a control template with triggers, if i switch to one of the triggers, the trigger changes are not shown in the design pane, its like ive turned off trigger rendering somehow

    Reproduction Steps

    Create a new WPF application in visual studio 2010
    Open new solution in blend
    Drag a "SimpleButton" onto the design surface
    Right click on the button>Edit Style>Edit Current
    On the triggers tab, select any of the triggers and nothing changes in the design view

    Any help would be greatly appreciated as this is quite a huge isue as far as blend goes

     

    -Kris

     

    Monday, July 19, 2010 3:19 AM

Answers

  • Thanks for bringing this to our attention, we've confirmed this regression from V3 behavior and we've filed a bug. If you select a trigger, even though it doesn't appear to be selected (the artboard doesn't immediately update), changes are recorded at leaves. And we have noticed behavior that you might want to use as a workaround. If you perform the following steps then the trigger is applied to the artboard:
    1. Select a trigger
    2. Click the style segment on the breadcrumb
    3. Click the template segment on the breadcrumb
    4. re-select the trigger
    Monday, July 19, 2010 11:19 PM

All replies

  • Narrowed it down a bit, this issue appears

    Only if the style is defined in a resource dictionary
    Only if the template is contained within a style, ie <Stlye><Setter><ControlTemplate>

    Monday, July 19, 2010 3:30 AM
  • Thanks for bringing this to our attention, we've confirmed this regression from V3 behavior and we've filed a bug. If you select a trigger, even though it doesn't appear to be selected (the artboard doesn't immediately update), changes are recorded at leaves. And we have noticed behavior that you might want to use as a workaround. If you perform the following steps then the trigger is applied to the artboard:
    1. Select a trigger
    2. Click the style segment on the breadcrumb
    3. Click the template segment on the breadcrumb
    4. re-select the trigger
    Monday, July 19, 2010 11:19 PM
  • Thanks for the workaround

    What is the usual timeline of a bug like this and is there anywhere i can go to see its status?

    -Kris

    Tuesday, July 20, 2010 12:49 AM