locked
Remote debugging of Azure App Service has suddenly stopped recognising credentials RRS feed

  • Question

  • Hello there,

    I am using Visual Studio 15.5.6.

    For over a year I have been developing an Azure App Service and regularly attaching the remote debugger. I do this by navigating to the App Service in the Cloud Explorer, right clicking and chosing Attach Debugger.

    As of this week I keep getting asked to enter my credentials which are then not recognised and I get stuck in a loop of being asked to enter my credentials.

    The only way I can get this to work is to switch off remote debugging on the App Service in the Azure Portal and then switch it back on again which is a pain.

    Updates to the project publish without problems. Does anyone have any hints or tips as to what might have changed to break this?

    Thanks,

    Phil




    Phil

    Thursday, April 12, 2018 2:32 PM

All replies

  • Hi Phil,

    It seems that the real issue is not the debugging tool issue, it would be related to the credentials, to real repro this issue, I help you move it to the Azure App Service forum for dedicated support.

    Sincerely,

    Jack


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, April 13, 2018 7:38 AM
  • I have exactly the same problem...

    Although, I can't even solve it by turning remote debugging on and off, I'm constantly stuck in a wrong credentials loop, I'm not even sure which credentials I should enter from my publish profile anymore 

    I tried, republishing profile, and publishing app again, still wrong credentials

    I tried entering following:

    - nameOfApp/$nameOfApp and password

    - /$nameOfApp and password

     - even my ftp credentials and password

    It would be really nice if someone can explain how this works, and which credentials should I enter, cause none seems to work. Once again publishing app works seamlessly.


    • Edited by predragbabic Friday, April 13, 2018 11:36 AM word ordering
    Friday, April 13, 2018 11:36 AM
  • Remote debugging uses NTLM V2 authentication. Follow below instructions, see if this can be help, on your PC, open secpol.msc, locate to local policies—security policy

    Double click: network security: Lan manager authentication level, select “send NTLMv2 response only”, click Apply and OK, reboot your PC if required and make sure latest SDK is installed. For more information and step by step process refer to this link.

    -----------------------------------------------------------------------------------------------------

    If this answer was helpful, click “Mark as Answer” or Up-Vote. To provide additional feedback on your forum experience, click here


    Wednesday, April 18, 2018 10:49 AM