none
Test agent configuration problem RRS feed

  • Question

  • The problem is I can't configure test agent and continue receive that "No such host error".

    I believe this is similar problem, but the solutions didn't work for me (http://social.msdn.microsoft.com/Forums/en-US/vslab/thread/b531be11-1bf6-4192-bb81-920305ac36c1)

    I have 2 computers in a workgroup. I created shadow accounts on both ("tester"). Test controller service is installed and run as "tester". This user is in all TeamTest... user groups on controller machine.

    Controller machine's name is resolved from another one and is accessible, moreover, I tried adding the computer name in windows hosts, and tried using computer name and ip address with and without port number. I also tried running the test agent configuration tool as "tester" and tried disabling firewall at all. 

    Event details:

    The description for Event ID 0 from source VSTTExecution cannot be found. Either the component that raises this event is not installed on your local computer or the installation is corrupted. You can install or repair the component on the local computer.
    If the event originated on another computer, the display information had to be saved with the event.
    The following information was included with the event: 
    (TestAgentConfigUI.exe, PID 3656, Thread 4) KnownExecutionKeys.GetRemoteControllerUri: machineName is null or empty.
    the message resource is present but the message is not found in the string/message table

    In log it is:

    Creating Channel
    CreateControllerObject : ControllerVersion : 11.0
    CreateControllerObject: attempt 0, System.Net.Sockets.SocketException (0x80004005): No such host is known

    Thanks in advance.

    • Moved by Barry Wang Friday, March 1, 2013 7:12 AM Test related
    Thursday, February 28, 2013 10:11 PM

Answers

All replies

  • Hi lostmsu2,

    Thanks for your post.

    Seems a test issue so I moved it.

    Regards,


    Barry Wang
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Friday, March 1, 2013 7:13 AM
  • Hi lostmsu2,

    Thank you for posting in the MSDN forum.

    If possible, I suggest you enable the Test Controller/Agent logs to find more useful information.

    Two blogs:

    How to enable test controller logs

    How to enable test agent logs

    In addition, this is a guide for VS Test Controller and Agent, it shared us the detailed steps to troubleshoot this issue, so if possible, you could refer it.

    Troubleshooting Guide for Visual Studio Test Controller and Agent

    Best Regards,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, March 4, 2013 6:17 AM
    Moderator
  • Hi,

    Enabling test agent logs doesn't give new information: no files appear in test agent folder.

    I can't find any useful information in the troubleshooting guide, I've read it several times already.

    Can you suggest anything else?

    Tuesday, March 5, 2013 6:18 AM
  • This is full configuration log.

    Configuration started on 2013/03/04, 22:19:34.
    OS Version : Microsoft Windows NT 6.1.7601 Service Pack 1
    Executable version : 11.0.51106.1

    I, 2013/03/04, 22:19:34.305, Listing agent configurations
    I, 2013/03/04, 22:19:34.343, Found that service VSTTAgent is installed and its current status is Stopped
    I, 2013/03/04, 22:19:34.345, Getting the service account of windows service VSTTAgent.
    I, 2013/03/04, 22:19:34.346, display name: Visual Studio Test Agent, serviceStartName:.\tester, for the service VSTTAgent
    I, 2013/03/04, 22:19:34.354, Found that service VSTTAgent is installed and its current status is Stopped
    I, 2013/03/04, 22:19:34.355, GetControllerName : The controller name managed by lab is 
    I, 2013/03/04, 22:19:34.376, IsManagedByLab : lab managed controller name : 
    I, 2013/03/04, 22:19:34.377, GetControllerName : The controller name managed by lab is 
    I, 2013/03/04, 22:19:34.377, GetLabEnvironmentName *** under 
    I, 2013/03/04, 22:19:34.410, Creating Channel
    I, 2013/03/04, 22:19:34.416, IsManagedByLab : lab evironment name : 
    I, 2013/03/04, 22:19:34.420, Initializing UI : Found service already installed with user account
    I, 2013/03/04, 22:19:34.423, NotManagedByLab = True
    I, 2013/03/04, 22:19:48.701, Agent configuration update pack details :
    I, 2013/03/04, 22:19:48.701, Run as interactive process : False
    I, 2013/03/04, 22:19:48.703, User name : tester
    I, 2013/03/04, 22:19:48.703, Change Port : False
    I, 2013/03/04, 22:19:48.703, Chang eService Account : True
    I, 2013/03/04, 22:19:48.703, Change Test Controller : True
    I, 2013/03/04, 22:19:48.703, Test Controller Uri : lost-pc
    I, 2013/03/04, 22:19:48.703, Disable Screensaver : False
    I, 2013/03/04, 22:19:48.703, Enable autologon : False
    I, 2013/03/04, 22:19:48.703, Port : -1
    I, 2013/03/04, 22:19:48.715, Validating user name and password.
    I, 2013/03/04, 22:19:48.719, Validated user name and password.
    I, 2013/03/04, 22:19:48.723, Starting firewall configuration...
    I, 2013/03/04, 22:19:48.745, IsPortExceptionEnabled: Checking for port exception for port 6910 in firewall profile STANDARD
    I, 2013/03/04, 22:19:48.759, IsPortExceptionEnabled: Checking for port exception for port 6910 in firewall profile DOMAIN
    I, 2013/03/04, 22:19:48.769, IsPortExceptionEnabled: Checking for port exception for port 6910 in firewall profile CURRENT
    I, 2013/03/04, 22:19:48.780, BaseConfig: AddFirewallExceptionIfRequired: Firewall exception already enabled for port 6910.
    I, 2013/03/04, 22:19:48.780, No change to the firewall setting as the firewall exception was already enabled for the application 'Microsoft Visual Studio Test Agent Service'.
    I, 2013/03/04, 22:19:48.782, Configured firewall exceptions for: 'Microsoft Visual Studio Test Agent Service'.
    I, 2013/03/04, 22:19:48.783, Enabling Remote Desktop on the machine...
    I, 2013/03/04, 22:19:48.906, No change to the Remote Desktop setting as Remote Desktop was already enabled on the machine.
    I, 2013/03/04, 22:19:48.935, Starting firewall configuration...
    I, 2013/03/04, 22:19:49.057, BaseConfig: AddFirewallExceptionIfRequired: Firewall exception already enabled for service Remote Desktop.
    I, 2013/03/04, 22:19:49.058, No change to the firewall setting as the firewall exception was already enabled for the service 'Remote Desktop'.
    I, 2013/03/04, 22:19:49.058, Configured firewall exceptions for: 'Remote Desktop'.
    I, 2013/03/04, 22:19:49.058, Adding agent setting Microsoft.TeamFoundation.Lab.TestIntegration.AgentVersion=3.0.0 on agent machine
    I, 2013/03/04, 22:19:49.058, Adding agent setting Microsoft.TeamFoundation.Lab.TestIntegration.AgentVersion=3.0.0 on agent machine - 32 bit hive
    I, 2013/03/04, 22:19:49.060, Added agent setting Microsoft.TeamFoundation.Lab.TestIntegration.AgentVersion=3.0.0 on agent machine - 32 bit hive
    I, 2013/03/04, 22:19:49.060, Adding agent setting Microsoft.TeamFoundation.Lab.TestIntegration.AgentVersion=3.0.0 on agent machine - 64 bit hive
    I, 2013/03/04, 22:19:49.060, Added agent setting Microsoft.TeamFoundation.Lab.TestIntegration.AgentVersion=3.0.0 on agent machine - 64 bit hive
    I, 2013/03/04, 22:19:49.076, Adding agent setting NetworkAdapterInfo=485B39C9F395 on agent machine
    I, 2013/03/04, 22:19:49.076, Adding agent setting NetworkAdapterInfo=485B39C9F395 on agent machine - 32 bit hive
    I, 2013/03/04, 22:19:49.076, Added agent setting NetworkAdapterInfo=485B39C9F395 on agent machine - 32 bit hive
    I, 2013/03/04, 22:19:49.076, Adding agent setting NetworkAdapterInfo=485B39C9F395 on agent machine - 64 bit hive
    I, 2013/03/04, 22:19:49.077, Added agent setting NetworkAdapterInfo=485B39C9F395 on agent machine - 64 bit hive
    I, 2013/03/04, 22:19:49.077, Adding agent setting InstallationPath=C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE on agent machine
    I, 2013/03/04, 22:19:49.077, Adding agent setting InstallationPath=C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE on agent machine - 32 bit hive
    I, 2013/03/04, 22:19:49.077, Added agent setting InstallationPath=C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE on agent machine - 32 bit hive
    I, 2013/03/04, 22:19:49.077, Adding agent setting InstallationPath=C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE on agent machine - 64 bit hive
    I, 2013/03/04, 22:19:49.078, Added agent setting InstallationPath=C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE on agent machine - 64 bit hive
    I, 2013/03/04, 22:19:49.079, Creating event sources VSTTAgent 
    I, 2013/03/04, 22:19:49.079, Creating event sources VSTTAgent 
    I, 2013/03/04, 22:19:49.079, Event source VSTTAgent already exists.
    I, 2013/03/04, 22:19:49.079, Creating event sources VSTTAgentProcess 
    I, 2013/03/04, 22:19:49.079, Event source VSTTAgentProcess already exists.
    I, 2013/03/04, 22:19:49.079, Adding event source for event logging
    I, 2013/03/04, 22:19:49.080, ResetForceGuestKey : Getting the value of ForceGuest key
    I, 2013/03/04, 22:19:49.080, ResetForceGuestKey : The value of ForceGuest key is 0
    I, 2013/03/04, 22:19:49.083, Updating the startup registry
    I, 2013/03/04, 22:19:49.083, Removing VSTTAgentProcess from Run registry
    I, 2013/03/04, 22:19:49.084, Starting service configuration...
    I, 2013/03/04, 22:19:49.084, Started checking the status of agent service VSTTAgent.
    I, 2013/03/04, 22:19:49.085, Found that service VSTTAgent is installed and its current status is Stopped
    I, 2013/03/04, 22:19:49.085, Controller service VSTTAgent is already installed, so not doing anything here.
    I, 2013/03/04, 22:19:49.086, Configured service successfully.
    I, 2013/03/04, 22:19:49.086, Setting Tcp Parameters
    V, 2013/03/04, 22:19:49.086, Setting Tcp Parameters in 32bit Hive
    V, 2013/03/04, 22:19:49.087, Setting Tcp Parameters in 32bit Hive completed. 
    V, 2013/03/04, 22:19:49.087, Setting Tcp Parameters in 64bit Hive. 
    V, 2013/03/04, 22:19:49.087, Setting Tcp Parameters in 64bit Hive completed. 
    I, 2013/03/04, 22:19:49.087, Setting Tcp Parameters completed.
    I, 2013/03/04, 22:19:49.089, Registering this test agent with the test controller. This may take few minutes...
    I, 2013/03/04, 22:19:49.089, AgentConfiguration: Starting controller configuration.
    I, 2013/03/04, 22:19:49.089, GetControllerName : The controller name managed by lab is 
    I, 2013/03/04, 22:19:49.090, GetControllerName : The controller name managed by lab is 
    I, 2013/03/04, 22:19:49.090, AgentConfiguration: Found agent is not configured on any controller.
    I, 2013/03/04, 22:19:49.091, Getting information about controller: lost-pc.
    I, 2013/03/04, 22:19:49.091, Creating Channel
    I, 2013/03/04, 22:19:49.107, CreateControllerObject : ControllerVersion : 11.0
    I, 2013/03/04, 22:19:53.626, CreateControllerObject: attempt 0, System.Net.Sockets.SocketException (0x80004005): No such host is known

    Server stack trace: 
       at System.Net.Dns.GetAddrInfo(String name)
       at System.Net.Dns.InternalGetHostByName(String hostName, Boolean includeIPv6)
       at System.Net.Dns.GetHostAddresses(String hostNameOrAddress)
       at System.Runtime.Remoting.Channels.RemoteConnection.CreateNewSocket()
       at System.Runtime.Remoting.Channels.RemoteConnection.GetSocket()
       at System.Runtime.Remoting.Channels.SocketCache.GetSocket(String machinePortAndSid, Boolean openNew)
       at System.Runtime.Remoting.Channels.Tcp.TcpClientTransportSink.SendRequestWithRetry(IMessage msg, ITransportHeaders requestHeaders, Stream requestStream)
       at System.Runtime.Remoting.Channels.Tcp.TcpClientTransportSink.ProcessMessage(IMessage msg, ITransportHeaders requestHeaders, Stream requestStream, ITransportHeaders& responseHeaders, Stream& responseStream)
       at System.Runtime.Remoting.Channels.BinaryClientFormatterSink.SyncProcessMessage(IMessage msg)

    Exception rethrown at [0]: 
       at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
       at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
       at Microsoft.VisualStudio.TestTools.Controller.ControllerObject.Hello()
       at Microsoft.VisualStudio.TestTools.ConfigCore.TestControllerHelper.CreateControllerObject(String controllerUri, NetworkCredential labServiceAccount)
    I, 2013/03/04, 22:19:53.728, CreateControllerObject : ControllerVersion : 11.0
    I, 2013/03/04, 22:19:58.236, CreateControllerObject: attempt 1, System.Net.Sockets.SocketException (0x80004005): No such host is known

    Server stack trace: 
       at System.Net.Dns.GetAddrInfo(String name)
       at System.Net.Dns.InternalGetHostByName(String hostName, Boolean includeIPv6)
       at System.Net.Dns.GetHostAddresses(String hostNameOrAddress)
       at System.Runtime.Remoting.Channels.RemoteConnection.CreateNewSocket()
       at System.Runtime.Remoting.Channels.RemoteConnection.GetSocket()
       at System.Runtime.Remoting.Channels.SocketCache.GetSocket(String machinePortAndSid, Boolean openNew)
       at System.Runtime.Remoting.Channels.Tcp.TcpClientTransportSink.SendRequestWithRetry(IMessage msg, ITransportHeaders requestHeaders, Stream requestStream)
       at System.Runtime.Remoting.Channels.Tcp.TcpClientTransportSink.ProcessMessage(IMessage msg, ITransportHeaders requestHeaders, Stream requestStream, ITransportHeaders& responseHeaders, Stream& responseStream)
       at System.Runtime.Remoting.Channels.BinaryClientFormatterSink.SyncProcessMessage(IMessage msg)

    Exception rethrown at [0]: 
       at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
       at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
       at Microsoft.VisualStudio.TestTools.Controller.ControllerObject.Hello()
       at Microsoft.VisualStudio.TestTools.ConfigCore.TestControllerHelper.CreateControllerObject(String controllerUri, NetworkCredential labServiceAccount)
    I, 2013/03/04, 22:19:58.338, CreateControllerObject : ControllerVersion : 11.0
    I, 2013/03/04, 22:20:02.845, CreateControllerObject: attempt 2, System.Net.Sockets.SocketException (0x80004005): No such host is known

    Server stack trace: 
       at System.Net.Dns.GetAddrInfo(String name)
       at System.Net.Dns.InternalGetHostByName(String hostName, Boolean includeIPv6)
       at System.Net.Dns.GetHostAddresses(String hostNameOrAddress)
       at System.Runtime.Remoting.Channels.RemoteConnection.CreateNewSocket()
       at System.Runtime.Remoting.Channels.RemoteConnection.GetSocket()
       at System.Runtime.Remoting.Channels.SocketCache.GetSocket(String machinePortAndSid, Boolean openNew)
       at System.Runtime.Remoting.Channels.Tcp.TcpClientTransportSink.SendRequestWithRetry(IMessage msg, ITransportHeaders requestHeaders, Stream requestStream)
       at System.Runtime.Remoting.Channels.Tcp.TcpClientTransportSink.ProcessMessage(IMessage msg, ITransportHeaders requestHeaders, Stream requestStream, ITransportHeaders& responseHeaders, Stream& responseStream)
       at System.Runtime.Remoting.Channels.BinaryClientFormatterSink.SyncProcessMessage(IMessage msg)

    Exception rethrown at [0]: 
       at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
       at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
       at Microsoft.VisualStudio.TestTools.Controller.ControllerObject.Hello()
       at Microsoft.VisualStudio.TestTools.ConfigCore.TestControllerHelper.CreateControllerObject(String controllerUri, NetworkCredential labServiceAccount)
    E, 2013/03/04, 22:20:02.946, System.Net.Sockets.SocketException (0x80004005): No such host is known

    Server stack trace: 
       at System.Net.Dns.GetAddrInfo(String name)
       at System.Net.Dns.InternalGetHostByName(String hostName, Boolean includeIPv6)
       at System.Net.Dns.GetHostAddresses(String hostNameOrAddress)
       at System.Runtime.Remoting.Channels.RemoteConnection.CreateNewSocket()
       at System.Runtime.Remoting.Channels.RemoteConnection.GetSocket()
       at System.Runtime.Remoting.Channels.SocketCache.GetSocket(String machinePortAndSid, Boolean openNew)
       at System.Runtime.Remoting.Channels.Tcp.TcpClientTransportSink.SendRequestWithRetry(IMessage msg, ITransportHeaders requestHeaders, Stream requestStream)
       at System.Runtime.Remoting.Channels.Tcp.TcpClientTransportSink.ProcessMessage(IMessage msg, ITransportHeaders requestHeaders, Stream requestStream, ITransportHeaders& responseHeaders, Stream& responseStream)
       at System.Runtime.Remoting.Channels.BinaryClientFormatterSink.SyncProcessMessage(IMessage msg)

    Exception rethrown at [0]: 
       at Microsoft.VisualStudio.TestTools.ConfigCore.TestControllerHelper.CreateControllerObject(String controllerUri, NetworkCredential labServiceAccount)
       at Microsoft.VisualStudio.TestTools.ConfigCore.TestControllerHelper.GetControllerInformation(String controllerUri, NetworkCredential labServiceAccout)
       at Microsoft.VisualStudio.TestTools.ConfigCore.AgentConfiguration.BindToController(String testController, ServiceAccount agentServiceAccount, NetworkCredential labServiceAccount)
       at Microsoft.VisualStudio.TestTools.ConfigCore.AgentConfiguration.HandleControllerChange(AgentConfigurationUpdatePack updatePack, DelegateStatusUpdate statusListener)
    E, 2013/03/04, 22:20:02.948, Failed to register this test agent with the test controller. Connection to the test controller lost-pc failed because either the test controller is inaccessible or the service is not running.
    E, 2013/03/04, 22:20:02.960, Got Exception : Microsoft.VisualStudio.TestTools.ConfigCore.ConfigToolException: Failed to register this test agent with the test controller. Connection to the test controller lost-pc failed because either the test controller is inaccessible or the service is not running. ---> System.Net.Sockets.SocketException: No such host is known

    Server stack trace: 
       at System.Net.Dns.GetAddrInfo(String name)
       at System.Net.Dns.InternalGetHostByName(String hostName, Boolean includeIPv6)
       at System.Net.Dns.GetHostAddresses(String hostNameOrAddress)
       at System.Runtime.Remoting.Channels.RemoteConnection.CreateNewSocket()
       at System.Runtime.Remoting.Channels.RemoteConnection.GetSocket()
       at System.Runtime.Remoting.Channels.SocketCache.GetSocket(String machinePortAndSid, Boolean openNew)
       at System.Runtime.Remoting.Channels.Tcp.TcpClientTransportSink.SendRequestWithRetry(IMessage msg, ITransportHeaders requestHeaders, Stream requestStream)
       at System.Runtime.Remoting.Channels.Tcp.TcpClientTransportSink.ProcessMessage(IMessage msg, ITransportHeaders requestHeaders, Stream requestStream, ITransportHeaders& responseHeaders, Stream& responseStream)
       at System.Runtime.Remoting.Channels.BinaryClientFormatterSink.SyncProcessMessage(IMessage msg)

    Exception rethrown at [0]: 
       at Microsoft.VisualStudio.TestTools.ConfigCore.TestControllerHelper.CreateControllerObject(String controllerUri, NetworkCredential labServiceAccount)
       at Microsoft.VisualStudio.TestTools.ConfigCore.TestControllerHelper.GetControllerInformation(String controllerUri, NetworkCredential labServiceAccout)
       at Microsoft.VisualStudio.TestTools.ConfigCore.AgentConfiguration.BindToController(String testController, ServiceAccount agentServiceAccount, NetworkCredential labServiceAccount)
       at Microsoft.VisualStudio.TestTools.ConfigCore.AgentConfiguration.HandleControllerChange(AgentConfigurationUpdatePack updatePack, DelegateStatusUpdate statusListener)
       --- End of inner exception stack trace ---
       at Microsoft.VisualStudio.TestTools.ConfigCore.AgentConfiguration.HandleControllerChange(AgentConfigurationUpdatePack updatePack, DelegateStatusUpdate statusListener)
       at Microsoft.VisualStudio.TestTools.ConfigCore.AgentConfiguration.Configure(AgentConfigurationUpdatePack updatePack, DelegateStatusUpdate statusListener)
       at Microsoft.VisualStudio.TestTools.AgentConfigUI.AgentConfigUI.ConfigureWorker_DoWork(Object sender, DoWorkEventArgs e)
       at System.ComponentModel.BackgroundWorker.OnDoWork(DoWorkEventArgs e)
       at System.ComponentModel.BackgroundWorker.WorkerThreadStart(Object argument)
    I, 2013/03/04, 22:20:02.961, Work completed for GetConfiguration() call : got out of turn error
    E, 2013/03/04, 22:20:02.962, Failed to register this test agent with the test controller. Connection to the test controller lost-pc failed because either the test controller is inaccessible or the service is not running.

    Tuesday, March 5, 2013 6:21 AM
  • Hi,

    Which Test Agent version are you using, 2010 or 2012? Do you use the port like “MyCtroller:6901” when you configure Test Agent? If you use it, how about removing it like Edwer’s suggestion in this thread? If you don’t use it, maybe you could try to use it.

    Reference:

    Configuring Ports for Test Controllers and Test Agents

    Best Regards,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Wednesday, March 6, 2013 7:19 AM
    Moderator
  • Version 2012
    I tried with and without port numbers. No difference.
    • Edited by lostmsu2 Friday, March 8, 2013 10:04 PM
    Friday, March 8, 2013 9:43 PM
  • Hi,

    To get the issue confirmed and diagnose by product team, would you please create connect report for it? You will get email notification for update.http://connect.microsoft.com/VisualStudio/feedback/CreateFeedback.aspx, if possible, I suggest you share the detailed log message to the product team experts, I think it will be helpful for them to resolve this issue. If you submit the connect report, you could share us the link her, so people who met the same issue could help you vote it. Thanks for your understanding.

    Best Regards,


    Jack Zhai [MSFT]
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Sunday, March 10, 2013 7:24 AM
    Moderator
  • For those who still are looking for an answer, here is my solution. All these steps were executed on the test controller / test manager machine (which is the same machine in my case) :

    1 - I'm not sure if this is related to my problem but this was something I did before the following steps. At some point I've tried to install the VS Agents separately to the test agent machine. It didn't help to solve my problem but I could see to which machine it was being registered. After executing one of the following steps (I can't remember which one) I saw it being registered to a machine name which was on the test controller's hosts file pointing to 127.0.0.1. I've deleted those records from the hosts file. Now the localhost is pointing to 127.0.0.1 and after completing these steps the test agent is being registered to the test controller with the right machine name.

    2 - Since I have two network adapters on the test controller/manager machine, I've added the "bind to" key to the QTControllerConfig.xml file according to this article http://support.microsoft.com/kb/944496/en-us 

    I didn't add it to the QTAgentService.exe.config on the Test Agent and to the QTAgent.exe.config on Test Controller.

    (I don't believe that this step was necessary but it's worth mentioning)

    3 - On the test controller, I've deleted the cache in this directory : C:\Users\username\AppData\Local\Microsoft\Team Foundation\4.0\Cache

    This step does not solve the issue by itself.

    4 - I've deleted the record about a former environment from the file QTControllerConfig.xml which is located at C:\Program Files (x86)\Microsoft Visual Studio 11.0\Common7\IDE.

    After these steps I could finally install the test agent to my virtual machine from the test manager.


    • Edited by enmosarge Friday, October 11, 2013 8:35 AM missing step
    • Proposed as answer by Solozmar Friday, November 20, 2015 8:43 PM
    Friday, October 11, 2013 8:05 AM