none
What cause the fail:"WDTF_SIMPLE_IO : - Open(I2C HID Device ACPI\SMO91D0\1 ) Failed : Device is reporting a problem code (Status Flags=0x1802400 (DN_HAS_PROBLEM DN_DISABLEABLE DN_NT_ENUMERATOR DN_NT_DRIVER) ...." ? RRS feed

  • Question

  • When I run WHCK Test of I2C Controller1: DF - Sleep and PNP (disable and enable) with IO Before and After (Functional), Failed, and there is an error message in Te.wtl log file, part of information as below:

    Process Name: C:\WLK\JobsWorkingDir\Tasks\WTTJobRun43294942-5D8B-4638-8907-0464379DC61C\Te.exe
    Process ID: 1708
    Thread ID: 1284
    Error 7/15/2014 8:15:52.283 PM WDTF_SIMPLE_IO : - Open(I2C HID Device ACPI\SMO91D0\1 ) Failed : Device is reporting a problem code (Status Flags=0x1802400 (DN_HAS_PROBLEM DN_DISABLEABLE DN_NT_ENUMERATOR DN_NT_DRIVER) Problem Code=16 (CM_PROB_DISABLED)) HRESULT=0x80004005
    File: Line: -1
    Error Type:
    Error Code: 0x0
    Error Text: Error 0x00000000
    Error 7/15/2014 8:15:52.283 PM WDTF_SIMPLE_IO : Device Status: Status Flags=0x1802400 (DN_HAS_PROBLEM DN_DISABLEABLE DN_NT_ENUMERATOR DN_NT_DRIVER) Problem Code=16 (CM_PROB_DISABLED)
    File: Line: -1
    Error Type:
    Error Code: 0x0
    Error Text: Error 0x00000000

    The device I2C HID Device (HID:SMO91D0) is under I2C Controller1, I2C driver normal,  but the I2C HID Device driver not ready( Yellow Bang).

    I want to know what cause these fail? I2C Controller1? I2C HID Device (HID:SMO91D0): driver not ready( Yellow Bang)?

    Thank you,

    Trista


    answer to my question of answer file

    Thursday, July 17, 2014 7:08 AM

Answers

  • Hi Trista,

    The yellow bang on your device causing this problem. You have to fix the problem of yellow bang. This test usually checks that after disabling-enabling the driver during SIMPLE IO test, device should come back in ready state. but, in this device is showing yellow bang, so it's not recognizing it's as ready state, which is actually correct and failing the test.

    To verify the device, please install some old driver which is already certified previously, so that you'll come to know where the problem is exactly. Is it a driver or device problem.

    Thanks,

    Mudit

    • Marked as answer by Trista_gao Monday, August 18, 2014 7:21 AM
    Thursday, July 17, 2014 11:36 AM

All replies

  • Hi Trista,

    The yellow bang on your device causing this problem. You have to fix the problem of yellow bang. This test usually checks that after disabling-enabling the driver during SIMPLE IO test, device should come back in ready state. but, in this device is showing yellow bang, so it's not recognizing it's as ready state, which is actually correct and failing the test.

    To verify the device, please install some old driver which is already certified previously, so that you'll come to know where the problem is exactly. Is it a driver or device problem.

    Thanks,

    Mudit

    • Marked as answer by Trista_gao Monday, August 18, 2014 7:21 AM
    Thursday, July 17, 2014 11:36 AM
  • OK, I'll try it again when i get the driver. Thank you very much, Mudit!

    Best Regards,

    Trista


    answer to my question of answer file

    Friday, July 18, 2014 1:31 AM
  • Ok. keep updating :-)
    Friday, July 18, 2014 3:27 AM
  • Yes, the problem was caused by the yellow Bang driver, now the downstream driver is ready,  and the test: DF - Sleep and PNP (disable and enable) with IO Before and After (Functional) and some other related case all passed .

    Thank you very much!

    Best Regards,

    Trista


    answer to my question of answer file

    Monday, August 18, 2014 7:21 AM
  • thanks for the update, trista.
    Tuesday, August 19, 2014 4:14 AM