none
Error The report definition is not valid. rsInvalidReportDefinition RRS feed

  • Question

  • I got this error

    error rsInvalidReportDefinition

    The report definition is not valid.  Details: The report definition has an invalid target namespace 'http://schemas.microsoft.com/sqlserver/reporting/2008/01/reportdefinition' which cannot be upgraded.

    It is in a team project, it works OK on all other machine in my team except mine. So I think there is no error in the code. It happened after another programmer updated one report file from 2005 to 2008 and checked it in. I am using visual studio 2010, SQL server 2008 r2, I have all ReportViewer2005,2008 and 2010 installed in my machine. I have all the version 8,9 and 10 about ReportViewer.Common, ReportViewer.ProcessingObjectModel, ReportViewer.WebForms, ReportViewer.WinForms in GAC. The project is a winform project, so the reference I added in the project is ReportViewer.WinForms version 10.

    I tried reinstall  ReportViewer, not hlep.

    Any suggestions? Thanks

    Monday, January 31, 2011 6:48 PM

All replies

  •  

    Update:  I created a totally new report on my machine, that does not work either, the same error. It looks like something wrong on the settings of my machine. Not sure which part, VS2010, ViewReporter , SQL report server, .Net Frame.... By the way, I reinstalled reportviewer 2008 sp1, not help.

    Any possible reason cause this?

    Tuesday, February 1, 2011 5:48 PM
  • Hi

    I also have this problem. I have VS2010 SP1, SQL Server 2008 R2, Report Viewer 10 and all the V10 dll's. New project using local report and I get:

     

    The report definition is not valid. Details: The report definition has an invalid target namespace 'http://schemas.microsoft.com/sqlserver/reporting/2008/01/reportdefinition' which cannot be upgraded.

     

    Really want this fixed!! Been looking for solution for 4 days now. Stuck.

     


    ChangedDaily
    Tuesday, March 22, 2011 8:15 PM
  • Open the report's RDL file in edit XML mode. Inspect the top line. It should show the version of the RDL as shown here:

    xmlns

     

    ="http://schemas.microsoft.com/sqlserver/reporting/2008/01/reportdefinition">

    This is "3rd generation" (2008) RDL created with the VS 2010 report wizard (or by hand). The report processor in VS2010 can only support 2008 RDL. VS 2008 ReportViewer can only consume (2nd generation) 2005 RDL.

    What version of Visual Studio are you using?


    __________________________________________________________________
    William Vaughn
    Mentor, Consultant, Trainer, MVP
    http://betav.com
    http://betav.com/blog/billva
    http://www.hitchhikerguides.net

    “Hitchhiker’s Guide to Visual Studio and SQL Server (7th Edition)”

    Please click the Mark as Answer button if a post solves your problem!

    Tuesday, March 22, 2011 8:33 PM
    Moderator
  • Hi, not sure who you are asking but I am using:

    VS2010 Professional with SP1

    Report Viewer 10 Redistributable

    SQL Server 2008 R2

    I have checked Microsoft.ReportViewer.WinForms in the project and it is V10.0.0.0.

     

    What else to check?

    Thanks


    ChangedDaily
    Tuesday, March 22, 2011 9:35 PM
  • Hi,

    I have managed to fix the issue I was having by uninstalling Visual Studio 2010 and SP1 and then re-installing both. Note that prior to this I had tried running Visual Studio installation in maintenance mode to re-install but this did not work.

    So, don't know what was wrong or what caused it but removing and re-installing Visual Studio fixed it.

    Thanks

     


    ChangedDaily
    • Proposed as answer by ChangedDaily Wednesday, April 6, 2011 6:57 PM
    Tuesday, March 29, 2011 9:07 AM
  • The version of the SSRS on which the report was created is different from the one your trying it in.

    You can convert the 2008 rdl files to 2005 version

    or

    You can convert the 2008R2 rdl files to 2008 version

    Contact me :- 
    Amar Sale [amarsale(at)gmail(dot).com]

    Regards,
    Amar Sale

    Friday, November 9, 2012 8:53 AM