Git Deploy fails - The process cannot access the file 'file' because it is being used by another process.


  • I've posted a question on SO, but think it may be better suited here.

    For some reason, there is activity on my website which is configured with my domain name, such that during a Git Deploy, the files are still being locked.  The same files deployed to another azure website that is not configured with a domain name works fine.

    Do I need to wait until Azure supports Git deploy while the site is stopped? 

    Monday, March 18, 2013 4:47 AM


All replies

  • Are you sure that the fact that there is a custom domain name makes a difference? It shouldn't. What might make a difference is whether there are active requests coming to the site, and if those requests cause some files to be locked.

    Are the locked files part of the new commit that you're trying to push?

    Monday, March 18, 2013 10:18 PM
  • yes, I don't think its the presence of a custom domain name, but like what you say, some requests coming to the site causing the files to lock.  

    I'm not sure what you mean by "Are the locked files part of the new commit that you're trying to push?"

    The files are the dlls in the App_Data\Dependencies folder and they haven't been updated in any of my commits.  And I'm guessing kudu uses msdeploy to sync the files?

    I've tried stopping the site, deleting the app_data files via ftp, then starting the site, then performing a Git Deploy.  The files are deployed successfully into the app_data folder, but it gives the same error afterwards

    Tuesday, March 19, 2013 3:41 AM
  • I added a reply on SO since you have most of the info on there.
    Tuesday, March 19, 2013 4:07 AM
  • Ok, we resolved this on StackOverflow, so let's close this one here as well :)
    Tuesday, March 19, 2013 4:22 PM