locked
Visual Web Developer 2008 Express freezes when I switch to design view. RRS feed

  • Question

  • User165406575 posted

    When I try to switch to design view of any form, aspx, or html, the entire program freezes and I heave to end task.

    It also freezes if I click Tools, Options, HTML Designer, CSS Styling.

    Any help would be appreciated.

    Tuesday, March 11, 2008 9:57 AM

Answers

  • User165406575 posted

     I found a work-around.

    The link to the Office compatibility problem gave me an idea. This is a new computer that came with Office 2007 preloaded but in order to use it I would have to buy it seperately. Since I have no need for Office, I uninstalled it. It left a folder with a few files in it (Common Files/Microsoft Shared/Office 12).

    I uninstalled VWD 2008 and deleted the Office 12 folder. I then reinstalled VWD 2008, but it still did not work. I then ran the installations for WebDesignerCore, WinSDK, and RDBG(x64) that are in the VWDExpress folder of the installation DVD. Finally, I re-installed the VS90-KB946581 hot fix. Now everything appears to be working.

    Thanks for the help.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, March 13, 2008 3:24 PM

All replies

  • User-694963578 posted

    I have the same problem.  When it freezes, I notice that its using upwards of 200MB of memory in the task list.  The only way I can get out of it is to end task on it.  I'm using Visual Studio 2008 Professional.

    Doesn't anyone at Microsoft test this stuff?

    Tuesday, March 11, 2008 11:27 AM
  • User-694963578 posted

    Doesn't help....  I'm talking about the entire dev envelopment locking up as is the other gentleman.  Not that design view doesn't work or is "broken".  Anyone else experience lock-ups in VS?  If so, have you discovered a fix yet?

    Tuesday, March 11, 2008 12:18 PM
  • User165406575 posted

    Thanks for a quick response. 

    The file fpcutl.dll is only on my hard drive once, at "C:\Program Files (x86)\Microsoft Web Designer Tools\VWD".  The version number is 12.0.4518.1066.  I don't think that is the problem.

    Tuesday, March 11, 2008 12:46 PM
  • User-1363174918 posted

    Try obtaining a dump in task manager (on Vista): when VWD locks up, please open Task Manager, switch to Processes, right click on vwdexpress.exe and choose Create Dump. Make 3-4 of them, zip them into an archive and open a bug on http://connect.microsoft.com

     

    Tuesday, March 11, 2008 12:49 PM
  • User165406575 posted

     I found a work-around.

    The link to the Office compatibility problem gave me an idea. This is a new computer that came with Office 2007 preloaded but in order to use it I would have to buy it seperately. Since I have no need for Office, I uninstalled it. It left a folder with a few files in it (Common Files/Microsoft Shared/Office 12).

    I uninstalled VWD 2008 and deleted the Office 12 folder. I then reinstalled VWD 2008, but it still did not work. I then ran the installations for WebDesignerCore, WinSDK, and RDBG(x64) that are in the VWDExpress folder of the installation DVD. Finally, I re-installed the VS90-KB946581 hot fix. Now everything appears to be working.

    Thanks for the help.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, March 13, 2008 3:24 PM
  • User1968765806 posted

     I have the same issue. It is a new pc with office 2007 pre-installed. I uninstalled it the first day. My design view doesn't work. I don't have any file called fpcutl.dll and the variable 'path' doesn't include anything neither about visual web dev nor about office. I installed the VS90-KB946581 fix and it did not change anything.

    I don't know what to do to solve that bug. Any help is welcome ;-)

    Thanks.
     

    Monday, March 24, 2008 2:05 PM
  • User165406575 posted

    I was able to get it working by:

    1. uninstalling Web Developer Express 2008
    2. deleting the folder "c:\Program Files\Common Files\Microsoft Shared\Office 12" (it may be in "c:\Program Files (x86)\..." on Vista)
    3. re-installing Web Developer Express 2008
    4. install WebDesignerCore from the Web Developer Express 2008 installation media (I downloaded the dvd image and burned it to a dvd)
    5. install WinSDK from the Web Developer Express 2008 installation media.
    6. install RDBG\x64 from the Web Developer Express 2008 installation media.
    7. re-install the VS90-KB946581 hot fix.

    Now Web Developer 2008 Express works great on my computer.

     I hope this helps.

    Monday, March 24, 2008 5:45 PM
  • User1968765806 posted

    Thank you for your reply.
    I am downloading the visual express dvd image to try what you've done. Concerning the uninstall, did you uninstall only vwd or also the three SDK programms?

    Thanks again.
     

    Tuesday, March 25, 2008 2:02 PM
  • User1968765806 posted

     I could not install RDGB since I run on a x32 machine.
    However I did everything else and it works now :-)

    Thanks a lot. 

    Tuesday, March 25, 2008 3:44 PM
  • User165406575 posted

    I'm glad it worked for you also.

    Tuesday, March 25, 2008 3:46 PM
  • User-55569844 posted

    I don't mean to hijack this thread, but I'm having a similar experience with trying to open a web site project in VWD EE 2008 today.

    My scenario is that I copied an existing web site (i.e., "PROJ_1" is now "PROJ_1A" for the purposes of trying VWD EE 2008) and then asked to open "PROJ_1A". The open dialog appear and then (after selecting the apprioriate project directory) NOTHING HAPPENS?

    HUH?

    A few months ago, I tried VWD EE 2008 on a smaller project (for a "taste test") and it worked fine.

    Any suggestions, ideas gratefully accepted. :)   KevInKauai

     [P.S. On a hunch I found the "hotfix" info here and downloaded and updated that. Same results.]

     ==================================================================

    DISPOSITION: Pilot error! (NOTE TO SELF: If the "Solution Explorer" is hidden in a tab and you open a project never before opened in VWD EE 2008 NOTHING will change -- no page references across the top -- and it will look like NOTHING has happened.)

    :) KevInKauai

    Thursday, March 27, 2008 10:49 PM
  • User1647658757 posted

    I have the same problem with Visual Studio 2008 on Vista Business. I have tried to uninstall and reinstall, aply the patches, checked the system PATH but no success.

    I have noticed when I click the Design or Split button in the web designer window, VS seems to run a setup.exe from the "C:\Program Files\Common Files\microsoft shared\OFFICE12\Office Setup Controller" directory. This process appears in task manager, takes  2804kB and seems to do nothing else. I have managed to locate the log file from this setup application:

    PERF: TickCount=2132440 Name=OBootStrapper::Run Description=Begin function
    Operating System version: 6.0.6000 . Platform ID: 2
    Running on a 32-bit operating system.
    Command line: C:\PROGRA~1\COMMON~1\MICROS~1\OFFICE12\OFFICE~1\SETUP.EXE -Embedding
    Parsing command line.
    Running SETUPEXE as a COM server.
    Using setup controller dll at location [C:\Users\Dlouhy.TCL\AppData\Local\Temp\Setup00001054\OSETUP.DLL].
    Verify file signature in "C:\PROGRA~1\COMMON~1\MICROS~1\OFFICE12\OFFICE~1\SETUP.EXE"
    Verify file signature in "C:\Users\Dlouhy.TCL\AppData\Local\Temp\Setup00001054\OSETUP.DLL"
    Using setup controller dll at [C:\Users\Dlouhy.TCL\AppData\Local\Temp\Setup00001054\OSETUP.DLL].
    PERF: TickCount=2133875 Name=OBootStrapper::Run Description=Calling RunSetup
    Opening log file C:\Users\Dlouhy.TCL\AppData\Local\Temp\SetupExe(200803311419401054).log.

    Does someone have any idea what that means or how to solve the problem?

    Monday, March 31, 2008 8:53 AM
  • User165406575 posted

    I would try these two things, in this order.

    First, run the setup.exe in the "C:\Program Files\Common Files\microsoft shared\OFFICE12\Office Setup Controller" directory by right-clicking on it and pick "Run as Administrator". 

    If that doesn't fix the problem, rename the file to "setup.exe.bak" and hopefully it will not run.

     

    Monday, March 31, 2008 10:29 AM
  • User1647658757 posted

    Thanks,

    i tried to run the setup with no results. After renaming the setup file the designer seems to work ok.

    Monday, March 31, 2008 3:50 PM
  • User1065390909 posted

    When I write persian (Farsi) text in to my code and I want to switch to design view , My VWD restarted. I Use the Vista Ultimate. What's the problem ?

    Thursday, April 17, 2008 3:26 PM
  • User-1420361370 posted

    Thank you phopper for this FIX. 

    Before doing the phopper-fix, my VWD freeze (s) when aspx is placed into design-mode -- as the topic of this thread is all about.
    My system (WinXP SP2 laptop) worked fine before 5/10/08 -- and froze VWD in design-mode (yesterday) when I resumed web work after about 3-weeks (since 5/10/08) without running VWD.
    I installed WinXP SP3 upgrade and the VWD was still freezing in design mode.
    I researched this aspx-freeze problem and found the above quoted thread from phopper.

    I followed these steps.
    1) rebooted and let the system settle down to no disk-activity.
    2) ran (double-clicked) the setup.exe in the "C:\Program Files\Common Files\microsoft shared\OFFICE12\Office Setup Controller" directory as instructed and the setup.exe brought up a dialog that offered 'Repair' option. 
    3) I selected the repair option and watched the progress bar move for about 5-8 minutes.
    4) When completed (with success), I closed the setup and opened VWD to a one-page web-project with only a single textbox on an otherwise empty page (except for <div>).
    5) I switched to design-mode on the aspx file and IT WORKED.
    6) I closed the simple-project and opened my complex web-site project and tried design-mode on the edit-customer-aspx-page and IT WORKED.

    I think a corruption occurred and running the setup as noted by phopper in repair-option fixed the corruption.

    Good luck to all and many thanks to phopper.
    Thanks...John

     

    Monday, June 2, 2008 9:01 PM
  • User2129008437 posted

    Thank you for this post!

    Was having same problem where VWDE 2008 freezes when opening any ASPX page.

    After full day of removing & reinstalling components this finally worked for me.  Wish I had found it sooner!

    Notes: Repair only took about 20 secs to run on my system.  Did not reboot before or after.

    - Scott.

     

     

    Tuesday, July 14, 2009 12:26 PM
  • User2129008437 posted

     OK - I spoke too soon...  VWDE still freezes in design mode, it just took longer this time.

    Instead, I renamed the Setup.exe file as suggested earlier in this post and that seems to be working now.  Not wild about renaming an 'exe' as it will probably cause problems somewhere else...

    - Scott. 

    Tuesday, July 14, 2009 2:18 PM
  • User2050844374 posted

    Hi, I wanted to post that I got to this step, and when i ran the Office Setup Controller setup file, I selected the repair option.  I was able to view the design view afterwards.  My vwde2008 was also freezing a lot prior to this fix, and I think the fix has addressed the freezing as well.

    I wanted to point out I could not install the VS90-KB946581 hotfix as this setup file was not in the vwde dvd.  I found the hotfix online, and when I tried to install it, I got the message that the hotfix did not apply to any of the programs I have installed.  Strange...

    I am using an ASUS laptop with win7, it also had office 2007 trial installed on it.  I got rid of it and installed office 2003 pro.  Actually it seemed like all these problems started after getting rid of 2007 and putting in 2003.  I'm glad i got this issue taken care of finally.

    Thursday, February 25, 2010 3:47 PM
  • User-1363174918 posted

    KB946581 applies to stock RTM version (see file versions mentioned: 9.0.21022.* means RTM, SP1 would be 9.0.30729.*).  KB946581 is included in SP1 and current download of VWDE is with SP1 applied hence you don't need KB946581. Various post-SP1 fixes are available here https://connect.microsoft.com/VisualStudio/Downloads

    Thursday, February 25, 2010 4:44 PM
  • User1769983110 posted

    Thanks Phil Hopper.  I followed the steps you outlined - removed office12, re-installed vwd and applied the hotfix.  vwd does not freeze when I switch to design mode.  

    Neeta

    Friday, March 5, 2010 3:13 PM
  • User1944846137 posted

    I had the same problem and following your steps would indeed solve the problem. However, most of the steps that you outlined are not required. Just the mere deletion of the [Program Files]\Common Files\microsoft shared\OFFICE12\Office Setup Controller\Setup.exe file or its renaming would solve the problem. Nothing needs to be downloaded or reinstalled to address this particular issue. However, your solution did help me to pin point the root cause.


    Saturday, March 6, 2010 2:06 PM
  • User165406575 posted

    It looks like there may be two different problems that cause VWD 2008 Express to freeze in design view.  When I originally had the problem, renaming setup.exe was not a part of the solution at all.  A later post suggested the renaming as a solution to a slightly different set of symptoms.

    Saturday, March 6, 2010 2:25 PM
  • User-1363174918 posted

    Have a look of this KB http://support.microsoft.com/?kbid=2022915

    Most issues boil down to missing or improperly registered MSXML5, mostly related to x64 machines. 

    Monday, April 12, 2010 1:07 PM
  • User831230609 posted

    Hello, Mikhail


    I have similar problem with Microsoft Wisual Web Developer 2008 Express Editon on Windows XP. Designer of .aspx does not work. When I click 'View Designer' on .aspx page it nothing happens. After double click on the page I see only black HTML code. I have not toolbox-items when a page is open (aspx or html). The tabs for split view and design-view are absent.

    I tried all of this and other posts:

    http://forums.asp.net/t/1186584.aspx?PageIndex=2

    http://forums.asp.net/t/1354411.aspx

    http://forums.asp.net/p/1194475/2061103.aspx

    http://blogs.msdn.com/webdevtools/archive/2008/10/03/troubleshooting-visual-studion-2008-design-view-hangs-issues.aspx

    but it does not work.

    Could you help me?


    Best regards, Andrew Shyliuk



    Tuesday, May 11, 2010 10:12 AM
  • User-1363174918 posted

    Have a look here http://forums.asp.net/t/1550899.aspx - in short, try repairing Web Authoring Component in control panel.

    Friday, May 14, 2010 5:35 PM
  • User-885658940 posted

    Hey guys, I was having this same problem (a hidden modal dialog keeping me from interacting with the IDE) but with Visual Studio 2008 SP1.  I was able to produce the problem by either opening an .aspx file, or by clicking on "CSS Styling" under Tools --> Options --> HTML Designer.

    This started happening after I uninstalled Office 2007 and installed Office 2010.  I also noticed "setup.exe" running in Task Manager.  In windows 7 you can right-click on it and go to the file location.  After killing the devenv.exe and setup.exe processes, I started setup.exe up again and an Office 2007 splash screen appears -- ah hah!! -- asking me if I wanted to Repair or Remove the Visual Studio Web Designer tool and I chose to Remove it.  That solved my problem.

    It seems as if the Office 2007 uninstall algorithm detected my Visual Studio installation and decided to leave those components on my computer.  Can't figure out why VS2008 kept trying to run the setup though.  Very odd.  There must be another switch in Windows that says "office is not installed" so it decided to run that setup program again.

    Well it's obviously a bug, so let's hope Microsoft issues a hotfix for it ASAP!

    Saturday, July 17, 2010 1:42 AM
  • User-1363174918 posted

    Several gory details... Smile on how all this works (or doesn't).

    First, Microsoft Web Authoring Component is Office 2007 component that uses Office setup. Removing Office does not remove the component since component is not part of Office box. Similarly, removing Office does not necessarily uninstall SharePoint Designer or Vizio.

    However, all Office-based applications share certain key elements which remain on the machine until the last component that is using particular binary is uninstalled. This is called reference counting.

    The problem is in MSXML5 that get incorrectly removed when Office 2007 is uninstalled on x64 OS even when there is another application (Microsoft Web Authoring Component) that still needs it (this is very subtle bug in MSXML5 type library registration). The issue is generally not a problem for Office apps since Office has self-repairing installtion and when Office detects that certain component is missing it just goes ahead and silently repairs it or asks you to insert media CD and reinstalls the missing piece. However, Visual Studio does not support self-repair. So what ends up happening is that Microsoft Web Authoring Component detects missing MSXML5 and asks its host process (Visual Studio or Visual Web Developer) to reinstall it - but neither is able to do it so the process never completes and the main application hangs.

    And yes, fix is in works (it is in Office 2007 setup).

    BTW, removing Microsoft Web Authoring Component will effective disable design view.

     

    Monday, July 19, 2010 4:37 PM
  • User-192046744 posted

    This works for me:
    Right Button at Visual Studio -> Compatibility -> Run this program... Windows Vista

    :D

    Monday, August 9, 2010 11:05 PM
  • User84047913 posted

    Wow, what a simple fix. I was getting the same problem - i.e. VS2008 appears to hang when trying to view an .aspx page in design view, except in my case, I found that closing the page would actually close it despite giving the appearance of being hung. I could then reopen it but again the "hang" on trying to switch to design view persisted. However, VS2008 would crash when finally exiting.

    I tried ruinning a repair on the VS Web Authoring component as previously suggested on this thread but that didn't work either.

    As this instance of VS2008 was running on Windows Server Std 2007, I didn't have the option of running VS in Vista compatability mode, but I did have the option of running in XP SP2 compatibility mode. Just for good measure I ticked the run as Admin as well.

    Problem solved. Many thanks for the solution murilloab.

    Thursday, September 9, 2010 3:37 PM
  • User1750192879 posted

    I have had this problem for months.  I went to the MSDN blog below, and found that I did not have Microsoft Visual Studio Web Authoring Component installed.  Under the section called "How to install Web Authoring Component manually", I followed the installation instructions.  The installation took much longer than the post suggested.  I could hear the DVD churning for about 20 minutes, and then I got a prompt to let the WebDesignerCore.exe make changes, which I accepted, and then it completed in a few seconds.  When I went back to the Control Panel / Programs & Features and refreshed, it was there.  Then, when I opened up VS 2008, I was able to switch to Design View!!

    http://blogs.msdn.com/b/webdev/archive/2008/10/03/troubleshooting-visual-studion-2008-design-view-hangs-issues.aspx

    Tuesday, January 7, 2014 2:44 PM