none
Empty Project Menu For New Solution In VS2010

    Question

  • Developing on Win 8.1 with VS2010.

    Yea, I know VS2010 is old, but it's what I have for now.

    I'd like my Project drop down menus to look something like this:

    This allows me to add or create a source file, among other things.

    Too often, though not all the time for some reason, after creating a new solution I get this when I want to start writing code for a new project:

    Why aren't I looking at a useful Project menu?

    Hitting "Rescan Solution" seems to do nothing.

    I've copied some C++ files into the folder, which I'll edit for this project:

    Why can't I get the Project menu to display "Add Existing Item"?

    What am I doing wrong?

    Thanks
    Larry

    Sunday, March 13, 2016 9:38 PM

Answers

All replies

  • Hi Larry,

    Is this problem occurs randomly?

    Please create a new default project without any custom code and then check the Project menu, whether there still empty?

    If the default project doesn't have this issue, please check your project whether there has any compiler error which lead to your solution not loaded correctly.

    If there has no error, please try delete the .suo file and clear your solution to rebuild it. Then please copy the C++ files into the folder one by one to make sure which file causes this issue.

    If default project also has this issue, please try with below steps to troubleshoot this issue.

    1. Please check whether have installed sp1 for your Visual Studio 2010.
    2. Run Visual Studio in safe mode with "Deven.exe /SafeMode" command to prevents all third-party VSPackages from loading when Visual Studio starts, thus ensuring stable execution.
    3. Close all third part software when running Visual Studio.

    In addition, please right-click your project when the Project menu is empty, whether the Add options in right-click context menu also empty.

    If just the Project menu is empty, please right-click the Project menu to choose Customize option to check whether all options are added to this menu. If options not listed in Controls list, please click the Add Command button to add them.

     

    Best Regards,
    Weiwei

    Monday, March 14, 2016 8:34 AM
    Moderator
  • Thanks Weiwei:

       When I checked for updates I was surprised to see there was an indication that SP1 had not yet been applied.  I've used this machine for a couple of years and I thought I'd installed SP1 when I moved VS 2010 over to this PC. 

       I got an error when I tried to install SP1 so I uninstalled VS 2010 and did a clean install. 

       The install of VS 2010 went well, but the update failed again:

    "Get More Info" displays this:

    Here are the two links:

    Error 643

    Error 13EC

    I'm not getting much from these links.

    Money is tight right now.  Is it time to accept that VS 2010 just isn't supported anymore and move on? 

    Thanks
    Larry


    Wednesday, March 16, 2016 2:29 PM
  • Hi Larry,

    According to your screenshot, you installing the sp1 from Windows Update, is it right?

    Please download and install Visual Studio 2010 sp1 from below official site and run the installer as administrator.

    https://www.microsoft.com/en-us/download/details.aspx?id=23691

    >>Money is tight right now.  Is it time to accept that VS 2010 just isn't supported and move on? 

    Based on the Visual Studio 2010 life cycle, it is supported to 7/14/2015. So I suggest you update your Visual Studio to version 2015. The Visual Studio Community 2015 is a free, fully featured, and extensible IDE for individual developers, open source projects, academic research, education, and small professional teams. You can get it from below link.

    https://www.visualstudio.com/en-us/downloads/download-visual-studio-vs.aspx

    Best Regards,
    Weiwei

    Thursday, March 17, 2016 1:21 AM
    Moderator
  • Thanks Weiwei Cai:

       I thought the community editions were "toy" development systems that were missing important tools.  I didn't realize they were fully featured development environments licensed to individual developers, which I am. 

       I've downloaded the VS 2015 community edition, which converted my current project. 

       Now I'm seeing "fatal error C1083: Cannot open include file: 'windows.h':" errors. 

       I'm marking this thread as solved, because I think you did solve my problem, I just need to do some digging to get everything converted. 

       I'll do some Google queries and ask questions in your Visual Studio General Questions forum. 

          Thanks again
          Larry

    Wednesday, March 23, 2016 10:58 PM