locked
Error message: Could not load file or assembly 'System.EnterpriseServices....... RRS feed

  • Question

  • User408950079 posted

    I get the following error message when I am debugging a site:

    Could not load file or assembly 'System.EnterpriseServices, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. Systemet could not find the file.

    I have tried to reinstall VS 2005 express twice, but with the same result.

    Do anyone have a tip what to do?

    Monday, January 23, 2006 6:07 AM

All replies

  • User1075342052 posted
    Most probably you have a different version of the System.EnterpriseServices assembly in the global cache. Or you don't have it at all.
    You need to add the 2.0.0.0 version to the GAC.
    In order to do that just drag the file at
    "<windows_directory>\Microsoft.NET\Framework\v2.0<your_subversion>\System.EnterpriseServices.dll"
    to the "<windows_directory>\assembly\" folder.

    Before that just check the properties of the file to be sure it has the appropriate version number.

    Wednesday, February 8, 2006 6:53 AM
  • User1618103024 posted
    OMGoodness; you just saved me the worst headache and temperfit.  Thanks :)
    Thursday, February 1, 2007 3:42 PM
  • User2087990801 posted

    I too am experiencing a similar problem; I've been using an automated friend adding program for myspace and one day I went to extract a page and I recieved this message:

    The system cannot find the file specified. (Exception from HRESULT: 0x80070002)

    I was given the option of either ending the program entirely, ignoring the message, or viewing the details of the error. While I cannot recall at this point the details of the message, I do recall that enabling JIT debugging was mentioned (as a matter of fact, I've had similar error messages in the past). what does all of this mean? Is there a way for me to aleviate this problem from my computer?

    I was told to do just what you'd said in this previous post, but it didn't quite work for me...is there anything that can be done?

     

    ===============================

    Saturday, August 4, 2007 8:54 AM
  • User-2065704428 posted

    I see this item was posted 2 years ago or more. Hopefully a reply can be still given.

     I am having the same problem with this stupid System.EnterpriseServices.dll just like the other person did. And just like him I too did nothing to bring this albatross into my application other than maybe install a service pak or other upgrade.

     I attempted to resolve my problem as you instructed above but when i tried the file was rejected from being copied listing the error below:

     "System.EnterpriseServices.dll - cannot find the specified file"

     I had it in my bin file and the application was operating fine until I tried to open the ASP.NET Configuration utility. When the System.EnterpriseServices.dll was in the bin file and I tried to use the Config Utility I get the error below:

    "Server Error in '/asp.netwebadminfiles' Application."

    Configuration Error

    Description: An error occurred during the processing of a configuration file required to service this request. Please review the specific error details below and modify your configuration file appropriately.

    Parser Error Message: Could not load file or assembly 'System.EnterpriseServices, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.

    Source Error:

    Line 50:         <add assembly="System.Xml, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089"/>
    Line 51:         <add assembly="System.Drawing, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>
    Line 52:         <add assembly="System.EnterpriseServices, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>
    Line 53:         <add assembly="System.Web.Mobile, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>
    Line 54:         <add assembly="*"/>


    Source File: c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Config\web.config    Line: 52

    Assembly Load Trace: The following information can be helpful to determine why the assembly 'System.EnterpriseServices, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' could not be loaded.

    What to do?

     

    Philip

    Thursday, July 17, 2008 1:37 PM
  • User925297766 posted

    If this is a x64 bit server, the dll in the assembly cache might be 64-bit, while your app is executing in a 32-bit mode (it's compiled for x86)

    In that case you need to copy the 32 bit version of 'System.EnterpriseServices.dll' and 'System.EnterpriseServices.Wrapper.dll' from

    C:\Windows\Microsoft.NET\Framework\v2.0.50727  to your application or bin folder

    Note: ..\Framework\... and NOT  ..\Framework64\..

    Regards

    Johan

    Thursday, October 8, 2009 4:22 AM
  • User1883879157 posted

    Hi

    I already have the System.EnterpriseServices.dll in GAC for both .NET versions 32 and 64. But when i try to view any .NET application, it is giving error "Could not load file or assembly System.EnterpriseServices version 2.0.0.0, culture = neutral, ..." or one of its dependencies. The system  cannot find the file specified

    Any ideas!!

    Thanks in advance

    Tuesday, December 1, 2009 10:15 AM
  • User-1000605453 posted

    Hi, I had a similiar problem and I uninstall all my dot net frameworks and just installed the .Net 3.5 SP1. This solved my problem.

     

    I have a problem of my own. I have a web app that uses Enterprise Lib 3.1.0.0 the site works fine, until i update it and then it starts asking for entlib 4.1.0.0. When i change the web.config and the actual lib files to 4.1.0.0, the application then asks for 3.1.0.0 again! It's like the application is asking for both versions but can only accept one. I have searched the web and also read Tom Hollander's blog and it does not say anything about this specific problem.

     

    Please help.

    Thanks,

    JK.

    Wednesday, December 2, 2009 9:23 AM