none
i can't install the .net framework 4.0 RRS feed

  • Question

  • i tried to install 3dsmax 2013 but during the install process it told me to install microsoft .net framework 4.0(which i already have), i tried the step detailed on this page

    http://social.msdn.microsoft.com/Forums/en/netfxsetup/thread/20912798-2d00-488a-9a24-1dbb61eaee3f

    but .net 4.0 still gives me an error after the install process, this are the details of the installation log

    OS Version = 6.1.7600, Platform 2
    OS Description = Windows 7 - x64 Ultimate Edition
    CommandLine = E:\2285750d0d9ccc2d2db342\\Setup.exe /x86 /x64
    Using Simultaneous Download and Install mechanism
    Operation: Installing
    Package Name = Microsoft .NET Framework 4 Setup
    Package Version = 4.0.30319
    User Experience Data Collection Policy: Disabled
    Number of applicable items: 11
    Exe (E:\2285750d0d9ccc2d2db342\SetupUtility.exe) succeeded.
    Exe Log File: dd_SetupUtility.txt
    ServiceControl operation succeeded!
    ServiceControl operation succeeded!
    Exe (E:\2285750d0d9ccc2d2db342\Windows6.1-KB958488-v6001-x64.msu) failed with 0xc8000222 - (null).
    Final Result: Installation failed with error code: (0xC8000222) (Elapsed time: 0 00:00:11).

    please help.

    Thursday, October 24, 2013 1:43 PM

Answers

  • The error you cite, "failed with 0xc8000222 - (null)." always indicates that the OS is not up to date.

    I see "OS Version = 6.1.7600, Platform 2", indicating that you have not applied SP1 for Windows 7.

    Please update your OS with SP1 and subsequent updates, then retry the .NET 4.0 install.


    • Marked as answer by kkbass Tuesday, October 29, 2013 11:24 AM
    • Edited by pvdg42 Friday, November 1, 2013 3:39 PM
    Thursday, October 24, 2013 2:16 PM