locked
ADO.NET Data Services published on 3rd party host. RRS feed

  • Question

  •  

    After first publishing my working ADO.NET data service on a hosting service I got the message:

    This collection already contains an address with scheme http.  There can be at most one address per scheme in this collection.

     

    Having experience with WCF Services on the host, I first tried to override (like I had to with ServiceHostFactory) DataServiceHostFactory with:

     

    Code Snippet

     

    class CustomDataServiceHostFactory : DataServiceHostFactory

    {

    protected override ServiceHost CreateServiceHost(Type serviceType, Uri[] baseAddresses)

    {

    return new DataServiceHost(serviceType, new Uri[] {baseAddresses[0]});

    }

    }

     

     

    and in my .SVC file put:

     

    Code Snippet
    Factory
    ="[OurNameSpace].CustomDataServiceHostFactory"

     

     

     

    But then I get

    Service '[OurNameSpace].DataModel' has zero application (non-infrastructure) endpoints. This might be because no configuration file was found for your application, or because no service element matching the service name could be found in the configuration file, or because no endpoints were defined in the service element.

     

    I then tried, without success, to add random junk that looked like it should work to app.config for the endpoints, but that didn't work, so I revered it all back to how I had it originally and tried in app.config:

     

    Code Snippet

    <serviceHostingEnvironment aspNetCompatibilityEnabled="true">

    <baseAddressPrefixFilters>

    <add prefix="http://mydomain.com"/>

    </baseAddressPrefixFilters>

    </serviceHostingEnvironment>

     

    Woohoo, the furthest I've gotten, but then I get:

     

    IIS specified authentication schemes 'Basic, Anonymous', but the binding only supports specification of exactly one authentication scheme. Valid authentication schemes are Digest, Negotiate, NTLM, Basic, or Anonymous. Change the IIS settings so that only a single authentication scheme is used.

     

    I don't have access to these settings through my 3rd party web host.  So, what's next?

    Monday, October 6, 2008 12:11 AM

Answers

  • Ok, my hosting provider provides access to IIS 7.0 control panel so I was able to get rid of all but one of the authentications.  It works!!!!!!!!!
    Monday, October 6, 2008 12:41 AM