locked
Visual Studio 2013. You do not have sufficient privilege to access IIS web sites on your machine RRS feed

  • Question

  • User422038134 posted

    error : Creation of the virtual directory localhost:xxxxx failed with the error: Unable to access the IIS metabase. You do not have sufficient privilege to access IIS web sites on your machine

    I am getting the above error while loading web project in visual studio 2013. 

    Please help!

    Wednesday, May 7, 2014 2:54 PM

Answers

  • User422038134 posted

    I found the solution for this. It was My documents folder.

    My documents folder should be on your system and not on a network drive and give access to \IISExpress\config folder.

    I had to uninstall everything and then followed the below steps.

    1. Install IIS express

    2. Install VS 2013

    3. Install VS2013 service pack1

    4. Install VS2013 service pack2

    It works finally :) Thank you all for your replies.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, May 8, 2014 11:22 AM

All replies

  • User-718146471 posted

    Take a look at this thread on stack overflow, they have some useful tips that may resolve this: http://stackoverflow.com/questions/12859891/error-unable-to-access-the-iis-metabase

    Wednesday, May 7, 2014 3:00 PM
  • User422038134 posted

    Tried all the things mentioned in the thread..still doesnt work.

    Wednesday, May 7, 2014 4:16 PM
  • User-1454326058 posted

    Hi,

    Do you get the error if you create a new web site project in VS?

    On the other hand, please try to repair the VS.

    Thanks

    Best Regards     

    Thursday, May 8, 2014 3:43 AM
  • User422038134 posted

    Yes i get it when i create a new website or open an existing website.

    I tried reinstalling VS2013. Still not working.  I guess the issue might be with IIS.

    Thursday, May 8, 2014 9:56 AM
  • User422038134 posted

    I found the solution for this. It was My documents folder.

    My documents folder should be on your system and not on a network drive and give access to \IISExpress\config folder.

    I had to uninstall everything and then followed the below steps.

    1. Install IIS express

    2. Install VS 2013

    3. Install VS2013 service pack1

    4. Install VS2013 service pack2

    It works finally :) Thank you all for your replies.

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Thursday, May 8, 2014 11:22 AM