locked
HTTP Source using TLS 1.2 RRS feed

  • Question

  • I want to download files from https://www2.census.gov/programs-surveys/acs/data/pums/2001/ to my Azure Data Lake store.

    I used the Data Factory wizard and got the following error:

    Copy activity encountered a user error at Source side:

    ErrorCode=UserErrorFailedToReadHttpFile,

    'Type=Microsoft.DataTransfer.Common.Shared.HybridDeliveryException,

    Message=Failed to read data from http source file.,Source=Microsoft.DataTransfer.ClientLibrary

    ,''Type=System.Net.WebException

    ,Message=The request was aborted: Could not create SSL/TLS secure channel.,Source=System,'.

    This is very similar to the error that I got using Powershell downloading this same files.  The work around was to set the security protocol to TLS 1.2, as mentioned toward the bottom of the following article.

    https://windowsserver.uservoice.com/forums/301869-powershell/suggestions/15150051-add-support-for-tls-1-2-invoke-webrequest-invoke

    My question.  Is there a property that I can set to help the HTTP Linked service to use TLS 1.2 to connect?


    Russel Loski, MCSE Data Platform/Business Intelligence Twitter: @sqlmovers; blog: www.sqlmovers.com

    Wednesday, August 9, 2017 7:33 PM

All replies

  • I am receiving the same error on of my copy activity. not sure how to set up linked service for https connection

    https://sometoken:x@api.mydomain.com/....


    Thursday, August 24, 2017 12:02 PM
  • Same issue for me. I tried putting the property into the additional properties allowable in the input data set for the linked service and that also did not resolve the issue.

    Update 20171207 - our workaround was to set up a proxy...

    • Edited by Tom Harmon Thursday, December 7, 2017 9:52 PM
    Thursday, November 30, 2017 10:56 PM
  • Tom, I just saw this.  Did you set up a proxy on the server or on the data factory?  If it is on the data factory, is there a walk through for this process?

    Russel Loski, MCSE Data Platform/Business Intelligence Twitter: @sqlmovers; blog: www.sqlmovers.com

    Friday, December 29, 2017 3:02 PM