locked
Smart Card authentication is designed to be skipped after the 'Cancel' button is clicked from the popped up certificate selection dialog?

    Question

  • Hello, Dear all,

    Currently I encountered an issue: a server is configured to use smart card authentication optionally and I could access the server via IE on a Win8 Pro with all smart card environment ready to use.

    Given the server address is smartcard.server.com, then if I access https://smartcard.server.com from IE10 then the certificate selection dialog will be popped up. However, if I click the 'Cancel' button, then the dialog will not be popped up if I access the address in the same tab or other newly tabs. And if I open a new IE window without closing the current IE window, the dialog will still not be popped up. I have to close the old window and use a new IE window to make the dialog pop up again.

    Is this behavior designed to this? Or I missed something? Is there any setting that I could do to let it pop up, such as clearing the cache?

    Thank you very much.

    Tuesday, May 7, 2013 11:25 AM

All replies

  • Is this an IE question or a Windows Store app question? For IE, you can try to "Clear SSL State" and check if that resolves your problem. The button is present here: Internet Options -> Content -> Clear SSL State (under Certificates).

    Thanks,

    Prashant.


    @prashantphadke || Windows Store Developer Solutions #WSDevSol || Want more solutions? See our blog, Windows Store & Phone Developer Solutions

    Wednesday, May 15, 2013 10:45 PM
    Moderator
  • Hi, Prashant,

    With the operations you mentioned, the issue could be reproduced, but not every time. I tried for more than 15 times. Sometimes the certificate selection dialog will be popped up, while other times it couldn't. But I haven't found a rule to make the dialog pop up each time, or not pop up each time.

    Thank you very much.

    Tuesday, May 21, 2013 7:31 AM