locked
Visual Studio 2015 CTP 5 could not debug Windows Store Apps

    Question

  •  I used Visual Studio 2015 CTP 5 (

    14.0.22512.0.DP) 
    to create an blank Universal app and run the app by clicking on the Local Machine or the Simulator, It returns an Error: 

    Unable to activate Windows Store app '4b942f4c-9dd2-4cad-bb64-e18590b1b267_zebk0zv3aayar!App'. The activation request failed with error ‘The app didn’t start’.

    Then I opened the Event Viewer and saw an Error:

    The server HubApp1.App did not register with DCOM within the required timeout.

    If I right click the solution and choose deploy solution, then run the app from the windows 8 menu, the app can run well without any error.

    It means I could debug any windows store apps.

    Is there any solution for this?... Please Help!

    Monday, February 2, 2015 10:57 AM

Answers

All replies

  • Hi Lionel_Fang,

    >>Unable to activate Windows Store app '4b942f4c-9dd2-4cad-bb64-e18590b1b267_zebk0zv3aayar!App'. The activation request failed with error ‘The app didn’t start’.

    (a)Did you install the NuGet Package before?

    Based on the error message, I found a similar thread which was related to the App. config file:

    https://social.msdn.microsoft.com/Forums/windowsapps/en-US/39e9dfb0-f736-4392-bcbf-8b4974ca0eb0/unable-to-active-windows-store-app-the-app-didnt-start-win8nl-package?forum=winappswithcsharp

    (b)Please also make sure that your project saved in your local disk, for example, the default project path is in C:\Users\xxx\Documents\Visual Studio 2015\Projects. Or you could move it to other folder in D disk or others, test it again.

    Actually I could debug a simple sample Universal app in my side using the same version as yours like the following screen shot, whether other projects still have this issue like Windows or Windows Phone apps? If above steps no help, refer to the following steps.

    (1)    To make sure that it is not the account issue, please run your VS as the admin.

    (2)    Please make sure that you could view the UI in designer mode if you double click the .xaml file.

    (3)    Please close all third party tools in your Windows like Anti-virus software or others, to make sure that it is not the add-ins or extension tools’ issue, please run your VS in safe mode: https://msdn.microsoft.com/en-us/library/ms241278.aspx.

    (4)    To make sure that it is not the VS IDE issue, I suggest you reset your VS settings: https://msdn.microsoft.com/en-us/library/ms247075(v=vs.100).aspx, and then you can create a new project in a new workspace to avoid if there’re any problems of the old workspace settings.

    (5)    If still no help, I suggest you repair your VS from the control panel, create a new project, test it again.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.


    Tuesday, February 3, 2015 6:13 AM
    Moderator
  • Thanks for your reply.

    I have tried all the method you mentioned.

    But unfortunately, no one way could solve this issue.

    My visual studio 2015 works well for other WCF and WinForm projects.

    Wednesday, February 4, 2015 6:50 AM
  • Hi Fang,

    Visual studio 2015 CTP is prerelease version of next visual studio, its purpose is to collect feedback. I suggest you use connect to submit your problem. https://connect.microsoft.com/VisualStudio/feedback/CreateFeedbackForm.aspx?FeedbackFormConfigurationID=5303&FeedbackType=1

    More information about 2015 CTP, visit here. http://support.microsoft.com/kb/2967191.

    Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.


    Thursday, February 12, 2015 8:50 AM
    Moderator