none
Kinect 2 powering off after 7 seconds RRS feed

  • Question

  • Hi all!

    I've been trying to get a kinect 2 to work with my VR rig.

    I've tested it with my laptop, and it was performing fine for over an hour of continuous use. It shows up in the device manager as 2 devices, the depth sensor itself, and an audio device.

    My VR rig seems to have some problems, and I am not sure if those are hardware or software.
    When connected to any of the 3.0 ports on my motherboard, it will light up and function fine in the SDK software for roughly 7 seconds, then abruptly turn off, then turn back on again in about 5 to 10 seconds. In device manager, only the depth sensor is listed.
    When connected to the single usb 3.1 port, it shows up in device manager as the depth sensor only, and with a little warning triangle over the icon (needless to say it doesn't work through that port).

    Things I've tried:
    -Removing all usb devices (save the mouse and keyboard, which are on a separate usb controller anyway). No change in behaviour.
    -Uninstalling the drivers for the depth sensor from device manager.
    -Reinstalling SDK and runtime
    -Updating all motherboard drivers
    -Making sure the kinect runtime uses my dedicated GPU
    -Trying every single USB port (obviously only the 3.0 and 3.1 ones)

    A thing I've noticed: When the kinect is plugged into my laptop (and works), disabling its audio device through the sound settings causes the same shut-offs. This makes me suspect the issue is software-related, but I would really want to avoid a clean windows reinstall xD.

    My specifications:
    Motherboard: MSI gaming m5 z170a
    GPU: GTX 970 4GB from MSI 

    Wednesday, September 12, 2018 3:42 PM

All replies

  • Even 3.0? Because it doesn't seem that you have even have a single 3.0 USB port. Only 3.1 Gen1 on the front and Gen2 on the back. At that is what I see on the official site.

    I have a 3.1 Gen1(Edit: Gen2) PCI-E card, which allowed it to get the stable maximum of 30 FPS. but I never got it to work more than once when used with Kinect, before needing to disable and re-enable the device. Right now with the latest drivers it doesn't work at all.

    Could you post the driver versions of your USB Controllers? They may be useful.

    EDIT: Wait a minute I don't have 3.0 either!!! I always assumed that the PCI-E card had the only 3.1 port!
    • Edited by Yanis Lukes Friday, September 14, 2018 8:32 PM Oh no...
    Wednesday, September 12, 2018 11:06 PM
  • I just had this problem: I followed the solution in this thread, and that fixed it:

    https://social.msdn.microsoft.com/Forums/en-US/a2af9bf2-8d52-4406-98ef-0ae21ab25016/kinect-v2-freezing-then-restarting-repeatedly-within-a-few-seconds-even-with-samples?forum=kinectv2sdk
    • Proposed as answer by Mark_C_M Sunday, September 16, 2018 2:36 PM
    Sunday, September 16, 2018 2:36 PM