locked
Failed to register the adapter for "SOAP" for the receive location RRS feed

  • Question

  • We are receiving the below error suddenly in the production system

    The Messaging Engine failed to register the adapter for "SOAP" for the receive location "/StrnData/BizTalk_Strn_StrnData_StrnList_Port_StrnList.asmx". Please verify that the receive location exists, and that the isolated adapter runs under an account that has access to the BizTalk databases.

    I never worked with the webservices and not able to figure out what is going wrong.

    Can anybody help me on this. Thanks

    Wednesday, September 2, 2015 6:07 PM

Answers

  • I am checking the receive location SOAP Transport properties

    Virtual directory plus Web Service .asmx file:

    Does it needs to be /StrnData/BizTalk_Strn_StrnData_StrnList_Port_StrnList.asmx right???

    I have /ABC.BizTalk.Strn.StrnData/ABC_JaxStrn_StrnData_StrnList_Port_StrnList.asmx

    Is that should be the problem


    It should be Virtual directory plus Web Service .asmx file

    Please look into MSDN article,

    How to Configure a SOAP Receive Location

    Please confirm, Are you able to browse the webservice? If not then please try to browse from IIS.


    Thanks, If my reply is helpful please mark as answer or vote as helpful.

    • Marked as answer by vdha Thursday, September 3, 2015 12:27 PM
    Wednesday, September 2, 2015 7:13 PM
    Moderator

All replies

  • Hi Vdha,

    As this is a permission issue the error occurs because the web service is running on the application pool which security account user is not a member of the BizTalk Isolated Host Users group. 

    To solve this issue check the application pool security user account in the IIS. Add that user account into the BizTalk Isolated Host Users group. Or change the application pool to the pool which user is already a member of the BizTalk Isolated Host Users Group.


    Thanks, If my reply is helpful please mark as answer or vote as helpful.

    Wednesday, September 2, 2015 6:16 PM
    Moderator
  • I did check in here

    But i am not sure how to  check the application pool security user account in the IIS.

    Is that what I need to look at.

    • Edited by vdha Wednesday, September 2, 2015 6:29 PM
    Wednesday, September 2, 2015 6:20 PM
  • I did check in here

    But i am not sure how to  check the application pool security user account in the IIS.

    1. Open the IIS Management Console (INETMGR.MSC). or Windows+R then type inetmgr and press enter
    2. Open the Application Pools node underneath the machine node. Select the application pool you want to identity.
    3. Right click the application pool and select Advanced Settings...

    4. Please verify same identity(user) has been configured for Host BizTalkServerIsolatedHost user group.



    Thanks, If my reply is helpful please mark as answer or vote as helpful.

    Wednesday, September 2, 2015 6:30 PM
    Moderator
  • Thanks Kamlesh. Yes I verified that it has the same user

    What could be the issue now?

    Wednesday, September 2, 2015 6:35 PM
  • Can you browse to (the WSDL of) the webservice? Is displayed correctly?

    /StrnData/BizTalk_Strn_StrnData_StrnList_Port_StrnList.asmx

    And please check error mentioned in eventlog also for more details.


    Thanks, If my reply is helpful please mark as answer or vote as helpful.

    Wednesday, September 2, 2015 6:47 PM
    Moderator
  • Vdha,

    One more thing, Please make sure You have configured correct receive port.

    Please refer below related thread have same issue,

    http://www.biztalkgurus.com/biztalk_server/biztalk_2006_r2/f/13/t/14706.aspx


    Thanks, If my reply is helpful please mark as answer or vote as helpful.

    Wednesday, September 2, 2015 6:50 PM
    Moderator
  • I am checking the receive location SOAP Transport properties

    Virtual directory plus Web Service .asmx file:

    Does it needs to be /StrnData/BizTalk_Strn_StrnData_StrnList_Port_StrnList.asmx right???

    I have /ABC.BizTalk.Strn.StrnData/ABC_JaxStrn_StrnData_StrnList_Port_StrnList.asmx

    Is that should be the problem


    Wednesday, September 2, 2015 7:00 PM
  • I am checking the receive location SOAP Transport properties

    Virtual directory plus Web Service .asmx file:

    Does it needs to be /StrnData/BizTalk_Strn_StrnData_StrnList_Port_StrnList.asmx right???

    I have /ABC.BizTalk.Strn.StrnData/ABC_JaxStrn_StrnData_StrnList_Port_StrnList.asmx

    Is that should be the problem


    It should be Virtual directory plus Web Service .asmx file

    Please look into MSDN article,

    How to Configure a SOAP Receive Location

    Please confirm, Are you able to browse the webservice? If not then please try to browse from IIS.


    Thanks, If my reply is helpful please mark as answer or vote as helpful.

    • Marked as answer by vdha Thursday, September 3, 2015 12:27 PM
    Wednesday, September 2, 2015 7:13 PM
    Moderator