locked
ASP session not working in firefox RRS feed

  • Question

  • User1009872404 posted

     hello gurus,

    I am facing this problem for long time. It would be appreciated if some1 can help me.

    ASP Session is working in IE but not in firefox(on web server). Firefox is allowed to accept cookies. i have tried all. I stopped firewall and ran but still same. session timeout is not working . it works fine on IE. 

    Well when i tried with localhost in firefox , to check session, it works ok. but when i try on webserver, its not working.

    Plzzzzzzzzzzz help.

    Saturday, August 16, 2008 9:55 PM

Answers

  • User1073881637 posted

    You wouldn't setup a proxy server, this is a device or technology to share a internet connection.  When you originally posted, you said it worked 'locally', but not on the web server.  Is it possible to try 'locally' on the web server with firefox?

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Monday, August 18, 2008 10:56 PM

All replies

  • User1073881637 posted

    Is your 'remote' connection going through some type of proxy server?  Sounds network related more than something IIS specific.   

    Sunday, August 17, 2008 10:06 PM
  • User1009872404 posted

     hi ,thanks for your help.

    I checked network but we are not using any kind of proxy server?

    should i set up proxy server to resolve these problem?

    thank in advance

    Monday, August 18, 2008 9:21 AM
  • User1073881637 posted

    You wouldn't setup a proxy server, this is a device or technology to share a internet connection.  When you originally posted, you said it worked 'locally', but not on the web server.  Is it possible to try 'locally' on the web server with firefox?

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Monday, August 18, 2008 10:56 PM
  • User1009872404 posted

     hi , you were right there is problem in network,,,we haveserver name Gold..

    and it has 4 IP addresses is its changing everytime .

    when i ping Gold if i get  x.y.2.2 then its work but if i get x.y.2.3 then its not working..

    can u tell me how to fix IP for gold. 

     

    Tuesday, August 19, 2008 7:56 AM
  • User1073881637 posted

    Sounds like a DNS issue where it could have automatically registered all 4 ip's in DNS or someone put them there.  I would fix DNS to have only one IP address and see if your site works.  Or configure your website to listen on just a single ip address.

    Tuesday, August 19, 2008 9:59 PM
  • User1009872404 posted

     hi, yesterday we had fixed IP address for our server.

    and we tried for session timeout but yet we are facing same problem its working in IE (localhost & server ) but its not working for server in FireFox....

    Wednesday, August 20, 2008 9:20 AM
  • User1073881637 posted

    I can't think of anything on the server that would be causing Sessions to not work with Firefox.  Have you tried Opera or Safari (apples browser) to see if the same behavior happens?  If they work, then there is something with FF.  Also, do you see this behavior on multiple machines with various versions of FF? 

    Wednesday, August 20, 2008 10:36 AM
  • User544016513 posted

     HI,

     

    I have  similar problem. I have a .net tree control (generated java script). It works on my PC (Vista) with IE & FF. But, fails when I browse it from FF for the site on IIS web server. Hwoever, IE is ok. I have even tried with localhost on the webserver and fails. If you guys know the solution please let me know.

     

    Satish

    Thursday, August 21, 2008 11:45 AM