locked
Can't access TSWeb from internet RRS feed

  • Question

  • User817936275 posted

    Hello!

     I have a problem I'm been trying to figure out for a couple of days now. And its really staring to bug me.

    I want to access my desktop with the Remote desktop web service, but it will only work on my lan and not from internet. I've tried almost everything, forwarding ports just wont work.

    I always get "Page cannot be displyed". No matter if the RDP port is closed I should still see the login page "default.htm" but I cant. I've tried changing my standard website ports to different ports and opened the same ports in the router but nothing.

    For all I know it shouldnt matter if I remove the default.htm from the TSWeb folder and replace it with a new default.htm page that just says hello or whatever, I still can only access it from inside my lan.

    All other applications work with portforwarding, including using the normal RDP Client.

    I dont know what to try next, I havent tried to remove my firewall/router but will try that too soon.

    Any idea what it could be? I used to be able to acces my desktop this way with my old computer using the same router etc. I have a feeling its just some little anoying setting buried deep in the registry or some place where I cant find it.

    All help is appreciated /Martin

    Saturday, February 3, 2007 1:46 PM

All replies

  • User989702501 posted

    All other pages works except /tsweb?  what's the status code in IIS log ? or the request is not reaching IIS at all?

     

    Saturday, February 3, 2007 11:23 PM
  • User817936275 posted

    There is nothing in log, except when I access it from my lan. If I try to access from internet the attempt wont show in the log.

    I got through one time, and that time it showed my lan ip in the log. And I havent changed anything since then. It mysteriously worked just once, but when I tried refresh page it wouldnt work again. I tried changing the IP of the Standard website to my lan IP, so Im not sure if thats why it showed up in the log. But Im pretty sure it worked just once, when it happened I was so thrilled after working so many hours on the problem. But afterwards I was unsure if it really worked from outside my lan because I was kind of tired and mixed up in the head after thinking too much and keeping all settings, ports etc in my head.

    In my standard website I also have the IISHelp folder containing a default.htm document but I cant reach that either.

    Also when I check netstat -a I can see that it sais listening on my RDP web port, but when I try checking that port with www.canyouseeme.org/ it can see my port for RDP which I use for the standard RDP client and which also the web client will use once I can access the IIS/Tsweb. But it cant see my port which I use for the IIS even though netstat sais its listening and its open in my firewall/router.

    Sunday, February 4, 2007 1:18 PM
  • User989702501 posted

    Looks like something blocking in between as well, did you check that port 80 is open from canyouseeme.org

     

    Monday, February 5, 2007 12:44 AM
  • User-823196590 posted
    Sounds like a router/firewall issue, blocking your IIS web traffic.
    Monday, February 5, 2007 8:55 AM
  • User817936275 posted

    All the necessary ports are open, and there is nothing wrong with my router.

    Just tried to access tsweb on my old computer which is in my lan too, worked perfectly on the first try. Only changed the ports to be directed to my old computer and checked that all settings was ok and it worked just as good as it used to.

    Im pretty sure its something on my new computer that is refusing to let me access it from the internet. Ive tried uninstalling .NET framework cos my old computer didnt have any asp stuff in the standard website settings. Will try some more but im pretty sure it wont work.

    Tuesday, February 13, 2007 9:12 AM
  • User-823196590 posted
    Are you running the Windows XP firewall?
    Tuesday, February 13, 2007 11:47 AM
  • User989702501 posted

    Port forwarding setup correctly? how about remotely from the net browser your IIS ? try other url - say a simple hello.html

     

    Tuesday, February 13, 2007 11:16 PM
  • User817936275 posted

    Hi again!

    Thanks for all your efforts to help. Still no luck on solving my problem Im afraid.

    Im not using windows firewall, and Ive even tried opening the right ports in that too, eventhough Im not using it, just to make sure.

    On trying another document, as for example hello.htm the same thing happens. Access by lan ip ok, by wan ip "the page can not be displayed"...

    Do you think it could be my NIC? I have another one and will try that just to make sure. Also do you think installing a newer version of IIS will help? Im kind of running out of options here, and its realy disturbing cos I normally solve all "computer related" problems sooner or later and normally dont quit trying or searching for answers, but it feels like this one is going to get me.

    Please keep posting possible solutions, all help is highly appreciated!

    Saturday, February 17, 2007 3:48 AM
  • User-823196590 posted
    "the page can not be displayed"... means all kinds of things and is not at all helpful. You're saying you can access your old pc from the internet when you change the router to forward to it instead of the new one?
    Monday, February 19, 2007 9:14 AM
  • User817936275 posted

    Exactly, I can access my old computer by just changing the ports to go to my old computer's ip instead of my new one.

    With "the page can not be dislplayed" I mean the standard error page which further sais something like the page you are looking for is not available for the moment. This could be because of a technical problem or you have to adjust your browsersettings etc..

    Friday, February 23, 2007 2:12 PM
  • User989702501 posted

    Sorry, been away for Chinese New Year. Now, I'm getting confuse. what's your actual setup?

     1 IIS - that can access locally but not remotely via WAN

    do you have another machine in LAN that access the IIS ? does it work for the hello.html?  what do you mean by changing port to the old computer?

     

    Sunday, February 25, 2007 11:07 PM
  • User817936275 posted

    Yes I have three computers in my lan that are all connected via a D-Link 604 router/switch.
    My new computer, my old computer and one more computer using XP Home.
    My old and new computer use XP Professional.

    I can access TSWeb folder on my old and on my new computer within my lan, from all three computers using local name or local ip 192.168...etc.

    I can access my old computer by typing WAN ip when IIS port is directed to old computers ip. From both within my lan and from my work, friends house etc.

    I cannot access my new computer by typing WAN ip from within lan or my work even though port is directed to new computer.

    So if IIS port are directected old computer = success, change the port to be directed to new computer = failure.

    IIS setup is the same on both old and new computer.

    Remote Desktop access works great on both computers using the RD client.

    I have also deployed the RD Web client on my webserver provided by my ISP, and connecting works perfectly by typing WAN ip in there.

    So, the problem is that I cannot access TSWeb folder on my new computer from the internet.
    No difference whether Im using the default.htm for RD Web or a simple hello.htm.

    Thx Martin

    Tuesday, February 27, 2007 3:53 PM
  • User989702501 posted

    Wow.. I'm clear now. So you are sure that the pot redirecting to new computer is seutp correctly? and no firewall blocking in between?

    anything in IIS log file? what do you see in the browser? page can't be display? or other errors?

     

    Tuesday, February 27, 2007 11:31 PM
  • User817936275 posted

    Sorry been away for a couple of days now.

    Everything is setup correctly, I dont understand why it wont work.

    I get the "The page cannot be displayed" everytime I try connecting.

    Tuesday, March 20, 2007 3:59 PM
  • User1073881637 posted

    When you are outside the LAN. Open up a command prompt and test port connectivity. 

    Try telnet x.x.x.x 3389 (tests RDP port)

    Try telnet x.x.x.x 80  (tests port 80) 

    Terminal Server uses port 3389.  IIS uses port 80.  Make you can connect with simple commands.  Have you tried using remote desktop on your local machine to access your pc from outside? this would verify the network, firewalls and routers are setup correctly to access Terminal Server.

    I doubt this is the cause or contributing to the issue, TS Web has an ActiveX embedded in the web, make sure the source the CAB file is configured properly.  There are a few ideas. 

    Thursday, March 22, 2007 11:28 PM
  • User-823196590 posted
    ... TS Web has an ActiveX embedded in the web ...
    ... meaning that IIS is not actually used to handle the remote connection.  The ActiveX just independently talks back to the remote machine ...
    Friday, March 23, 2007 7:50 AM
  • User1073881637 posted
    Great catch Tom.   The 'client' is trying to make a connection on port 3389.  IIS is not involved.  Thanks for mentioning that.
    Friday, March 23, 2007 8:31 AM
  • User-823196590 posted
    I wasn't sure if that was clear to the original poster.
    Friday, March 23, 2007 9:47 AM
  • User989702501 posted

    wah..Zzz.. still not fix yet ?

    Well, my call is before tsweb - it need to talk to IIS to get the activex.. so if it's page  can't be display and no iis log, this mean it is not talking to IIS at all. so for sure no tsweb.

    but then - OP mentioned no firewall, etc. yet he/she got page can't be display. so the request is not even reaching iis.

    Saturday, March 24, 2007 10:10 PM
  • User817936275 posted

    Hi again!

    Thanks for all the previous efforts, but still no luck.
    But I solved the problem for now by just putting the tsweb folder on the space provided by my ISP.

    But, a new problem arose just recently when I tried to set up a FTP server using bulletproof ftp server.

    It seems to be the same problem as with IIS.

    I posted this in MS forums but no one cared to reply:

    Ok, I have an issue thats been bugging me for a looong time.
    And I have spent countless hours trying to resolve it, my next step is to do
    a complete reformat and see if it helps.

    The problem: Im trying to set up a FTP server on my home computer, but its
    impossible to connect to it from the internet.

    I had this problem before when I wanted to set up Remote Desktop Web, but
    again it was impossible to connect to my computer. Instead I put the tsweb
    folder on the space provided by my ISP and solved it that way.

    Let me explain:
    I have 3 computers in a lan.
    My "main" computer is the only one having this problem.
    The other 2 work fine with both FTP and RDW.
    I know for a fact that it is NOT my router that is the problem, it workes
    fine when set up with the other 2 computers.
    Also, if I disconnect the router and connect my computer directly to the dsl
    modem the problem remains.
    I have no software firewalls. My ISP is not blocking me.
    Remote Desktop works fine when using the normal RD Client.
    Also pc Anywhere works fine.

    The strange thing is, that both FTP and RDW works if use them localy on my
    lan, but not over the internet.
    And I assure you again, that my problem has nothing to do with forwarding
    ports this and that... Ive tried it all a million times.
    The only thing I can think of is that might be some little setting in the
    registry or something similar that is preventing me from using these services
    over the internet.
    I used fool around before with some settings in gpedit.msc to get different login screen etc. but Im pretty sure its nothing that should cause this.

    Its a little difficult to explain all the specific details in text, but I
    hope you get the picture.

    All help is greatly appreciated /Martin

    Monday, September 17, 2007 11:38 PM
  • User989702501 posted

    Wow. six month later. welcome back :)
    First, I don't quite get you on the tsweb issue with hoster give you another space ? what space ?
    For ftp, typically you can test it via ftp.exe first.
    So from remote machine, try ftp yourpubipaddress, if your port forwarding is setup correctly you will see the ftp banner + login prompt. try login and then do a simple dir listing... works? if not post the output here.

    Tuesday, September 18, 2007 2:50 AM
  • User817936275 posted

    Hello again!

    With space I meen the little site my ISP gives every user to put their own little homepage on. Its like 20Mb on their servers.

    Already tried FTP in cmd, Telnet, www.canyouseeme.org, and normal FTP client software. Nothing works.

    Tuesday, September 18, 2007 5:22 PM
  • User989702501 posted

    Well in that case, total ftp port blocking ? since you can even see it via the url. and you are sure that port forwarding is setup correctly? isp block, firewall block ,etc

     

    Wednesday, September 19, 2007 3:26 AM
  • User817936275 posted

    Yes Im sure.

    Like I said it works on all the other computers on my lan. And no ISP blocking.

    Even when I remove the router/firewall and connect directly to the modem it wont work.

    I have the XP Firewall completely disabled, and since FTP works over lan that cant be it. And also if XP Firewall in some strange way still were running it should report if its blocking by popup or log file.

    I think reformat is the only solution left, unless you have some idea of what it could be.

    Terima kasih for all your help.

    Wednesday, September 19, 2007 6:19 PM
  • User989702501 posted

    LOL.. that's thanks in malay.
    Can you see the port when it is directly connected to the modem? via www.canyouseeme.org ? port 21 visible ?
    As you said this is more like networking issue, as FTP is running fine internally. so reformat won't help at all.

    Wednesday, September 19, 2007 8:39 PM
  • User1073881637 posted

    Any symantec, McAfee, or Trend software loaded on your box?  Have you tried simple things like swapping out the NIC cable to see if something odd is there, try a different switch port?  I'm grasping at straws, I'm sure if I was on-sight, we'd figure it out, but that is not going to happen!  hehe!

    Thursday, September 20, 2007 12:36 AM
  • User817936275 posted

    Hello again!

    I've been away for a while cos I have moved to Norway.

    The problem remains, I now have a different router, different cable but its still the same.

    In this LAN we are 5 people, and it workes for the other guys same as before on my old LAN.

    I have a Symantec service running called Symantec Network Drivers Service, but I've tried stopping it and it makes no difference.

    I guess its a leftover from when I used to run Norton Antivirus.

    Im going to do a reformat soon anyway cos Im installing another harddrive in RAID etc. so hopefully that will resolve the issue.

    Sunday, October 7, 2007 6:16 PM
  • User817936275 posted

    Update:

    Now it works flawlessly... and I dont have a clue how it just suddenly got working.

    I havent reformatted or anything. Thanx for all your efforts.

    /Martin

    Wednesday, October 10, 2007 12:14 PM
  • User989702501 posted

    o.O... wow :) 

    Wednesday, October 10, 2007 11:25 PM
  • User1452631974 posted

    I have a similar problem with tsweb, but I must state that I'm using XAMPP from a flash drive. 

    1 - Webpages are working through the internet

    (tsweb page is http://24.164.65.140/winstuff/tsweb/)

    The page opens, but the pc is inaccessable.  I forwarded the port for the the RDC to work, a window pops up asking if I allow it to connect it to my pc. 

    I'm unable to connect to the pc from a remote location. 

    The following message comes up - (title is: VBScript: Remote Desktop Disconnected)

    This computer can't connect to the remote computer. 

    Remote Desktop cannot find the remote computer.  Type the computer name or IP address again, and then try connecting.  If the problem continues, contact the owner of the remote computer or your network administrator. 

     

    What am I missing? 

     

    Wednesday, August 12, 2009 12:22 PM
  • User1620423074 posted

    hi, sorry to revive a very old thread, but i have the same problem as the last poster i can access the RDP tsweb over LAN but when i try to access it over internet, the page loads up and everything seems norma.

     but when i try to connect to the computer which i am trying to connect it gives me an error "The specific remote computer cannot be found, Verify that you have typed the correct computer name or IP address, and then try connecting again"

    so just to check if i was typing the computer name wrong tried it again and even VNCed into another machine with which i used the tsweb to connect to the machine and it worked...so i am guessing that its got something to do with my router or maybe configurations with the RDP are only for LAN,

     any help is appreciated.

     cheers

    Tuesday, November 17, 2009 10:08 PM
  • User-823196590 posted

    This is not an IIS issue.  IIRC, the web page only hosts an ActiveX control that launches remote desktop on the client.

    Please follow-up in a windows networking forum.  You need to determine what ports are required for RDP.

    Wednesday, November 18, 2009 10:52 AM