none
FTP Receive Adaptor, only issue LIST command RRS feed

  • Question

  • Hi,

    I am new to using the FTP adaptor. I have configured a FTP adaptor which connects, and does a LIST command, and this shows the file I have waiting to pull down (seen in the log file), then does a QUIT.

    It doesn't issue a RETR command to pull down the three files. I have the file mask blank; can this be causing the issue? The problem is these file are on a EDI server, and have the file names removed as part of the upload process, so I have left the file mask blank.

    The log file is below:

    > LIST
    < 150 Opening data connection for transfer.
    <
    < Sender ID                          St APRF           SNRF           Service Ref.          Size
    < ----------------------------------------------------------------------------------------------
    < 505                                    N test              xxxx                  xx4                   3
    < 226-Closing data connection - action successful.
    <  List command OK
    < 226
    > QUIT
    < 221 Service closing control connection.

    Am I doing anything wrong?

    Many thanks

    Brett

    Monday, August 2, 2010 3:09 PM

Answers

  • Hi Brett,

    There is an issue with GXS FTP server.  See the following hotfix.

    http://support.microsoft.com/kb/943228/en-us

    Also, should check for any other ftp related hotfixes.

    Thanks,

    William

    • Marked as answer by Brett_NZ Thursday, August 12, 2010 10:09 AM
    Thursday, August 5, 2010 2:46 PM
  • This is a specific hotfix for GXS FTP server.

    When the BizTalk FTP Adapter issues the LIST command, the GXS FTP server sends the listing as a file which BizTalk FTP Adapter does not understand by default.

    After applying the hotfix, BizTalk FTP Adapter will send a SYST command first to verify if this is a GXS(ICS type) FTP server. If it is, a specific parser will be used to process the response from GXS FTP.

    Please call Microsoft support to get this specific hotfix and inquire if there is a BTS2009 version of it.

    Thanks.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Brett_NZ Thursday, August 12, 2010 10:09 AM
    Tuesday, August 10, 2010 9:13 AM
    Moderator

All replies

  • Hi Brett,

    In the file mask use "*".

    Thanks,

    William

    Monday, August 2, 2010 3:26 PM
  • Hi William,

    Thanks for replying. I have just tried that, but in the log it has now just added the * to the LIST command:

    < 200 Command Okay.
    > LIST *
    < 150 Opening data connection for transfer.

    It seems to be executing LIST instead of the RETR command (which I would expect?); unless it always does a LIST first to check if their are files ready to download first?

    I also notice my Pre Get and Post Get options don't show in the logs, so i guess it is not executing the Get based on the results of the LIST; but there are files there. Is there some sort of criteria that the results of the LIST is inspected for, possibly before a GET statement will be initiated?

    Best regards

    Brett

    Tuesday, August 3, 2010 7:26 AM
  • Hi Brett,

    The file mask of "*" should pull back everything that is in the configured path/directory on the ftp site.

    Also, quick question. When you say the file names have been removed, do you mean the file extension? (i.e. test vs test.edi or test.txt)

    Thanks,

    William

    Tuesday, August 3, 2010 8:03 AM
  • Hi William,

    I did mean file extensions sorry, not file names.

    It is strange, but adding the * only results in it appearing after the LIST command.

    I saw some comments on another post about the FTP adaptor only doing a download if it has delete permissions. This is a GXS FTP server for Tradacoms EDI transactions I am connecting to, and I think it doesn't allow deletes, it changes a flag marking that file for deletion in some kind of system processing once the file has been downloaded.

    I am using Biztalk 2009 FTP adaptor, but I also get this issue with when I tried with Biztalk 2006 if it helps.

    Best regards

    Brett

    Thursday, August 5, 2010 10:09 AM
  • Hi Brett,

    There is an issue with GXS FTP server.  See the following hotfix.

    http://support.microsoft.com/kb/943228/en-us

    Also, should check for any other ftp related hotfixes.

    Thanks,

    William

    • Marked as answer by Brett_NZ Thursday, August 12, 2010 10:09 AM
    Thursday, August 5, 2010 2:46 PM
  • Hi William,

    Thanks. I will download this hotfix and try it on my 2006 server. I also get this error on my Biztalk 2009 Server, but maybe they did not update the ftp driver between versions?

    Many thanks for all the help so far!

    Best regards

    Brett

    Thursday, August 5, 2010 2:54 PM
  • This is a specific hotfix for GXS FTP server.

    When the BizTalk FTP Adapter issues the LIST command, the GXS FTP server sends the listing as a file which BizTalk FTP Adapter does not understand by default.

    After applying the hotfix, BizTalk FTP Adapter will send a SYST command first to verify if this is a GXS(ICS type) FTP server. If it is, a specific parser will be used to process the response from GXS FTP.

    Please call Microsoft support to get this specific hotfix and inquire if there is a BTS2009 version of it.

    Thanks.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    • Marked as answer by Brett_NZ Thursday, August 12, 2010 10:09 AM
    Tuesday, August 10, 2010 9:13 AM
    Moderator
  • Many thanks for these responses. I tried to apply the hotfix, but this was only for the 2006 R2 version of the FTP adaptor. I was about to contact Micorsoft support to inquire if a 2009 version existed, but managed to get a third party FTP adaptor (Covast) to work, so I am going to stick with this solution.

     

    Thanks again for the help.

     

    Brett

    Thursday, August 12, 2010 10:09 AM
  • I am noticing the same thing on BizTalk Server 2013 R2.  The remote FTP server is an L8 GXS Enterprise type and I'm using Passive mode.  I've used active mode as well but it only runs the LIST command (shows the files there) and then QUITS.  I have logging turned on.  Does the remote GXS FTP server need to allow for delete permissions turned on.  Didn't think that was needed since there is a property "Delete After Download".  Any ideas?

    Thanks,

    Sean

    Wednesday, October 29, 2014 2:15 PM