none
Office 2007 Open XML format conflicts with Office 2010? RRS feed

  • Question

  • Hi,

    This is probably not a coding question but something related to using the basics of open XML. I have a plugin developed on Word 2007 using open XML format. Consider the scenario: I have a machine with Office 2007 and my plugin (which uses open xml) installed on Word 2007. If I upgrade this machine to Office 2010, there are no issues with the plugin.

    However if I start fresh with a machine having Office 2010 and then try to install my plugin, it gives issues. Is it because its Office 2007 open xml? If so, how do I get rid of this problem so all the new machines which have Office 2007 do not run into this issue?

    Thanks in advance,

    May.

     

    Monday, October 25, 2010 9:07 PM

Answers

  • Hi May,
     
    You need to install the PIAs. I am way out of my depth with this, but I think the PIAs are optional when you install Office, so go to the Control Panel and change your Office installation to include them. I think they are labelled as ".NET support" under each individual application in the Installation Options panel.
     

    Enjoy,
    Tony
    www.WordArticles.com
    • Marked as answer by May1006 Tuesday, October 26, 2010 7:41 PM
    Tuesday, October 26, 2010 7:12 PM

All replies

  • Hi May1006,

    I think maybe it's better to post this question at OpenXML SDK Format Forum to get better helps.
    http://social.msdn.microsoft.com/Forums/en-US/oxmlsdk/threads

    Best Regards,
    Amy Li

    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, October 26, 2010 3:35 AM
    Moderator
  • Impossible to say without more detail.
     
    What 'issues' are you seeing? What type of "plugin" do you have, and what does it do?
     
    A longshot --- are you using custom XML? Might you be being affected by the changes made as a result of the court case that Microsoft lost last year. Support for custom xml was removed from recent versions of Word 2007, and not included in Word 2010, but remained in versions of 2007 already running, and may well remain in them, even when updated to 2010 (just a guess).
     

    Enjoy,
    Tony
    www.WordArticles.com
    Tuesday, October 26, 2010 2:41 PM
  • Thanks for the reply Tony.

    The message I get is "The Office 2007 Shared PIA Component is not installed. Set up can not continue".

    I have a Word 2007 Plugin which basically has stuff where u can add content controls, mark some text as content controls etc...

    If you have more questions, please let me know.

    Thanks,

    May

    Tuesday, October 26, 2010 6:42 PM
  • Hi May,
     
    You need to install the PIAs. I am way out of my depth with this, but I think the PIAs are optional when you install Office, so go to the Control Panel and change your Office installation to include them. I think they are labelled as ".NET support" under each individual application in the Installation Options panel.
     

    Enjoy,
    Tony
    www.WordArticles.com
    • Marked as answer by May1006 Tuesday, October 26, 2010 7:41 PM
    Tuesday, October 26, 2010 7:12 PM
  • Thanks Tony. That worked! I am sure if there are bulk users on which we have to deploy Office 2010, we can turn this setting ON by default so individual user's don't have to do this set up.
    Tuesday, October 26, 2010 7:48 PM