locked
VS2005 RC, has anyone got the Club starter kit working RRS feed

  • Question

  • User-1829657710 posted
    I have started to play with the club starter kit in the RC IDE and the system will not run, I need to update the database file. When I start the application the system starts to upgrade the Data file, then drops out and returns a message that the DB File can not be upgraded as its version is incompatible with the RC DB Engine. All of that is ok, so I downloaded the SQL Scripts so that I could manually run the scripts against a new file so that the system can run. The problem is that I can not find the tools to run the script. I am almost at the stage were I will create the tables and SP by hand. There should be a way that we can run raw sql scripts against the db files using the IDE it's just that I can not find it.
    I looked at the command line tools for sql that are installed with the IDE (SQLCMD) and I can not work out the syntax to connect to the raw file (MDF). Can some one help me with the syntax for the tool, or a direction to where I can run the scripts in the IDE.

    I know that I could install the management tools from the SQL Server release, but Why should I install a full db engine just to run a script against an MDF File, as we are supposed to be able to work with just the files.
    Monday, September 26, 2005 6:06 PM

All replies

  • User1732183692 posted
    You might as well install a SQL Server manager program.  You're going to need it eventually anyway.  I use the free one from http://www.mssqlmanager.com  It's the lite version.
    Tuesday, September 27, 2005 1:47 AM
  • User-1829657710 posted
    I have thought of that, and I would install Enterprise manager or the SQL Management tools that actually ship with the sql 2005 product line. The problem is that with the VS 2005 system the sql engine is built into the vs system and is managed from there. Using one of the other packages that are out there at the moment you still have to have a valid engine running so that it can read the MDF file that is used.
    the visual studio system of products ship with a version of SQL server (Express edition). This package also includes the command line tools for managing SQL Server 2005, as well as a backdated system, these two programs allow you to connect to the database engine "SQLCMD" and "OSL". I used to use the OSQL command tool to manage SQL Server 2000 database systems by connecting directly to the database engine. The problem is tat for both of these tools to work you need to be able to connect to the database server or instance. If you run the IDE and then go to the command lin and run SQLCMD -L which will list the servers on the machine, it does not list a valid server. What I need to know is the command syntax for connecting to the direct file through the sqlexpress engine.

    With the RC Product or any of the newer ide systems you should be able to manage the data files that you are working with without having to install a complete engine. Now you should be able to do this in some way as you are able to create DDL "Data Definition Language" commands on the fileto create tables.... but not run scripts.
    Tuesday, September 27, 2005 8:01 AM
  • User1665397980 posted

    As a (simple?) workaround, you could create a new database file (in the Add Connection "Browse" dialog, just enter a new name), then create a stored procedure that just runs all of the queries you need to create the tables, etc.

    I'm wondering where you found the SQL scripts though.  I don't see them in the project template or on the download page.  Can you give me the link?

    Thanks!
    -Arian

    Saturday, October 1, 2005 1:32 AM
  • User-1829657710 posted

    After some playing around, I finaly got it working.

    What I had to do was get the SQL Script, see above post, then download the SSEUtil tool from the MSDN Site. http://www.microsoft.com/downloads/details.aspx?familyid=FA87E828-173F-472E-A85C-27ED01CF6B02&displaylang=en

    This is a command line tool that will allow you to connect to Express files and run SQL Commands against it.

    Monday, October 10, 2005 11:07 PM
  • User706157948 posted
    thanks for the info !!!

    I have used this SSEUtil command you suggested (which is the same as the SqlCmd in the binn directory of SQL Server), but now he complaints that he cannot find the tables.  If i look at the mdf file it is not increased in size, so the tables are not created in that file. 


    Any suggestions on how I could make that happen?

    Many thanks.

    Friday, October 21, 2005 6:50 PM
  • User469863107 posted
    I'm trying to do Club starter kit work, but I'm working with VS2005 and Sql Server 2005 RC2 and the install kit did not create the data base.

    I can't attach the data base Clubsite.MDF to my DB server, and I executed the database script by hand , but when I launch the app, I get a error: Could not find stored procedure 'dbo.aspnet_CheckSchemaVersion'. 

    This stored procedure is not created with the DB script and it is used by the SqlRoleProvider.

    Where can I get the DB scripts for all ASP.NET 2.0 providers or what must I to do to install OK the BD items that providers use?

    Thanks
    Monday, October 31, 2005 5:21 PM
  • User1900542555 posted
    As the previous posts allude, you essentially need to update the 'clubsite.mdf' file that is packaged in the starter kit. And while the posts make mention of the ability to execute commands against the .mdf file via SSEUtil, I couldn't find any straightforward way of doing so. Therefore, I came up with my own method. Basically, we're completely scrapping the database that is packaged with the starter kit. Here are the steps I took to get this project working:

    1. Download SSEUtil - http://www.microsoft.com/downloads/details.aspx?familyid=FA87E828-173F-472E-A85C-27ED01CF6B02&displaylang=en
    2. Download the Generic SQL Server Scripts for the Club Site Starter Kit - http://www.microsoft.com/downloads/details.aspx?FamilyID=0dd83a11-6980-4951-a192-da6eacc6a19e&DisplayLang=en
    3. After extracting both downloads, copy 'sseutil.exe' and 'club-add.sql' to the 'App_Data' directory of the Club Site starter kit. This is not a necessary step, but I found it useful so that I didn't have to always type full file paths into the utility.
    4. Open a Command Prompt and navigate to the directory containing SSEUtil.
    5. Type the following commands:
                sseutil -c
              1. CREATE DATABASE clubsite
              2. go
              --the command should execute successfully
              2. use clubsite
              3. !load club-add.sql
              4. go
              --the command should execute successfully, you should see the contents of the sql file after having been processed, type 'quit' to exit
    6. Still at the command prompt, type: sseutil -d clubsite
    7. The database should successfully detach and you have yourself a brand new clubsite.mdf to use in your project!
    8. Close your command prompt, and in Windows Explorer, browse to C:\Documents and Settings\<your username>\Local Settings\Application Data\Microsoft\Microsoft SQL Server Data\SQLEXPRESS
    9. There you will find your newly detached 'clubsite.mdf', just copy/cut it to the 'App_Data' folder of the starter kit and either overwrite or backup the old file
    10. Now load up your Visual Studio project and you should be able to connect to the clubsite.mdf database and be good to go.

    I'm sure once the final releases of Visual Studio 2005 and SQL Server 2005 Express are available for general purchase, the Starter Kits will probably be updated and this will be a moot point and an exercise in futility, but until then good luck and I hope you find this helpful.

    Tuesday, November 1, 2005 4:56 AM
  • User-1838124117 posted
    I downloaded your suggested files and tried this, but when I tried to load the sql, I got an error that said:
    Error processing extended command.
    Invalid command 'load'.

    Is there a different command prompt than just using the one at Start->run->cmd??

    Thanks,
    Sunday, November 6, 2005 10:19 PM
  • User1900542555 posted
    nope, that's the command prompt i was talking about.

    I know it's a dumb question, but are you sure you typed in !load, instead of just load?
    Monday, November 7, 2005 10:26 PM
  • User-1838124117 posted

    Not a dumb question, but I did type in !load as specified.

    I just tried this out on another computer and it works. I'll have to see why it didn't work on my other computer. Thanks for the solution. I'll try it later today on my other computer - this one is the work computer...

    Regards

    Tuesday, November 8, 2005 5:02 PM
  • User1691389741 posted
    I get the same error, when you ask ess for help the !load command is not listed as an extended command. 

    I tried !run club-add.sql and that just throws up loads of errors.

    Can anyone tell me if .asp is always this much trouble, I'm OK with Frontpage but wanted to learn to make better sites. This is my first look at .asp, i have no idea what I'm doing and this isn't a good start :(
    Tuesday, November 22, 2005 3:46 PM
  • User-1829657710 posted
    All you need to do now that the Express Products have been released is to download the latest version of both the IDE and the starter kits and they work fine. The above problem was just when you had the Starter Kits from pre release and one of the CTP or RTM Builds of the IDE.
    Tuesday, November 22, 2005 4:50 PM
  • User1691389741 posted

    I downloaded both the starter kit and Web Dev at 19:25 GMT today, no previous version of SQL, Web Dev, Visual Basic etc have been on this system. It still doesn't work for me.

    The build number on the file ClubSite.vscontnet is not available as someone forgot to fill out the extended details when creating it, the file is dated 07/03/2005 18:38.

    The VWD 2005 Expresss details are:
    Microsoft Visual Studio 2005
    Version 8.0.50727.42  (RTM.050727-4200)
    Microsoft .NET Framework
    Version 2.0.50727

    Installed Edition: WD Express

    Microsoft Visual Web Developer 2005   76872-000-0000011-00123
    Microsoft Visual Web Developer 2005

    I didn't download the library as I expect they will be in the next Technet DVD, could this be causing some or all of the problem?

    I would really like to learn asp and .net web site creation but this is putting me off big time

    Tuesday, November 22, 2005 5:26 PM
  • User-1829657710 posted

    I have just downloaded and installed the starter kit from,

    Direct Link to the Visual Studio Starter Kits on MSDN
    http://msdn.microsoft.com/vstudio/downloads/starterkits/

    Afetr installing, it all works fine. In the directory for the templates the starter kit is actually labeled as rtm.

    Directory and starter kit location.
    My Documents\Visual Studio 2005\Templates\ProjectTemplates\Visual Web Developer\CSharp
    Tuesday, November 22, 2005 5:41 PM
  • User-470525044 posted
    I have the Club starter kit downloaded and installed...I can open a new project using this template...I however can not save the project.  I get an error saying interface is not supported.

    Monday, November 28, 2005 5:43 PM
  • User-757370941 posted

    Just now used your instructions, and as expected, they worked for me.   For steps 3 thru 8, I followed your intent, but instead of using the command line method, used the SQL Server Management Studio Express CTP, downloadable now from msdn at...

    http://www.microsoft.com/downloads/details.aspx?FamilyID=82afbd59-57a4-455e-a2d6-1d4c98d40f6e&DisplayLang=en

    The only two things I can add:  

    1.    The Mgmt Studio adds an extention of ".mdf" automatically - no need for you to enter it when creating a new database.

    2.    The detached .mdf file is instead located at C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\Data

    Saturday, December 31, 2005 7:53 PM
  • User-1213092341 posted
    Did you ever figure out why it didn't work on your first computer? I have the same error: Invalid command 'load'.
    Friday, January 20, 2006 10:16 AM