none
Can't Create VSTO Projects RRS feed

  • Question

  • Hi, here's my development environment:

    • Windows Professional 64-bits
    • Office Professional Plus 2013
    • Visual Studio Professional 2013
    • .NET Framework 4.5
    • No pending updates from Microsoft

    Visual Studio has been working fine, until yesterday. I tried to create an Excel template and Visual Studio could not create the project:

    Clicking the help button takes me to the following link:

    https://msdn.microsoft.com/query/dev12.query?appId=Dev12IDEF1&l=EN-US&k=k(VST.Project.CannotOpen);k(TargetFrameworkMoniker-.NETFramework,Version%3Dv4.5)&rd=true#creating

    None of the reasons for failure apply to me. Then, reinstalled Visual Studio and the installer said installation of the VSTO runtime failed. I reinstalled it.

    Still, Visual Studio cannot create VSTO projects. I really need help, as I need to deliver a project early next week.

    Thanks,

    Carlos

    Sunday, January 29, 2017 2:34 PM

All replies

  • Hi all,

    The solution is to go back to a previous version of Office, as discussed in Microsoft Connect.

    https://connect.microsoft.com/VisualStudio/feedback/details/3117015/excel-designer-cannot-be-activated-visual-studio

    The article recommends to go back one step at a time, but I think that for most of us, the best is to go straight to version 15.0.4867.1003 (October 11, 2016). This is the same version that worked for the user that found the solution.

    Regards,

    Carlos.

    Sunday, January 29, 2017 3:35 PM
  • Hi,

    I suggest you mark the post as answer to close the thread, so that others with similar issue would see the answer.

    And thanks for sharing the feedback and workaround.

    Regards,

    Celeste


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, January 30, 2017 3:14 AM
    Moderator