none
I am getting an error :Message translation failed The sender of the document is not recognized RRS feed

  • Question

  • While processing the EDI message

    I am getting an error :Message translation failed The sender of the document is not recognized

    I am using Biztalk server 2006 with Covast accelerator

    I have created party as well for the same sender

    Please help me

    Friday, May 25, 2012 3:07 PM

All replies

  • Find below an errorr:

    An output message of the component "Covast EDI Disassembler" in receive pipeline "Covast.BizTalk.Pipeline.EDI.CovastEDIReceivePipeline, Covast.BizTalk.Pipeline.EDI.Default, Version=5.0.0.0, Culture=neutral, PublicKeyToken=68bef120a46b49ad" is suspended due to the following error:
         Message translation failed:
    (2220) The sender of the document is not recognized.
    sender: [] [5790000016839][14][],  (msgnr:0 segnr:0)(line:0 pos:73 filepos:73)
    .
     The sequence number of the suspended message is 1.


    • Edited by har Monday, May 28, 2012 7:36 AM
    Monday, May 28, 2012 7:35 AM
  • Hi,

    Check the party properties with the actual message data. There is surely a mismatch on some field which is causing the error


    Regards,
    Bali
    MCTS: BizTalk Server 2010,BizTalk Server 2006 and WCF
    My Blog:dpsbali-biztalkweblog
    -----------------------------------------------------
    Mark As Answer or Vote As Helpful if this helps.

    Monday, May 28, 2012 7:41 AM
  • I have checked the all possibilities but not able to understand

    what can be the problem

    I am new to Biztalk and need your help

    Monday, May 28, 2012 7:50 AM
  • Hi,

    If you share more details on the message and the party may be we can help, but not sure what could be wrong at the moment.


    Regards,
    Bali
    MCTS: BizTalk Server 2010,BizTalk Server 2006 and WCF
    My Blog:dpsbali-biztalkweblog
    -----------------------------------------------------
    Mark As Answer or Vote As Helpful if this helps.

    Monday, May 28, 2012 7:58 AM
  • Please find below the message I am trying to process:

    Its D96A message for the Orders

    UNA:+.? '
    UNB+UNOC:3+5790000016839:14+5790001865757:14+120518:1510+000581'
    UNH+726570+ORDERS:D:96A:UN:EAN008'
    BGM+220+12139045++NA'
    DTM+137:20120518:102'
    DTM+2:20120523:102'
    NAD+SU+5790001865757::9'
    NAD+BY+5790000016891::9'
    NAD+DP+5790000016891::9'
    NAD+IV+5790000016846::9'
    LIN+1++7290012291661:EN'
    QTY+21:6'
    UNS+S'
    CNT+2:1'
    UNT+13+726570'
    UNZ+1+000581'

    Monday, May 28, 2012 8:08 AM
  • Hi,

    Check this step by step walkthrough, I would suggest try this out first so that you get a hold of the various configurations and settings that need to be in place.


    Regards,
    Bali
    MCTS: BizTalk Server 2010,BizTalk Server 2006 and WCF
    My Blog:dpsbali-biztalkweblog
    -----------------------------------------------------
    Mark As Answer or Vote As Helpful if this helps.

    Monday, May 28, 2012 8:17 AM
  • I have done all the steps of the configuration

    I guess problem is with message only

    could you have any guesses what can be the fault by looking at  the error

    Monday, May 28, 2012 8:24 AM
  • Hi,

    Check the UNB2.1 in your agreement. In your case it should be 5790000016839 and UNB3.1 should be 5790001865757


    Regards,
    Bali
    MCTS: BizTalk Server 2010,BizTalk Server 2006 and WCF
    My Blog:dpsbali-biztalkweblog
    -----------------------------------------------------
    Mark As Answer or Vote As Helpful if this helps.


    • Edited by DPS Bali Monday, May 28, 2012 9:12 AM
    Monday, May 28, 2012 9:11 AM
  • I am doind the development in Biztalk server 2006

    can you please tell me where can I find UNB2.1

    I have created the party and have set the value EDI://5790000016839:14:

    Please help me

    Monday, May 28, 2012 9:16 AM
  • Are you using biztalk server 2006 R2 or 2006. Also are you using covast for EDI processing?

    Regards,
    Bali
    MCTS: BizTalk Server 2010,BizTalk Server 2006 and WCF
    My Blog:dpsbali-biztalkweblog
    -----------------------------------------------------
    Mark As Answer or Vote As Helpful if this helps.

    Monday, May 28, 2012 10:14 AM
  • Yes, I am using Covast for EDI processing.

    And its Biztalk server 2006

    Monday, May 28, 2012 10:32 AM
  • Create the party using the TPM in Cavast. Check the documentation to see how you are specifiying certain properties. I dont remember exactly the UI so cant give you the complete step by step.

    Regards,
    Bali
    MCTS: BizTalk Server 2010,BizTalk Server 2006 and WCF
    My Blog:dpsbali-biztalkweblog
    -----------------------------------------------------
    Mark As Answer or Vote As Helpful if this helps.

    Monday, May 28, 2012 11:06 AM
  • Yes,I have created the Party using Biztalk server admin

    Please help me out

    Monday, May 28, 2012 11:34 AM
  • I too faced the same problem, I have followed the below steps for the solution :-

    1) Deleted the existing party.

    2) Created parties for Sender and Receiver using TPM in Covast.

    3) Restarted the host Instances

    Saturday, May 25, 2013 10:03 AM