locked
rsAccessDenied on http://localhost/reportserver RRS feed

  • Question

  • Fresh install of all SQL 2008 SQL services (developer edition) on my laptop for home use. Windows 7 home premium x64. I'm a local admin. I get "The permissions granted to user 'Bruce-PC\Bruce' are insufficient for performing this operation. (rsAccessDenied)" error when accessing http://localhost/Reportserver. I've been reading posts on this for hours with no results. I can get to http://localhost/reports with no problem. No problem connecting with SSMS either.
    Saturday, August 7, 2010 10:55 PM

Answers

All replies

  • I guess you could open report manager but can't see folder setting button. It's caused by UAC. Please see details at http://msdn.microsoft.com/en-us/library/bb630430.aspx
    Have fun with Reporting Service
    Sunday, August 8, 2010 12:17 PM
  • I added http://localhost as a trusted site. I can get to http://localhost/reports running ie8 either as admin or not but still only see Home|My Subscriptions|Help. The directions next step is to start report manager and click Folder Setting which I can't see! When I connect to reporting services with SSMS I only see Jobs, Security and Shared Schedules folders. Should there be a Home folder visible also?

    Sunday, August 8, 2010 3:46 PM
  • Try opening the IE with Run As Admin option. Sometimes this could be the problem.Even I got similar permission issues but my case was different. It was giving access issue for the reporting server.
    Phani Note: Please mark the post as answered if it answers your question.
    Sunday, August 8, 2010 3:48 PM
  • Did that. Can get to report manager but only see Home|My Subscriptions|Help, no other links.
    Sunday, August 8, 2010 6:44 PM
  • Hi MyMathHelper,

    Try to disable UAC, and follow http://msdn.microsoft.com/en-us/library/ms167305.aspx to create a report and deploy it to report server, then to refresh the report manager website to see what are there.

    thanks,
    Jerry

    • Marked as answer by Jerry Nee Friday, August 13, 2010 7:31 AM
    Monday, August 9, 2010 6:08 AM
  • Are you able to connect to report server??

    open the internet explorer as admin and then connect to report manager. Click on the setting links and add yourself as user with system admin and click on folder setting folder and give permission to your ID as content manager. Add the http://localhost/reports to trusted sites.

    Then you will be able to connect to the report manager.

    Monday, August 9, 2010 6:15 AM