locked
Build Agent VM Template Issue RRS feed

  • Question

  • So I set up my initial build server with build agents software, deleted the build agents,  then unregistered the build service and then made a template from the VM. The original VM works fine the build agents connect 100%. The problem is now trying to use the template to create a second build server I cannot get the agents to connect. The build service keeps shutting itself off and then the agent give the could not connect to the build service message.

    I know this is configuration related ( Probably because TFS does not recognize the new server as new) because I can unregister and register it to my test TFS server (which never had the original build server hooked up) and it connects just fine. Also I have unregistered and deleted many times, once all the way to the controller, and it is just this machine that refuses to hook up to my production TFS. A couple of times (of the dozens) during the uninstall I got a message saying "there were things still associated with this, am I sure I want to delete". Since I have never been able to hook up successfully I am interpreting this to be from when I was first creating my template.

    Can anyone tell me how to get past this error and get my second build server running? How can I see if TFS still thinks this is the old build server? What info would it look at?

    The actual error is: "There was no endpoint listening at http://tfs2010build1:9191/Build/v3.0/Services/Controller/31 that could accept the message. This is often caused by an incorrect address or SOAP action" But none of the fixes listed on the internet have solved this issue.


    • Edited by AlexHutton Monday, February 18, 2013 10:51 PM
    Monday, February 18, 2013 10:50 PM

Answers

  • Hi AlexHutton,

    Thanks for your feedback!

    From a support perspective this is really beyond what I can do here in the forums. If you cannot determine your answer here or on your own, consider opening a support case with us. Visit this link to see the various support options that are available to better meet your needs:  http://support.microsoft.com/default.aspx?id=fh;en-us;offerprophone

    Hope it helps!

    Best Regards,


    Cathy Kong
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, March 4, 2013 3:04 AM
    Moderator

All replies

  • If you try to install the TFS Controller and Agent, does the wizard detect that the controllers and or the agents are installed on the machine? and asks you if you want to replace them?

    Ahmed is an independent consultant in Ottawa, Canada specialized in .NET, Biztalk, WCF, WPF, TFS and other Microsoft technologies.

    Blog: http://lajak.wordpress.com

    Twitter: ahmedalasaad

    Tuesday, February 19, 2013 2:48 AM
  • Hi AlexHutton,

    Thanks for your post!

    How about the issue, is it solved?

    Best Regards,


    Cathy Kong
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Tuesday, February 26, 2013 9:16 AM
    Moderator
  • Ahmed,

    As I have uninstalled, Reinstalled, and repaired these many times it does sometimes tell me that that agents and controllers exist (They shouldn't ) and ask if I want to replace them. I have chosen both to replace them and to not replace them and neither path seems to help.

    Tuesday, February 26, 2013 4:20 PM
  • No it is not solved, and for some reason I didn't get notified of Ahmed's post, but I did get notified of yours. This really driving me crazy, I have never had an issue before with agents and I have about 10 hours of work in this VM template with no desire to recreate it again.
    Tuesday, February 26, 2013 4:23 PM
  • Hi AlexHutton,

    Thanks for your feedback! 

    I recommend you install Team Foundation Server 2012 Power Tools to run a Complete Health Check or Team Foundation Build Health Check and see if it helps.

    Hope it helps!


    Cathy Kong
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    • Proposed as answer by Ahmed Al-Asaad Thursday, February 28, 2013 2:42 AM
    • Unproposed as answer by AlexHutton Thursday, February 28, 2013 5:19 PM
    Wednesday, February 27, 2013 8:34 AM
    Moderator
  • Well, this is 2010, not 2012 but I ran their BPA and it reported no issues that would seem to cause anything in the build system. Any other ideas? this bug is making me very upset, it is costing us a lot of time and energy.

    Again Steps:

    1. Create Build Server with all necessary software

    2. Register Build Service and test server.

    3. Once passed, unregister service

    4. Make template of VM

    5. Re-Register Build Service on original VM

    6. Make new VM off of template.

    7. Keep getting error message in 1st post because build service keeps stopping so agents cannot communicate

    Thursday, February 28, 2013 5:27 PM
  • Which virtual machine technology are you using (VMware, hyperv,..etc)?

    Which OS is installed on the VM?

    I am not a VM expert, could this be related to a SID conflict?


    Ahmed is an independent consultant in Ottawa, Canada specialized in .NET, Biztalk, WCF, WPF, TFS and other Microsoft technologies.

    Blog: http://lajak.wordpress.com

    Twitter: ahmedalasaad

    Monday, March 4, 2013 12:17 AM
  • I am using VMWare and vSphere with the Machine's OS being 2008 R2. I can tell you the machine has a unique name, IP, and NIC MAC within the network. What is a SID and how would I check it, a quick few internet searches don't show me anything about SID except one post about sysprep preventing a conflict. I assumed when the machine was created out of the template it went through sysprep but I will double check tomorrow.
    Monday, March 4, 2013 1:42 AM
  • Hi AlexHutton,

    Thanks for your feedback!

    From a support perspective this is really beyond what I can do here in the forums. If you cannot determine your answer here or on your own, consider opening a support case with us. Visit this link to see the various support options that are available to better meet your needs:  http://support.microsoft.com/default.aspx?id=fh;en-us;offerprophone

    Hope it helps!

    Best Regards,


    Cathy Kong
    MSDN Community Support | Feedback to us
    Develop and promote your apps in Windows Store
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.

    Monday, March 4, 2013 3:04 AM
    Moderator