locked
Fonts.. same old question any new answers? RRS feed

  • Question

  • Hi All,

     I've got a silverlight 1.0 app that needs to be converted to run locally. I've used the downloader to set fonts successfully for the web served version but have had to remove the downloader for the locally run version. I've noticed that by having the fonts in my project somewhere Expression Design will find them and allow me to set the font in my XAML. BUT when i run the "app" locally the font is not set. Anyone have any clue? Some specific way to assign a font without using a downloader? Like i said, Ex Design seems to pick it up fine.. Thanks!

    Wednesday, February 20, 2008 11:37 AM

Answers

  • Unfortunately if you want to use custom fonts, you’ll have to use downloader, which can’t be used in disconnected scenarios. Expression Design is built with WPF, which doesn’t have this limit. If you don’t need to set the texts dynamically, one work round is to convert the texts to graphics. In Expression Design, select your text, from “Object” menu, choose “Convert Object to Path”.

    Friday, February 22, 2008 12:08 AM

All replies

  • have had to remove the downloader for the locally run version.
     

    Don't remove the downloader for the locally run version. You should install IIS or Apache on your machine and run your SL application from IIS or Apache.  

    Wednesday, February 20, 2008 11:46 AM
  • Hi Michael, i wish it were an option.. but it ain't! Smile .. I actually had this working, setting the font

    FontFamily="./#Segoe UI"

    But it was still being served (without the downloader).. somehow i've broken it.

    Wednesday, February 20, 2008 11:49 AM
  • Unfortunately if you want to use custom fonts, you’ll have to use downloader, which can’t be used in disconnected scenarios. Expression Design is built with WPF, which doesn’t have this limit. If you don’t need to set the texts dynamically, one work round is to convert the texts to graphics. In Expression Design, select your text, from “Object” menu, choose “Convert Object to Path”.

    Friday, February 22, 2008 12:08 AM
  • Thanks, i've come to the same conclusion. Thanks for clarifying the reason why it works in Blend though. How do i mark this answered?

    Friday, February 22, 2008 9:26 AM
  • How do i mark this answered?
     

    There should be "Mark as answered"  link beside "Reply" link at the right side of the post.

    Saturday, February 23, 2008 1:15 PM