locked
Resolving LocalHost through ActiveSync RRS feed

  • Question

  • Hello,  hope I'm in the right forum.
    Im having some difficulty accessing my .Net project in IE Mobile when using a real device.
    When I'm using the Microsoft Device Emulator V3 (9.0.21022.8).  I'm loading up the USA Windows Mobile 5.0 Pocket PC R2 Emulator image and cradling it in ActiveSync.  From here, I am able to access my Visual Studios Project by resolving the URL in IE Mobile.  Im using the URL:  http://192.168.0.141:2552/projectname/project.aspx .  This comes up swimmingly, I can access the development server on the PC as well as any other websites.

    The problem is, when I connect an actual device running windows mobile 5 to the PC using activesync... I am unable to bring up the same URI in IE Mobile.  (does not resolve, connection is lost eventually), but I can in fact bring up web pages ok.  Im not sure what I should be using for the URI, I have tried replacing the IP with the PC name, as well as localhost.. but neither will work.  Any ideas what i should be using here?  I figured if the emulator can connect through activesync fine, I should be able to use a real device (with the same OS) as well....

    Other info:
    ActiveSync Version 4.5.0
    Connection Setting: DMA
    Windows Version XP, on Domain

    Any help would be appreciated,
    Thanks
    Wednesday, July 22, 2009 3:09 PM

Answers

  • This does not resolve the issue.  I think it might be domain related, so I'm going to move my setup to a different computer and retry.

    Update: After moving to a new setup (vista), ive decided to host locally on IIS instead of visual studios development server.
    This has seemed to resolve the issue. 
    • Marked as answer by Shadowrift Tuesday, August 11, 2009 5:10 PM
    Thursday, July 30, 2009 5:11 PM

All replies

  • Try resolving the ppp_peer IP address rather than localhost. Or run ipconfig on the desktop when your device is connected via ActiveSync and see what other IP addresses you get.

    --

    Ginny Caughey
    Device Application Development MVP
     
     
    "Shadowrift" wrote in message news:0d8b2cd8-8651-44b 6-981c-a133fc7ed1c0...
    Hello,  hope I'm in the right forum.
    Im having some difficulty accessing my ..Net project in IE Mobile when using a real device.
    When I'm using the Microsoft Device Emulator V3 (9.0.21022.8).  I'm loading up the USA Windows Mobile 5.0 Pocket PC R2 Emulator image and cradling it in ActiveSync.  From here, I am able to access my Visual Studios Project by resolving the URL in IE Mobile.  Im using the URL:  http://192.16 8.0.141:2552/projectname/project.aspx .  This comes up swimmingly, I can access the development server on the PC as well as any other websites.

    The problem is, when I connect an actual device running windows mobile 5 to the PC using activesync... I am unable to bring up the same URI in IE Mobile.  (does not resolve, connection is lost eventually), but I can in fact bring up web pages ok.  Im not sure what I should be using for the URI, I have tried replacing the IP with the PC name, as well as localhost.. but neither will work.  Any ideas what i should be using here?  I figured if the emulator can connect through activesync fine, I should be able to use a real device (with the same OS) as well....

    Other info:
    ActiveSync Version 4.5.0
    Connection Setting: DMA
    Windows Version XP, on Domain

    Any help would be appreciated,
    Thanks
    Wednesday, July 22, 2009 3:18 PM
    1. Is there a way to get the ppp_peer IP address from the pocket pc without deploying a Pocket PC application to it?  Ive tried the ipconfig on the desktop and received the following:
                           ipconfig

      At which point I have tried to resolve the following URI's from the Pocket PC to access the project.aspx on the development server on the PC:
    2. http://192.168.0.141:2552/projectname/project.aspx
      http://192.168.0.1:2552/projectname/project.aspx
      http://192.168.0.100:2552/projectname/project.aspx
    3. http://169.254.2.2:2552/projectname/project.aspx
      http://169.254.2.1:2552/projectname/project.aspx
    4. None of which will resolve.
    Wednesday, July 22, 2009 8:10 PM
  • Hi Shadowrift ,

    Please use the PC name instead, like the link:
    http://jso2:2552/projectname/project.aspx
    Please remember to mark the replies as answers if they help and unmark them if they provide no help
    Friday, July 24, 2009 7:07 AM
  • This does not resolve the issue.  I think it might be domain related, so I'm going to move my setup to a different computer and retry.

    Update: After moving to a new setup (vista), ive decided to host locally on IIS instead of visual studios development server.
    This has seemed to resolve the issue. 
    • Marked as answer by Shadowrift Tuesday, August 11, 2009 5:10 PM
    Thursday, July 30, 2009 5:11 PM
  • Hey can you please tell me how can I configure my device emulator in vs 2008 to run a mobile web application on the local iis server?thanks!!!
    Saturday, March 12, 2011 2:49 PM