locked
How do I get presence to show correctly in a Site Users web part RRS feed

  • Question

  • I've added a Site Users web part to my top level site but all the users show as Not Online even when they are.

    If I hover over the bubble they all say sip:firstname.lastname@abc.com is not an online contact.

    It's my understanding that SharePoint gets information from Office Communicator. We are using OC 2007 and Outlook 2003 if that makes any difference. 

    Any help would be appreciated

    Peter

    Monday, April 2, 2012 1:53 PM

Answers

  • Hi Peter_Atherton,

    If you can't access AD group, you can do it as the following .

    1) Go to Central Administration

    2) Select Application Management

    3) Under SharePoint Web Application Management select Web application

    general settings

    4) On the Web Application General Settings page set the web application to

    the problem web application

    5) Select Yes for Enable Person Name smart tag and Online Status for members

    If the option above is configured properly, please continue to perform the

    following steps:

    - Browse the SharePoint site and click on Site Action-Site setting-People

    and Groups.

    - Then click Setting-List Settings.

    - Click on Detail view and check following

    o SIP Address

    o Work e-mail

    - Then click on ok to come back to People and Groups.

    - Now we need to make sure that both SIP address and Work e-mail are set

    for user.

    - The SIP address is obtained from active directory and in SharePoint it

    imported when we do a profile import.

    - If we are not importing the profile in SharePoint and we manually adding

    the profile then we have to manually enter the SIP address.

    - To add the SIP address manually

    o Go to Shared Services Administration: <shared service provider name

    associated to your application> > User Profile and Properties > View User

    Profiles

    o Click Edit a user profile and check the SIP Address field and if this

    blank enter the SIP address.

    - If you manually edit the SIP address, we need to wait for some time

    (usually 5 minutes) for the change to be reflected before it is

    synchronized to the MOSS data

    You can refer to the following link.

    http://social.msdn.microsoft.com/Forums/ar/sharepointcustomization/thread/faf20f42-2dab-4c3f-a29c-97dba2e807a8

    Thanks,

    Jack


    Friday, April 13, 2012 1:58 AM
    Moderator

All replies

  •  

    Hi Peter_Atherton,

    You should add the users SIP(Session Initiation Protocol) address field populated in AD.To display online status, the presence feature uses a Session Initiation Protocol (SIP) address to communicate with the instant messaging client. If a SIP address is not available, a .NET address (MSNMessenger) or an Exchange Instant Messaging address (Windows Messenger) can be configured on an individual basis. However, only SIP addresses can take advantage of additional presence features, such as the ability to send and receive e-mail and to display free/busy information from the online status indicator.

    For more information, please refer to the following article:

    http://technet.microsoft.com/en-us/library/cc262338.aspx

    Thanks,

    Jack

    Thursday, April 5, 2012 3:07 AM
    Moderator
  • The problem is a disconnect between OC and the web part. The only thing I have control over is the SharePoint site. I have no access to AD other than as a user so I'm not able do do any of the above.

    Thanks anyway,

    Peter

    Thursday, April 12, 2012 4:57 PM
  • Hi Peter_Atherton,

    If you can't access AD group, you can do it as the following .

    1) Go to Central Administration

    2) Select Application Management

    3) Under SharePoint Web Application Management select Web application

    general settings

    4) On the Web Application General Settings page set the web application to

    the problem web application

    5) Select Yes for Enable Person Name smart tag and Online Status for members

    If the option above is configured properly, please continue to perform the

    following steps:

    - Browse the SharePoint site and click on Site Action-Site setting-People

    and Groups.

    - Then click Setting-List Settings.

    - Click on Detail view and check following

    o SIP Address

    o Work e-mail

    - Then click on ok to come back to People and Groups.

    - Now we need to make sure that both SIP address and Work e-mail are set

    for user.

    - The SIP address is obtained from active directory and in SharePoint it

    imported when we do a profile import.

    - If we are not importing the profile in SharePoint and we manually adding

    the profile then we have to manually enter the SIP address.

    - To add the SIP address manually

    o Go to Shared Services Administration: <shared service provider name

    associated to your application> > User Profile and Properties > View User

    Profiles

    o Click Edit a user profile and check the SIP Address field and if this

    blank enter the SIP address.

    - If you manually edit the SIP address, we need to wait for some time

    (usually 5 minutes) for the change to be reflected before it is

    synchronized to the MOSS data

    You can refer to the following link.

    http://social.msdn.microsoft.com/Forums/ar/sharepointcustomization/thread/faf20f42-2dab-4c3f-a29c-97dba2e807a8

    Thanks,

    Jack


    Friday, April 13, 2012 1:58 AM
    Moderator
  • Really Helpful.. Thanks a ton !! I checked and found that User SIP address was missing from User profiles. I added manually and waited for next incremental crawl.


    Wednesday, December 26, 2012 10:56 AM