none
TI Omap 3530 EVM(WEC 7) bsp os image is not booting up on Devkit8000 board which is TI's Omap 3530 series!!! RRS feed

  • Question

  • Hi,

    Am new to WEC 7. I have worked on Win CE 6.0 R2. I had Devkit 8000 board which is TI's Omap 3530 board. With the board they have provided the BSP for Devkit board. Using that i have created OS image and booted up the board.

    Now, i need to boot up Devkit 8000 board using Windows Embedded Compact 7 os image.

    So i created an image with TI Omap 3530 EVM BSP and i tried to boot up the board using memory card. But the board is not booting up.

    Here am attaching the logs which i took using Hyper Terminal. If anyone came to know cause for the failure please guide me up...

    40W
    Texas Instruments Windows CE SD X-Loader for EVM 3530
    Built Feb  9 2012 at 18:01:52
    Version 6.13.00
    open ebootsd.nb0 file
    Init HW: controller RST
    read ebootsd.nb0 file
    jumping to ebootsd image

    Microsoft Windows CE Bootloader Common Library Version 1.4 Built Feb  9 2012 17:
    57:27

    Texas Instruments Windows CE EBOOT for Mistral OMAP EVM, Built Feb  9 2012 at 18
    :01:47
    EBOOT Version 1.5, BSP 6.13.00

    TI OMAP3530 Version 0x4b7ae02f (ES3.1)
    TPS659XX Version 0x10 (Unknown)
    System ready!
    Preparing for download...
    INFO: Predownload....
    WARN: Boot config wasn't found, using defaults
    INFO: SW4 boot setting: 0x2f

    >>> Forcing cold boot (non-persistent registry and other data will be wiped) <<<

    Hit space to enter configuration menu 5...
    Hit space to enter configuration menu 4...
    Hit space to enter configuration menu 3...

    --------------------------------------------------------------------------------

     Main Menu
    --------------------------------------------------------------------------------

     [1] Show Current Settings
     [2] Select Boot Device
     [3] Select KITL (Debug) Device
     [4] Network Settings
     [5] SDCard Settings
     [6] Set Device ID
     [7] Save Settings
     [8] Flash Management
     [0] Exit and Continue

     Selection: 1

     Main:
      Boot device:   LAN9115 MAC
      Debug device:  LAN9115 MAC
      Device ID:     0

     SDCard:
      Filename:      "nk.bin"

     Network:
      KITL state:    enabled
      KITL type:     active
      KITL mode:     interrupt
      DHCP:          enabled
      IP address:    0.0.0.0
      IP mask:       0.0.0.0
      IP router:     0.0.0.0
      Eth MAC Addr:  Invalid Ethernet chip ID (0x0)!
    Controller not found!
      VMINI:         enabled
      Note: USBFN RNDIS MAC Addr cannot be changed.

    --------------------------------------------------------------------------------

     Main Menu
    --------------------------------------------------------------------------------

     [1] Show Current Settings
     [2] Select Boot Device
     [3] Select KITL (Debug) Device
     [4] Network Settings
     [5] SDCard Settings
     [6] Set Device ID
     [7] Save Settings
     [8] Flash Management
     [0] Exit and Continue

     Selection: 2

    --------------------------------------------------------------------------------

     Select Boot Device
    --------------------------------------------------------------------------------

     [1] LAN9115 MAC
     [2] USBFn RNDIS
     [3] NK from SDCard FILE
     [0] Exit and Continue

     Selection (actual LAN9115 MAC): 3
     Boot device set to NK from SDCard FILE

    --------------------------------------------------------------------------------

     Main Menu
    --------------------------------------------------------------------------------

     [1] Show Current Settings
     [2] Select Boot Device
     [3] Select KITL (Debug) Device
     [4] Network Settings
     [5] SDCard Settings
     [6] Set Device ID
     [7] Save Settings
     [8] Flash Management
     [0] Exit and Continue

     Selection: 5

    --------------------------------------------------------------------------------

     SDCard Settings
    --------------------------------------------------------------------------------

     [1] Show Current Settings
     [2] Enter Filename
     [0] Exit and Continue

     Selection: 1

     SDCard:
      Filename:      "nk.bin"

    --------------------------------------------------------------------------------

     SDCard Settings
    --------------------------------------------------------------------------------

     [1] Show Current Settings
     [2] Enter Filename
     [0] Exit and Continue

     Selection: 0

    --------------------------------------------------------------------------------

     Main Menu
    --------------------------------------------------------------------------------

     [1] Show Current Settings
     [2] Select Boot Device
     [3] Select KITL (Debug) Device
     [4] Network Settings
     [5] SDCard Settings
     [6] Set Device ID
     [7] Save Settings
     [8] Flash Management
     [0] Exit and Continue

     Selection: 0
    Init HW: controller RST

    BL_IMAGE_TYPE_BIN

    Download file information:
    -----------------------------------------------------------
    [0]: Address=0x8c000000  Length=0x026b6ab0  Save=0xa0000000
    -----------------------------------------------------------
    Download file type: 1
    rom_offset=0x0.
    ImageStart = 0x8c000000, ImageLength = 0x26b6ab0, LaunchAddr = 0x8c00bf00

    Completed file(s):
    -------------------------------------------------------------------------------
    [0]: Address=0x8c000000  Length=0x26b6ab0  Name="" Target=RAM
    ROMHDR at Address 8C000044h
    Launch Windows CE image by jumping to 0xa000bf00...

    Windows CE Kernel for ARM (Thumb Enabled)
    --- High Performance Frequecy is 32768 khz---
    DeviceId................. EVM3530-
    pArgs->flags............. 0x2D
    pArgs->devLoc.IfcType.... 0
    pArgs->devLoc.LogicalLoc. 0x15000000
    pArgs->devLoc.PhysicalLoc 0x0
    pArgs->devLoc.Pin........ 0
    pArgs->ip4address........ 0
    pDevice->Name............  s
    pDevice->ifcType......... 0
    pDevice->id.............. 0x15000000
    pDevice->resource........ 0
    pDevice->type............ 2
    pDevice->pDriver......... 0x8E6D1000
    g_kitlLock = 0x8E718BE0
    Invalid Ethernet chip ID (0x0)!
    ERROR: KITL call to pfnInit failed

    OEMKitlInit failed - trying again.

    Monday, February 13, 2012 7:22 AM

All replies

  • So you are using TI EVM BSP to DevKit 8000. Am i right?

    Did you check the hardware differences between these two development kit? it seems the Devkit8000 using different ethernet controller and it is not the same as TI EVM development kit. if two hardwares are different, you may have to do some BSP porting work based on the hardware changes.


    Vinoth.R http://vinoth-vinothblog.blogspot.com http://www.e-consystems.com

    Monday, February 13, 2012 4:59 PM
  • Hi Vinoth,

    Thanks for the reply.

    Ya, am using TI Omap 3530 EVM BSP to Devkit8000 board. As am new to this, i thought Microsoft provided this BSP to support TI Omap 3530 processor family completely.

    Is there any link or document which explains how to port the changes which u mentioned above?

    Tuesday, February 14, 2012 4:48 AM
  • Hi All,

    I found Devkit8000 is using DM9000A ethernet controller and TI EVM development kit supports SMSC LAN 9115 ethernet port.

        Anyone please suggest me how can i make TI EVM bsp os image supports DM9000A ethernet?

    Thursday, February 16, 2012 7:05 AM