none
Cannot create an MVC Web Application Project

    Question

  • Whenever I try to create a new MVC web application project using VS 2015, I get an instant "The system could not find the file specified" error.

    I am running Windows 10 and have tried repairing the VS installation 3 times and completely uninstalling and re-installing once to no effect.

    Any thoughts on how to fix this problem?

    Is there anything further I can provide to assist in a resolution?

    These days it seems I spend more time trying to fix visual studio/windows 10 issues than I do programming.


    • Edited by The Haunt Monday, January 25, 2016 5:04 AM corrected error message text
    Monday, January 25, 2016 5:01 AM

Answers

All replies

  • Hi Haunt,

    Thanks for your post.

    Could you please tell me when did you get the error?  Does the error occurred when only creating a MVC project or dong other things like building?

    I did a test in my side using VS2015 Update 1 in Windows 10 and I can create the MVC project successfully.

    So first I suggest you could try to run your Visual Studio in Safe mode to Check whether some add-ins and extensions affect it(devenv /safemode).

    Also Try to restore Visual Studio default settings using this command: “devenv.exe /resetsettings”.

    In addition, I suppose the test template was missing or not installed or some problem occurred

    You could try to restore the template in VS2015 with the following steps then try it again.

    1. Delete the ItemTemplatesCache, ProjectTemplatesCache folder (C:\Program Files (x86)\Microsoft Visual Studio 14.0\Common7\IDE)

    2. In the command prompt, navigate to the location of devenv.exe. This file is located in <Visual Studio Installation Path>\Common7\IDE.

    3. Type "devenv /installvstemplates" and press Enter.

    If above suggestion still no help .May be something wrong with your Visual Studio.

    In this case, I suggest you could uninstall all the Visual Studio. And install the VS2015 Update 1 and select "Microsoft Web Developer tools" then install it .

    Hope that could be helpful to you.

    Best Regards,

    Lake Xiao


    Tuesday, January 26, 2016 5:54 AM
    Moderator
  • Thank you for your reply.  I have tried each of your suggestions except the last and none have resolved the issue.

    For some reason trying to run "devenv /installvstemplates" results in a message stating the operation could not be completed.

    I am in the process of removing the web tools from VS.  Once that is finished I will try adding them again.

    If that fails then I will have to try installing VS for the third time.

    In your screen cap, I see you have "Universal Windows app development tools" selected.  I have not installed this.  It isn't required for MVC projects to work, is it?

    Thursday, January 28, 2016 9:56 PM
  • An interesting development!  I can't uninstall Visual Studio 2015 due to a fatal error in Microsoft Agent for Visual Studio 2015 Preview!  Hooray!

    I am now trying to repair my installation so I can uninstall it.  How far down does this rabbit hole of endless non-productivity go!

    Thursday, January 28, 2016 10:44 PM
  • Ok, so after a round of automatic uninstall -> repair repeat, I was finally able to remove VS 2015 using the info found here:

    http://stackoverflow.com/a/28731368/1781344

    I will now attempt a fresh re-install.

    Friday, January 29, 2016 12:40 AM
  • Hi Haunt,

    Thanks for your update.

    if after re-install. You still can't create an MVC Web Application in your Visual Studio.

    I think there might be something wrong with your Visual Studio installation package.

    If possible, please share us the installation log of your Visual Studio.

    I will check the installation log of your Visual Studio and check if there is some error during your VS installation.

    I suggest you could use the   collect.exe  tool to collect the installation logs. After using it, you will find vslogs.cab from %temp% folder.

    Then  upload the file to  https://onedrive.live.com/  and share link here.

    Best Regards,

    Lake Xiao

    Friday, January 29, 2016 1:33 AM
    Moderator
  • After a full re-install from a mounted iso the problem is finally resolved.
    • Proposed as answer by lake XiaoModerator Monday, February 15, 2016 1:35 AM
    • Marked as answer by The Haunt Monday, February 15, 2016 6:01 PM
    Friday, February 12, 2016 5:11 PM
  • Hi Haunt,

    Glad to hear you have solved your issue.

    If possible, please mark the reply as the answer which is helpful, so it would be helpful for other members who get the same issue as yours to research and find the answer directly, and I could close this case.

    Have a nice day.

    Best Regards,

    Lake Xiao

    Monday, February 15, 2016 1:35 AM
    Moderator