none
SharePoint 2013 send Welcome Email RRS feed

  • Question

  • Hi,

    at the beginning - my english is not good. Sorry.

    I have a trouble... When I get some permissions in SharePoint, and i check "Send Welcome E-mail...", Message is sent when I'm logged as Farm Administrator (System Account). User get Welcome E-mail from "sharepoint@domain.com". When I'm logged as I (my domain account) with permissions "Administrator Collection sites" Message is not sent, why?

    I'd like to set sent WelcomeMessage from e-mail "sharepoint@domain.com". Can I set on permanently? Maybe in some file?

    Thanks! Kobi55

    Thursday, May 12, 2016 10:01 AM

All replies

  • Hi Kobi,

    From your description, when you use farm account to grant users permissions, it would send email, however, if you use another user, no email was sent. Is it right?

    What is "Administrator Collection sites"? Is it Site collection administrator?

    When you grant a user permission using the domain account, please make sure you have checked "Send Welcome E-mail". And also make sure the user who is granted permissions has a valid email address.

    In addition, when you grant users permissions, check if there is an error or warning displaying. If yes, please provide it and also check ULS log to find more information about this issue.

    Thanks,

    Wendy


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Friday, May 13, 2016 8:27 AM
    Moderator
  • "From your description, when you use farm account to grant users permissions, it would send email, however, if you use another user, no email was sent. Is it right?"

    -Yes.

    What is "Administrator Collection sites"? Is it Site collection administrator?

    -Is it Site Collection Administrator.

    When you grant a user permission using the domain account, please make sure you have checked "Send Welcome E-mail". And also make sure the user who is granted permissions has a valid email address.

    - All is ok.

    In addition, when you grant users permissions, check if there is an error or warning displaying. If yes, please provide it and also check ULS log to find more information about this issue.

    - 0 errors and logs are empty.

    Thanks,

    Kobi

    Monday, May 16, 2016 7:49 AM
  • Hi Kobi,

    Please check the followings:

    1. Try to grant permission to different users, check if all users don't receive the email.

    2. Outgoing setting in CA->System Settings->Configure Outgoing email settings and CA->Manage web applications->[your web application]->General Settings->Outgoing email.

    3. Track Mail server if the email is getting delievered and not rejected by mail server

    4. Rules on mailbox receiving email- Junk email folder etc.

    Thanks,

    Wendy


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Thursday, May 19, 2016 8:02 AM
    Moderator
  • Hi Kobi,

    If you are relaying through local server, in your iis 6.0 management console, ensure the outbound security is set to anonymous.

    Also try to send a test mail from Telnet from the SharePoint server runs SMTP Service using your failed accounts.Below is the telnet command.

    ehlo mail.sample.com

    mail from: fromaddress@sample.com

    rcpt to: toaddress@sample.com

    data

    Subject: this is a test mail

    Enter

    .

    Enter


    Thursday, May 19, 2016 8:26 AM
  • Hi,

    we must sent this message with Authentication.

    Monday, May 30, 2016 1:02 PM