locked
Custom templates XML-files RRS feed

  • Question

  • User-955326108 posted

    Hello,

    Having some problems deploying custom templates and since Excel templates also show in Word.

    If I understood the instructions correctly the XML files that point towards the templates should be formatted in the following manner:

      <?xml version="1.0" encoding="utf-8" ?> 
    - <o:featuredcontent lcid="1053" xmlns:o="urn:schemas-microsoft-com:office:office">
    - <o:application id="WD">
    - <o:featuredtemplates startdate="2009-01-01" enddate="2020-03-02">
    - <o:featuredtemplate title="Template1.dotx" source="http://location/template1.dotx">
      <o:media mediatype="gif" filename="1.gif" source="http://location/thumbnails/templateTh.gif" /> 
      <o:preview filename="1big.gif" source="http://location/thumbnails/templatePv.gif" /> 
      </o:featuredtemplate>
    - <o:featuredtemplate title="template2.dotx" source="http://location/template2.dotx">
      <o:media mediatype="gif" filename="1.gif" source="http://location/thumbnails/templateTh.gif" /> 
      <o:preview filename="1big.gif" source="http://location/thumbnails/templatePv.gif" /> 
      </o:featuredtemplate>
      </o:featuredtemplates>
      </o:application>
    - <o:application id="XL">
    - <o:featuredtemplates startdate="2009-01-01" enddate="2020-03-02">
    - <o:featuredtemplate title="Excel Template 1.xltx" source="http://location/XlTemplate1.xltx">
      <o:media mediatype="gif" filename="1.gif" source="http://location/thumbnails/templateTh.gif" /> 
      <o:preview filename="1big.gif" source="http://location/thumbnails/templatePv.gif" /> 
      </o:featuredtemplate>
    - <o:featuredtemplate title="Excel Template 2.xltx" source="http://location/XlTemplate2.xltx">
      <o:media mediatype="gif" filename="1.gif" source="http://location/thumbnails/templateTh.gif" /> 
      <o:preview filename="1big.gif" source="http://location/thumbnails/templatePv.gif" /> 
      </o:featuredtemplate>
      </o:featuredtemplates>
      </o:application>
    - <o:application id="PP">
      <o:featuredtemplates startdate="2009-01-01" enddate="2020-03-02" /> 
      </o:application>
      </o:featuredcontent>
     
    The above XML of course is cut down since the list is pretty large for some folders. In total there are 11 separate XML-files being generated all added under their separate key in the registry .
    Everything works fine, I get the submenus under the "custom" tab, until you notice that the Excel templates show in Word as well? The word templates, on the other hand, is not shown in Excel as expected.
    What's wrong with the above XML file?
     
    Cheers!
    /Eskil
    Wednesday, December 2, 2009 7:15 AM

All replies

  • User-955326108 posted

    Update:

    Seems like these XML files get cached locally by Office...anyone knows how to clear this cache? 

    Friday, December 4, 2009 3:40 PM
  • User-955326108 posted

    Finally solved this.

    The only way I got it working was splitting everything up.

    Use application="WD" , application="XL" and so on.

    Split into different XML files for each application. This way I get decent results, although I still get repititions of some documents in Word (the XML file do not contain these duplicates).

    At least now I can launch this as it's only 2 files out of 100 that get's duplicated once.

    Cheers!

    /Eskil

    Monday, December 7, 2009 6:22 AM