locked
Cannot log into SQL Server 2008 using both Windows Authentication and SQL Server Authentication ...Need Help ! RRS feed

  • Question

  • Hi All
    Thank You for taking the time. I recently installed MSSQL Server 2008 on a Windows2008 server. I could log into the SQL Server2008 earlier. For some reason I am unable to login now using both Windows Authentication or SQL server authentication. Getting error code 18456
    Sunday, February 14, 2010 5:11 PM

Answers

  • The state of this 18456 error is important. However, you always receive this "Logon Error: 18456" error message that has a state set to 1 in the client application.

    To increase security, the error message that is returned to the client deliberately hides the nature of the authentication error by always setting the state of the 18456 error to 1.

    By default, auditing of failed logins is enabled. In this case, the true state of the 18456 error is reported in the SQL Server Error Log file

     

    So see the error log file for the STATE of this error 18456 from the default path

    C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\LOG\ERRORLOG

      And the entry for this login failed error in the error log would be something like this

     

    2009-10-08 11:14:18.440    Logon    Error: 18456, Severity: 14, State: 8.
    2009-10-08 11:14:18.440    Logon    Login failed for user 'leks'. [CLIENT: ]

     

    I have documented all the states with its cause and resolution in this article in my website

     

    http://sql-articles.com/articles/troubleshooting/troubleshooting-login-failed-error-18456


    Thanks, Leks
    Monday, February 15, 2010 3:54 AM

All replies

  • The state of this 18456 error is important. However, you always receive this "Logon Error: 18456" error message that has a state set to 1 in the client application.

    To increase security, the error message that is returned to the client deliberately hides the nature of the authentication error by always setting the state of the 18456 error to 1.

    By default, auditing of failed logins is enabled. In this case, the true state of the 18456 error is reported in the SQL Server Error Log file

     

    So see the error log file for the STATE of this error 18456 from the default path

    C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\LOG\ERRORLOG

      And the entry for this login failed error in the error log would be something like this

     

    2009-10-08 11:14:18.440    Logon    Error: 18456, Severity: 14, State: 8.
    2009-10-08 11:14:18.440    Logon    Login failed for user 'leks'. [CLIENT: ]

     

    I have documented all the states with its cause and resolution in this article in my website

     

    http://sql-articles.com/articles/troubleshooting/troubleshooting-login-failed-error-18456


    Thanks, Leks
    Monday, February 15, 2010 3:54 AM
  • The state of this 18456 error is important. However, you always receive this "Logon Error: 18456" error message that has a state set to 1 in the client application.

    To increase security, the error message that is returned to the client deliberately hides the nature of the flac authentication error by always setting the state of the 18456 error to 1.

    By default, auditing of failed logins is enabled. In this case, the true state of the 18456 error is reported in the SQL Server Error Log file

     

    So see the error log file for the STATE of this error 18456 from the default path

    C:\Program Files\Microsoft SQL Server\MSSQL.1\MSSQL\LOG\ERRORLOG

      And the entry for this login failed error in the error log would be something like this

     

    2009-10-08 11:14:18.440    Logon    Error: 18456, Severity: 14, State: 8.
    2009-10-08 11:14:18.440    Logon    Login failed for user 'leks'. [CLIENT: ]

     

    I have documented all the states with its cause and resolution in this article in my website

     

    http://sql-articles.com/articles/troubleshooting/troubleshooting-login-failed-error-18456


    Thanks, Leks

    Your article is wonderful, Thanks a lot!
    Monday, August 9, 2010 10:38 AM