none
video player doesn't work RRS feed

  • Question

  • Hi,

    I have added a video player to  my image but it can only play wmv files all other formats cannot be played. Also I have added all possible catalog items related to video/media. It cannot even play a video (venice.mpg) that comes with WEC7. Any ideas what is wrong there? This is a debug output for venice.mpg:

    PID:02C5012E TID:03FD014A [XR] ImageFactory::PrintImageFormat - PixelFormat: GUID_WICPixelFormat32bppBGRA
    PID:02C5012E TID:03FD014A [XR] ImageFactory::PrintImageFormat - PixelFormat: GUID_WICPixelFormat32bppBGRA
      KdTrap: JIT debugging requested, waiting for OEM selection
      KdTrap: JIT debugging accepted
    PID:02C5012E TID:03D5016A DEBUG_BREAK @4503fa30 Ignored.
      KdTrap: JIT debugging requested, waiting for OEM selection
      KdTrap: JIT debugging accepted
    PID:02C5012E TID:03FD014A DEBUG_BREAK @000287b8 Ignored.
    PID:00400002 TID:03D5016A OSAXST1: >>> Loading Module 'quartz.dll' (0xBFC92EA8) at address 0x445D0000-0x44A8D000 in Process 'NK.EXE' (0x8ACBAAD0)
    PID:02C5012E TID:03D5016A OSAXST1: >>> Loading Module 'quartz.dll' (0xBFC92EA8) at address 0x445D0000-0x44A8D000 in Process 'vplayer.exe' (0xBFC7A210)
    PID:02C5012E TID:03D5016A OSAXST1: >>> Loading Module 'waveapic.dll' (0xBFC53794) at address 0x41180000-0x411AF000 in Process 'vplayer.exe' (0xBFC7A210)
    PID:02C5012E TID:03D5016A ERROR: d:\chelanrtm14\private\directx\dshow\filters\demultiplexer\mpeg2\src\filter.cpp(2432); no pins
    PID:02C5012E TID:03D5016A ERROR: d:\chelanrtm14\private\directx\dshow\filters\demultiplexer\mpeg2\src\pin_out.cpp(691); output pin is not connected
    PID:02C5012E TID:03D5016A ERROR: d:\chelanrtm14\private\directx\dshow\filters\demultiplexer\mpeg2\src\pin_out.cpp(728); output pin is not connected
    PID:02C5012E TID:03D5016A ERROR: d:\chelanrtm14\private\directx\dshow\filters\demultiplexer\mpeg2\src\filter.cpp(2472); "Mpeg-1" not found
    PID:02C5012E TID:03D5016A ERROR: d:\chelanrtm14\private\directx\dshow\filters\demultiplexer\mpeg2\src\pin_out.cpp(691); output pin is not connected
    PID:02C5012E TID:03D5016A ERROR: d:\chelanrtm14\private\directx\dshow\filters\demultiplexer\mpeg2\src\pin_out.cpp(728); output pin is not connected
    PID:02C5012E TID:03D5016A ERROR: d:\chelanrtm14\private\directx\dshow\filters\demultiplexer\mpeg2\src\pin_out.cpp(691); output pin is not connected
    PID:02C5012E TID:03D5016A ERROR: d:\chelanrtm14\private\directx\dshow\filters\demultiplexer\mpeg2\src\pin_out.cpp(728); output pin is not connected
    PID:00400002 TID:03D5016A OSAXST1: >>> Loading Module 'imaadpcm.dll' (0xBFC97F50) at address 0x44DF0000-0x44DF9000 in Process 'NK.EXE' (0x8ACBAAD0)
    PID:02C5012E TID:03D5016A OSAXST1: >>> Loading Module 'imaadpcm.dll' (0xBFC97F50) at address 0x44DF0000-0x44DF9000 in Process 'vplayer.exe' (0xBFC7A210)
    PID:02C5012E TID:03D5016A [WARNING] No Error
    PID:02C5012E TID:03D5016A RegOpenKeyEx failed lResult = 2
    PID:02C5012E TID:03D5016A CheckMediaType failed: Format Type is not FORMAT_VideoInfo | FORMAT_VideoInfo2
    PID:02C5012E TID:03D5016A CVMRFilter::CheckMediaType: Exiting, hr = 0x8004022a
    PID:02C5012E TID:03D5016A CheckMediaType failed on Pin 0 rc=0X8004022A
    PID:02C5012E TID:03D5016A CVMRInputPin::CheckMediaType: Exiting, hr = 0x8004022a
    PID:02C5012E TID:03D5016A ReceiveConnection failed on Pin 0 reason 0X8004022A
    PID:00400002 TID:032C01C6 OSAXST1: >>> Loading Module 'icm.dll' (0xBFC9A798) at address 0x44B40000-0x44B49000 in Process 'NK.EXE' (0x8ACBAAD0)
    PID:02C5012E TID:032C01C6 OSAXST1: >>> Loading Module 'icm.dll' (0xBFC9A798) at address 0x44B40000-0x44B49000 in Process 'vplayer.exe' (0xBFC7A210)
    PID:02C5012E TID:03D5016A ERROR: d:\chelanrtm14\private\directx\dshow\filters\demultiplexer\mpeg2\src\pin_in.cpp(814); thread does not exist
    PID:02C5012E TID:03D5016A OSAXST1: <<< Unloading Module 'icm.dll' (0xBFC9A798) at address 0x44B40000-0x44B49000 in Process 'vplayer.exe' (0xBFC7A210)
    PID:02C5012E TID:03D5016A OSAXST1: <<< Unloading Module 'icm.dll' (0xBFC9A798) at address 0x44B40000-0x44B49000 in Process 'vplayer.exe' (0xBFC7A210)
    PID:02C5012E TID:03FD014A [XR] ImageFactory::PrintImageFormat - PixelFormat: GUID_WICPixelFormat32bppBGRA
    PID:02C5012E TID:03FD014A [XR] ImageFactory::PrintImageFormat - PixelFormat: GUID_WICPixelFormat32bppBGRA

    Friday, February 17, 2012 10:52 AM

All replies

  • As I understand output pin should be connected to a video renderer. But how to connect it? Are there any special registry settings? Those errors come from the private part so I cannot check what is wrong there.
    Tuesday, February 21, 2012 9:57 AM
  • Hi Jker,

    Were you able to get rid of this problem? I am getting the same problem. Please tell how can I solve it?

    Thanks!!!

    Monday, August 12, 2013 11:04 AM