none
HTTPS POST using Dynamic Send Port _ Urgent pls help RRS feed

  • Question

  • Hi ,

    I need to POST to a HTTPS url. It is a is REST based Service.

    But I just need a HTTPS POST using Dynamic Sendport.

    The HTTP post was successful by giving below setting on dynamic port. 

    SRP_ToDynamic_HTTP(Microsoft.XLANGs.BaseTypes.Address)= " http://URL";
    SRP_ToDynamic_HTTP(Microsoft.XLANGs.BaseTypes.TransportType) = "HTTP";
    MsgRequest(HTTP.AuthenticationScheme) = "None"; 

    Now the Service endpoint is modified to HTTPS. And URL is modified to have the API Key. Now I am not successful in hitting the HTTPS url. 

    How I modify my Dynamic port to post to this Url.

    Please suggest. I dont want to use any Certificates. The API Keys are encoded in the URL itself. Is this achievable using Dynamic port with HTTP Adapter.

    Or should I move to any other Adapter.

    Thanks

    RRY




    • Edited by MSRRU Monday, June 10, 2013 5:04 AM
    Monday, June 10, 2013 4:27 AM

Answers

  • try using the same HTTPS URL in the browser - do you get a warning saying that the certificate is no trusted? If so, that could be one reason why you are no longer able to access the HTTPS url from biztalk. The server certificate may need to be added to your certificate store (I understand you are using the API Key in your URL - but that is for you (client) to authenticate against the service. In HTTPs, your client (biztalk) needs to be able to trust the service, and for that purpose, the service's certificate must be trusted by your client box).

    • Marked as answer by MSRRU Tuesday, June 11, 2013 5:50 AM
    Monday, June 10, 2013 1:48 PM
  • What version of BizTAlk Server are you using?  On anything 2006 R2 or higher, you should be using the WCF bindings in stead of the HTTP Adapter.

    The process is essentially the same though except you have more items to config with WCF: http://msdn.microsoft.com/en-us/library/bb727706%28v=BTS.10%29.aspx

    HTTPS requires Certificates, that's just how it works.   So, the cert must be resolvable at runtime, issues by a trusted CA for example, or you have to add the site cert to the local store (for the BizTalk Service Account).

    • Marked as answer by MSRRU Tuesday, June 11, 2013 5:50 AM
    Monday, June 10, 2013 4:06 PM

All replies

  • Can you provide the error you are getting?

    If this answers your question please mark it accordingly. If this post is helpful, please vote as helpful.

    Monday, June 10, 2013 1:39 PM
  • try using the same HTTPS URL in the browser - do you get a warning saying that the certificate is no trusted? If so, that could be one reason why you are no longer able to access the HTTPS url from biztalk. The server certificate may need to be added to your certificate store (I understand you are using the API Key in your URL - but that is for you (client) to authenticate against the service. In HTTPs, your client (biztalk) needs to be able to trust the service, and for that purpose, the service's certificate must be trusted by your client box).

    • Marked as answer by MSRRU Tuesday, June 11, 2013 5:50 AM
    Monday, June 10, 2013 1:48 PM
  • What version of BizTAlk Server are you using?  On anything 2006 R2 or higher, you should be using the WCF bindings in stead of the HTTP Adapter.

    The process is essentially the same though except you have more items to config with WCF: http://msdn.microsoft.com/en-us/library/bb727706%28v=BTS.10%29.aspx

    HTTPS requires Certificates, that's just how it works.   So, the cert must be resolvable at runtime, issues by a trusted CA for example, or you have to add the site cert to the local store (for the BizTalk Service Account).

    • Marked as answer by MSRRU Tuesday, June 11, 2013 5:50 AM
    Monday, June 10, 2013 4:06 PM
  • Thanks for your replies.

    I managed to get the working with the same Setting. I believe the problem was with the Service on other end. So, since the Service accepted my request, do this mean that HTTP Adapter can work with HTTPS url ?

    Tuesday, June 11, 2013 5:50 AM