none
Unable to launch Visual Studio 2019 image RRS feed

  • Question

  • Hi,

    I just registered to Azure and immediately upgraded my account.

    I am attempting to launch a VM with the Visual Studio 2019 image from the Marketplace.

    The deployment fails:

    {"code":"DeploymentFailed","message":"At least one resource deployment operation failed. Please list deployment operations for details. Please see https://aka.ms/arm-debug for usage details.","details":[{"code":"NotFound","message":"{\r\n \"error\": {\r\n \"code\": \"PlatformImageNotFound\",\r\n \"message\": \"The platform image 'microsoftvisualstudio:visualstudio2019latest:vs-2019-comm-latest-win10-n:latest' is not available. Verify that all fields in the storage profile are correct.\",\r\n \"target\": \"imageReference\"\r\n }\r\n}"}]}

    Any idea of what could be wrong?

    Thanks


    Monday, May 27, 2019 9:14 PM

All replies

  • What is the region you've chosen to deploy VS 2019? Could you try with a different region?

    You can also try redeploying the image to see if that gets you going.

    Tuesday, May 28, 2019 9:31 AM
    Moderator
  • I tried US East and Africa North.

    I tried to deploy it a few times and still got the same error.

    Wednesday, May 29, 2019 12:30 PM
  • "I just registered to Azure and immediately upgraded my account."
    You mean registered to Azure free trial and then upgraded to Pay-As-You-Go?

    Thursday, May 30, 2019 8:53 AM
    Moderator
  • The article below provides a solution to your issue:

    https://medium.com/@rafique82.ai/azure-virtual-machine-visual-studio-platform-image-not-found-4234fe058317

    Monday, September 2, 2019 5:18 PM
  • @nx4evr Did the article help resolving this issue?
    Wednesday, September 11, 2019 11:32 AM
    Moderator