locked
Xamarin Mac agent not working ?? RRS feed

  • Question

  • User316012 posted

    I was able to connect my Mac located in a virtual machine with visual studio 2015 but after updating xamarin I could not connect to it ! here is the stack trace

    at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(Task task) at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(Task task) at System.Runtime.CompilerServices.TaskAwaiter.ValidateEnd(Task task) at Xamarin.Messaging.Ssh.MessagingService.d__65.MoveNext() in C:\d\lanes\4699\70f1268e\source\xamarinvs\src\Messaging\Xamarin.Messaging.Ssh\MessagingService.cs:line 244 Xamarin.VisualStudio.Remote.State.DisconnectedState|Error|0|Couldn't connect to Mac — Admin. Please try again. Xamarin.VisualStudio.Remote.State.ServerStateContext|Information|0|Server State transition from ConnectingState to DisconnectedState on Mac — Admin (192.168.59.130) Xamarin.VisualStudio.Remote.State.ServerStateContext|Information|0|Disconnected from the Mac Mac — Admin (192.168.59.130) Xamarin.VisualStudio.IOS.SettingsProvider|Information|0|Restarting IDB and Designer agents to refresh new Xcode location settings... Xamarin.VisualStudio.Android.MonoAndroidFlavoredProject|Error|0|The method or operation is not implemented. System.NotImplementedException: The method or operation is not implemented. at System.Runtime.InteropServices.Marshal.ThrowExceptionForHRInternal(Int32 errorCode, IntPtr errorInfo) at Microsoft.VisualStudio.ErrorHandler.ThrowOnFailure(Int32 hr, Int32[] expectedHRFailure) at Microsoft.VisualStudio.Shell.Flavor.FlavoredProjectBase.GetGuidProperty(UInt32 itemId, Int32 propId) at Xamarin.VisualStudio.Android.MonoAndroidFlavoredProject.GetGuidProperty(UInt32 itemId, Int32 propId) in C:\d\lanes\4699\70f1268e\source\xamarinvs\src\Core\VisualStudio.Android\ProjectSystem\MonoAndroidFlavoredProject.cs:line 335

    Wednesday, May 24, 2017 6:14 PM

All replies

  • User262172 posted

    @bahtisalaheddine

    You can try the following:

    Ensure the Xamarin.iOS version running on MacOS and VS are identical (recommended by Xamarin Team) Sometimes the same happens with me if the network changes (office, mobile hotspot, home etc), in that case:

    • Navigate to /Users/YourAccountName/AppData/Xamarin/MonoTouch and delete all the files within the folder.
    • Select the Xamarin Mac Agent (Tools > iOS > Xamarin Mac Agent).
    • Disconnect and forget the agent (You need to right click on relevant mac listed (by IP or DNS name) to get the options).
    • Add Agent again (enter the IP address, then you will be prompted to enter your user name and password).
    • Optionally restart VS

    I understand this may not be an optimal fix but then it gets the job done ;)

    Try and share your feedback.

    Wednesday, May 24, 2017 6:42 PM