locked
IISADMPWD works in Firefox but not IE RRS feed

  • Question

  • User1720447656 posted

    I've scoured everywhere and cannot find a stitch about this issue.

    Im running server 2003 R2 w/ SP2 IIS 6.0 and using IISADMPWD under the default website (only site on this server). This is an internal only and is in the same domain as my test account. I can use Firefox and it works great. I have already gone through everything currently on the internet as far as troubleshooting and nothing has helped. AuthProviders is set to kerb or NTLM and I have tried it just NTLM.

     Has anyone heard of this before?

     

    Thursday, September 17, 2009 3:50 PM

All replies

  • User-823196590 posted

    Speficially what happens with IE?

    Thursday, September 17, 2009 4:00 PM
  • User1720447656 posted

    I set my test account to require password change at next login and hit my test page through IE and it prompts login and fails authentication 3 times then redirects to the 401.2. If I use Firefox and my test account it prompts login, accepts it and allows me to change my password. Its the strangest thing.

    Thursday, September 17, 2009 4:09 PM
  • User1720447656 posted

    I should also note that this doesn't happen in IE if I create a local user account on the server, set that password to require change. IE works then.

    Thursday, September 17, 2009 4:10 PM
  • User-823196590 posted

    Is IE configured to allow Windows Integrated?

    Thursday, September 17, 2009 4:35 PM
  • User1720447656 posted

    It is. It's set to authenticate and does if I use credentials that aren't set to require password change at next login.

    Thursday, September 17, 2009 4:37 PM
  • User-1338102312 posted

    I just started having the same exact problem last week. Did you ever find the soluton??

    Wednesday, November 25, 2009 10:32 AM
  • User1720447656 posted

    Yeah, I got it working. What a dumb fix though. I had to go through adsutil.vbs and set the NTAuthenticationProviders to "NTLM" (even though I needed it to use kerberos).

    Monday, November 30, 2009 10:06 AM
  • User-1338102312 posted

    that worked! thank you very much.  I would never have guessed to do that.

     

    cscript adsutil.vbs set w3svc/1/root/NTAuthenticationProviders "NTLM"

    Monday, November 30, 2009 10:45 AM
  • User1720447656 posted

     Rock on!

    Monday, November 30, 2009 12:41 PM