locked
Brokered WinRT Component Project Templates not supporting visual studio

    Question

  • Hi All,

    I am very new windows developement. I am trying to compile https://github.com/apulliam/BrokeredPointOfService but my visual studio say it can compile only store apps.  I tried to install Brokered WinRT Component Project from Templates https://visualstudiogallery.msdn.microsoft.com/527286e4-b06a-4234-adde-d313c9c3c23e

    it shows following error:

    27-11-2014 12:15:36 - Microsoft VSIX Installer
    27-11-2014 12:15:36 - -------------------------------------------
    27-11-2014 12:15:37 - Initializing Install...
    27-11-2014 12:15:37 - Extension Details...
    27-11-2014 12:15:37 - Identifier      : BrokeredWindowsRuntimeComponentProjectTemplates.5d756893-332a-4fd6-95b8-0a988764fdb6
    27-11-2014 12:15:37 - Name            : Brokered WinRT Component Project Templates
    27-11-2014 12:15:37 - Author          : Microsoft
    27-11-2014 12:15:37 - Version         : 1.0
    27-11-2014 12:15:37 - Description     : This package contains project templates used to create Brokered Windows Runtime Components and their Proxy Stubs, which enables side-loaded modern applications to communicate with pre-existing desktop components.
    27-11-2014 12:15:37 - Locale          : en-US
    27-11-2014 12:15:37 - MoreInfoURL     : http://msdn.microsoft.com/en-us/library/windows/apps/dn630195.aspx
    27-11-2014 12:15:37 - InstalledByMSI  : False
    27-11-2014 12:15:37 - SupportedFrameworkVersionRange : [4.5,)
    27-11-2014 12:15:37 - 
    27-11-2014 12:15:38 - SignedBy        : Microsoft Corporation
    27-11-2014 12:15:38 - Certificate Info : [Subject]
      CN=Microsoft Corporation, OU=MOPR, OU=OPC, O=Microsoft Corporation, L=Redmond, S=Washington, C=US

    [Issuer]
      CN=Microsoft Code Signing PCA, O=Microsoft Corporation, L=Redmond, S=Washington, C=US

    [Serial Number]
      33000000B2E6906F8BE7453D5B0001000000B2

    [Not Before]
      25-01-2013 04:03:41

    [Not After]
      25-04-2014 04:03:41

    [Thumbprint]
      E4EEC5DFB7F413E5A15191DA00D017F97E3A6260

    27-11-2014 12:15:38 - Supported Products : 
    27-11-2014 12:15:38 - Microsoft.VisualStudio.Pro
    27-11-2014 12:15:38 - Version : [12.0]
    27-11-2014 12:15:38 - 
    27-11-2014 12:15:38 - References      : 
    27-11-2014 12:15:38 - 
    27-11-2014 12:15:38 - Searching for applicable products...
    27-11-2014 12:15:38 - Found installed product - Microsoft Visual Studio Express 2013 for Windows
    27-11-2014 12:15:38 - Found installed product - Global Location
    27-11-2014 12:15:38 - VSIXInstaller.NoApplicableSKUsException: This extension is not installable on any currently installed products.
       at VSIXInstaller.App.InitializeInstall()
       at System.Threading.Tasks.Task.InnerInvoke()
       at System.Threading.Tasks.Task.Execute()

    I am using visual studio 2013 update 4 and running windows 8.1 update OS, Please help me resolve this. I am stuck very badly and have no pointers further.

    Thursday, November 27, 2014 6:46 AM

Answers

  • Hi Manu_Manoj,

    Have you installed POS for .NET 1.14 as suggested in Prerequisites for building BrokeredPointOfService Code section of this reference? Please try and let me know the result.

    If you have any concerns, please feel free to let me know.

    Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place. Click HERE to participate the survey.

    Friday, November 28, 2014 3:32 AM
    Moderator