locked
[C#] Unable to pull azure table column data RRS feed

  • Question

  • I'm using a Windows IOT device to push data to the Azure platform using ServiceBus messaging. I'm using a FunctionApp to split that message into data columns and adding it to my Table Columns in an Azure table in my Storage Account. I'm trying to create a C# web application to view the last record in the database but its only pulling the PartitionKey, RowKey, and Timestamp columns, it wont pull out my custom columns or their data. I can see the columns and correct data using the Cloud Explorer in VS 2015 so I know the data is there. I'm also using Microsoft Bi and graphing the data without issue. 

    Code Snippit here:

    https://i.imgur.com/Eze2uEJ.png

    Thanks

    Ryan


    Ryan


    • Edited by Md Shihab Thursday, July 6, 2017 5:06 AM edited title for better clarity
    Wednesday, July 5, 2017 5:35 PM

All replies

  • It’s hard to tell without more information and debugging into what’s happening. Can you try running the same code, but instead of using TableOperation.Retrieve<pooldata>, using TableOperation.Retrieve()? This will return a DynamicTableEntity (DTE) containing all the data retrieved.  If the DTE contains the missing “Pool” data, this means that something’s gone wrong in the conversion from what’s read off the wire to an object of the “pooldata” type. If the DTE does not contain the “Pool” data, but it’s visible using the Storage explorer, something’s gone wrong with the query. In this case, one thing to try would be to run the query without specifying selected columns – this is what the Storage Explorer does, and it might help with debugging what the issue is.

    -----------------------------------------------------------------------------------------------------

    Do click on "Mark as Answer" on the post that helps you, this can be beneficial to other community members.

    Tuesday, July 18, 2017 7:32 AM