locked
.browser file is not read anymore (IIS broke?) RRS feed

  • Question

  • User789954666 posted

    Im doing a MOSS 2007 project and have used a .browser file to apply a controladapter to a custom control. This has worked fine up until we deploy a version to a new testserver. We couldn't get the new testserver to read the browser file. Using filemon.exe we could see that the ISS process was reading MOSS's browser file (compat.browser) but it was not even trying to access our own browser file. No matter what we do it just does not see our browser file. This is very strange since the excat same files and dll's is working on another server.

    On another working server, we then tried to rename the browser file to .old, reset IIS and hit the page. ofcourse it did not read the browser.old file. we then renamed it back to .browser, reset IIS and now its NOT reading the browser file on that server aswell. We now tried deleting, recreating, rebooting the server, etc etc and nothing works. It just does not want to read .browser files. It seems very buggy and random and we got no clue how to fix this.

    Has anyone ever experienced something similar. How do i fix this? any suggestions?

    Tuesday, October 2, 2007 5:47 AM

All replies