none
Compatibility with Outlook 2013 and Exchange 2013 - Version 15.0 (Build 1236.3) (on Prem) RRS feed

  • Question

  • Hi,

    Please can someone confirm that Outlook 2013 and Exchange 2013 is compatible with the JS Office API version 1.3.

    Regards

    Graham


    Monday, November 21, 2016 4:24 PM

Answers

  • Hello Graham,

    The answer is no.

    Your add-in should indicate 1.1 level of API to work with Exchange 2013. If you require 1.3 API level you need to work against Exchange 2016 as minimum. Please refer to the lookup table provided Celeste Li.

    Best regards,


    Slava Ivanov

    • Marked as answer by Graham Croker Tuesday, November 22, 2016 2:50 PM
    Tuesday, November 22, 2016 1:46 PM

All replies

  • Hi,

    To check the compatibility, please visit Understanding Outlook API requirement sets, you could find:

    Choosing a minimum requirement set

    Developers should use the earliest requirement set that contains the critical set of APIs for their scenario, without which the add-in won't work.

    Clients

    The following clients support Outlook add-ins.

    Client

    Supported API requirement sets

    Outlook 2016 for Windows

    1.1, 1.2, 1.3

    Outlook 2016 for Mac

    1.1

    Outlook 2013 for Windows

    1.1, 1.2, 1.3

    Outlook on the web (Office 365 and Outlook.com)

    1.1, 1.2, 1.3

    Outlook Web App (Exchange 2013 On-Premise)

    1.1

    Outlook Web App (Exchange 2016 On-Premise)

    1.1, 1.2. 1.3

    Note: Support for 1.3 in Outlook 2013 was added as part of the December 8, 2015, update for Outlook 2013 (KB3114349)

    If you want to Exchange 2013 supports for 1.2/1.3, I suggest you submit a feedback in the link below:

    http://officespdev.uservoice.com

    Regards,

    Celeste


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, November 22, 2016 2:57 AM
    Moderator
  • Hi Celeste,

    So can Outlook 2013 connect to Exchange 2013 (on- premise) and be able to use features from 1.3 version of the API?

    Exchange server is on CU 14

    Graham


    Tuesday, November 22, 2016 10:53 AM
  • Hello Graham,

    The answer is no.

    Your add-in should indicate 1.1 level of API to work with Exchange 2013. If you require 1.3 API level you need to work against Exchange 2016 as minimum. Please refer to the lookup table provided Celeste Li.

    Best regards,


    Slava Ivanov

    • Marked as answer by Graham Croker Tuesday, November 22, 2016 2:50 PM
    Tuesday, November 22, 2016 1:46 PM