Invalid formatetc structure RRS feed

  • Question

  • User-742492890 posted

    Out of the blue, when dragging a control or extender from the ajax toolbox onto my form design serivce, I get following error message:

     "The operation could not be completed. Invalid FORMATETC structure"

    Have found lots of posts from people who share this error, but no resolution.

    Interestingly, it is project specific.  Does not happen when I create a new web app in a different solution.

    Any ideas?

    Thanks in advance! 




    Thursday, June 14, 2007 5:35 PM


  • User399821848 posted

    No idea unfortuntately.  Best I can suggest is to create a new project that works and start moving things over until it doesn't (or maybe it always will).

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, June 15, 2007 2:02 PM

All replies

  • User399821848 posted

    Are you on the most recent (10606) build?  I believe this only happens with the AnimationExtender and the Accordion control, and we addressed this issue in the this latest release.  Can you make sure that's the version your Toolbox items are referencing?

    Thursday, June 14, 2007 7:45 PM
  • User-742492890 posted

    sburke thanks for the response.

    The toolbar now references version 10606 of AJAXExtensionsToolbox.dll.  

    However, still getting same error mesage when I try to drag ANY control or extender from toolbar onto form.

    Here are version for the two primary ajax dlls: 

    <add assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>

    <add assembly="System.Web.Extensions.Design, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>

    Any suggestions? 


    Friday, June 15, 2007 12:03 AM
  • User399821848 posted

    Hmmm - what's "AJAXExtensionsToolbox.dll"?

    Friday, June 15, 2007 1:26 AM
  • User-742492890 posted

    Good Morning Shawn...

    Sorry for the mix-up. Actually, the toolbox (for the Ajax Control Toolkit) points to --> AjaxControlToolkit.dll, ver 1.0.10606.0.

    (The AJAXExtensionsToolbox.dll lives in the directory --> C:\Program Files\Microsoft ASP.NET\ASP.NET 2.0 AJAX Extensions\v1.0.61025.  And, I am not directly referencing him.)

    Can I send you a word doc that has pictues of the my references, web.config, directory structure and such?

    There has to be some kind of bad reference within the solution itself, as I can create a new web project in a different solution and access the ajax control toolkit just fine.

    Really appreciate your help.

    rob vettor, robv@avanade.com, 214-707-0584



    Friday, June 15, 2007 11:54 AM
  • User399821848 posted

    Well if it works in another project/solution that means you've got something left over in your web.config file or bin directory.  Close VS and go to the bin directory and delete the *.refresh file.  Copy in the 10606 AjaxControlToolkit.dll, reopen VS and see if that helps.

    Friday, June 15, 2007 1:10 PM
  • User-742492890 posted

    (1) Removed following files from the bin directory:


    (2) Added AjaxControlToolkit.dll to bin

    (3) Re-Opened Visual Studio (even 'cleaned' the solution).

     Unfort, prob still exists.

    Question: Believe that Visual Studio creates a cache of the solution files somewhere. Could finding and clearing that cache help?

    Again, appreciate your help. 

    By the way, here is a copy of my web.config:

    <?xml version="1.0"?>



    <section name="dataConfiguration" type="Microsoft.Practices.EnterpriseLibrary.Data.Configuration.DatabaseSettings, Microsoft.Practices.EnterpriseLibrary.Data, Version=, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>


    <dataConfiguration defaultDatabase="DesignPatternsStudyGroupConnectionString"/>







    <add tagPrefix="asp" namespace="System.Web.UI" assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>




    Set compilation debug="true" to insert debugging

    symbols into the compiled page. Because this

    affects performance, set this value to true only

    during development.


    <compilation debug="true">


    <add assembly="System.Windows.Forms, Version=, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>

    <add assembly="System.Design, Version=, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>

    <add assembly="System.Management, Version=, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>

    <add assembly="System.Data.OracleClient, Version=, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>

    <add assembly="System.Configuration.Install, Version=, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>

    <add assembly="System.Transactions, Version=, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>

    <add assembly="System.Drawing.Design, Version=, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/>

    <add assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>

    <add assembly="System.Web.Extensions.Design, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>

    <add assembly="VsWebSite.Interop, Version=, Culture=neutral, PublicKeyToken=B03F5F7F11D50A3A"/></assemblies>



    <remove verb="*" path="*.asmx"/>

    <add verb="*" path="*.asmx" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>

    <add verb="*" path="*_AppService.axd" validate="false" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>

    <add verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" validate="false"/>



    <add name="ScriptModule" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>




    <validation validateIntegratedModeConfiguration="false"/>


    <add name="ScriptModule" preCondition="integratedMode" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>



    <remove name="WebServiceHandlerFactory-Integrated"/>

    <add name="ScriptHandlerFactory" verb="*" path="*.asmx" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>

    <add name="ScriptHandlerFactoryAppServices" verb="*" path="*_AppService.axd" preCondition="integratedMode" type="System.Web.Script.Services.ScriptHandlerFactory, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>

    <add name="ScriptResource" preCondition="integratedMode" verb="GET,HEAD" path="ScriptResource.axd" type="System.Web.Handlers.ScriptResourceHandler, System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"/>




    Friday, June 15, 2007 1:27 PM
  • User399821848 posted

    No idea unfortuntately.  Best I can suggest is to create a new project that works and start moving things over until it doesn't (or maybe it always will).

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Friday, June 15, 2007 2:02 PM
  • User626107716 posted

    Hmm.... I'm having the exact same problem [:(]

    Friday, July 6, 2007 9:06 AM
  • User1005758432 posted

    I have exact problems It seems AJAX has more bugs than useful. I'm using VS under Vista and perhaps the majority of the problems are coming from. Anyway, I couldn't even drag and dropg the Collapsible extender from the toolbar to the .aspx page in Design mode. I'll give me a black circle with a line crossing it. If I drag the control to the .aspx page in source mode then the error listed above popup. For me, it doesn't matter which project or solution I'm in, I always get this problem. Is there any real solution for these kinds of problem? I'm also getting errors when using the According too. So many there is a bigger problem here.

    Thursday, July 19, 2007 9:52 AM
  • User1550315626 posted

    I got the same problem with Beta 2 of Orcas when trying to drag a ScriptManager or any other control on the page.  I though ajax extention was included in .Net Framework 3.5 but it is perhapse not the case.



    Tuesday, July 31, 2007 6:26 AM
  • User1646371542 posted

    I get the same message and am running VS2005 on Vista. I get the message whenever I try dragging a scriptmanager over to a page. I have reloaded ASP.NET 2.0 and AJAX 1 on the system with no success.

    Sunday, August 26, 2007 1:57 PM
  • User1005758432 posted

    If you have VS2005 on Vista, that's the source of MANY problems. I've never complained anything about Microsoft's product until I installed VS2005 on Vista and then to top it off, I installed Orcas thinking that it will solve many incompatible issues with Vista. Well, it's giving me a ton of grief and headaches so I uninstalled it. However, since VS2005 is still running on my Vista machine, I've still experienced various other problems including the ones you mentioned. However, since I did some many tthings to this machine (couldn't remember which step I did), I no longer see that problem now. My best advice to use VS2005 under Windows XP Pro.

    Monday, August 27, 2007 8:49 AM
  • User1646371542 posted

    OK, so here is what I have discovered so far. I am now able to use VS2005 and ASP.NET AJAX on Vista, but it took a little figuring and a lot of time. When I orignally set my machine up, I was installing most software as the Administrator, then created the user account. I was having issues due to Vista's new locked down security. With my user account being in the Administrators group there were administrative tasks I could not run. I did a full wipe of the HDD and reinstalled Vista and created a user. I then installed VS2005 (had some install issues first time through), VS SP1, then the Vista Update for VS. Installed AJAX and the tool kit and everything runs just fine. I think the issue is with Vista's security and not VS2005, but I cannot really confirm this, but maybe someone else can. BTW if you install 2008 beta 2, it takes to run throughs of the installer. First time installs ASP.NET 3.5 and that is it. Second time through will install the actual program.

     For the install issue, I was getting the error that it could not open vs_setup.ms_ and it could not be opened. I redownloaded the ISO image and unpacked it to a directory on the HDD, but even then had an issue. Found out, even though my user account was in the administrators group and I created the folder, I still did not have permissions on the folder. Burned the ISO to CD and no problems.


    Thursday, August 30, 2007 8:10 AM
  • User1005758432 posted

    If you want to find out more problems with the VS2005 and Vista, take a look at this two threads.



    http://forums.asp.net/t/1118954.aspx?PageIndex=3 problems with Orcas in this thread.

    So far there are no answers to the problems I have in those two threads. And the problems is getting more weird, random, and hard to reproduce with VS2005 and Vista.

    Thursday, August 30, 2007 8:56 AM
  • User-991753956 posted


    I have same issue with "the operation could not be completed" on XP with VS2005 and Beta2 also. It keeps the same manner like working with new projects and this error on the current one. It really appears that the only thing is to start a new one but ...is this a real solution. I mean it happens with AjaxControls as well as Telerik RADControls..Actually thats why i got to VS2008 - just hoped that the JS is going to be a little bit more integrated. We'll see that in the future. The bad thing is that it can happen just like that any time and moving and copying isn't quite an elegant solution. If someone get to an idea or some kind of semi-solution - I will be grateful.

    Good luck to all and success




    Friday, October 12, 2007 9:50 AM
  • User894167286 posted

    I've had this Formatetc structure error every time I would drag in an AJAX toolbox control on a page (old project or not) in Visual Web Developper 2008, and I found why it was happening in my case. Here's the sequence of events:

    -VWD 2008 was working fine but I needed the older AJAX toolkit to work with the Framework.net 2.0.

    -I download the AjaxControlToolkit.zip from CodePlex and save it on the desktop.

    -I extract its content in a folder on the desktop and install everything. Everything is working perfectly.

    -I'm done working so I close VWD 2008, and clean up my desktop so I move the AjaxControlToolkit (which came from the .zip) folder somewhere else.

    -The day after, I open up my project and I can't drag any Ajax toolkit control on my pages anymore, getting the FORMATETC error.

    -After many hours searching for a solution, moving the AjaxControlToolkit folder back on the desktop made it work.

    So VWD was still looking on my desktop for some files, while they were somewhere else.

    Thursday, January 10, 2008 2:02 PM
  • User-991753956 posted

    Hi FRobert,

    I solved this simply by recreating the project - well guess, it worked. I am 99% sure that I missed something myself but the debug info was too useless. So it works now - thanks God it was not a huge project yet.

    Success with yours though.



    Thursday, January 10, 2008 4:00 PM
  • User1086278009 posted

    Hi FRobert,

      May I ask, how did you get the Ajax Toolkit Control included in Visual Web Developer 2008?

      I got the latest Ajax Toolkit and extract it to a directory on my computer, but I'm not sure what to do next.

      I can't find anywhere where it tells me how to make add it to Visual Web Developer 2008.

      Have a great day and thanks in advance.




    Thursday, February 21, 2008 5:24 PM
  • User894167286 posted

    Hi, I made a post there: http://forums.asp.net/t/1214633.aspx 
    It should contains what you need to correctly install the toolkit in VWD 2008.
    Good luck!

    Thursday, February 21, 2008 5:42 PM
  • User1086278009 posted



    Thursday, February 21, 2008 6:02 PM
  • User-576999009 posted

    Weird, I have same problem today when I opened an existing project. No problem before, only today, I am using VS 2008.

    Tuesday, April 15, 2008 2:09 PM
  • User-185328631 posted

    The issue I had was trying to drag and drop and AjaxControlExtender from the AjaxControlToolkit tab in the Toolbox.  The solution was courtesy of my friend.  He figured out that the version being used in the References section of our solution was different from the version installed on our local computers and in the ajaxControlToolkit tab in our VS 2008 Toolbox.  Hence the quick solution was to create a new tab in the Toolbox, and click "Choose Items" -> Browse and pick the AjaxControlToolkit.dll in the directory where the solution for that project resided on the computer.



    Tuesday, August 5, 2008 4:48 PM
  • User1883266596 posted

    I was having this problem using VS 2005 and XP pro.  I was able to resolve it by removing several project entries from my solution.  They were all entries for projects that did not exist on my local system (I believe they were added to the solution by another team member, but were not yet put into source control).  Hope that can help someone!

    Friday, August 22, 2008 11:47 AM
  • User-1824873309 posted

    Step by Step

    Remove  ajaxControlToolkit tab

    Create a ajaxControlToolkit tab

     click "Choose Items" 


    pick AjaxControlToolkit.dll

    Now works!!


    Thanks DevKnight

    Sunday, August 24, 2008 7:04 AM
  • User1407828493 posted

     Reset toolbox.Then add new tab and browse to the dll.Try this.

    This works for me.


    Thursday, November 6, 2008 2:12 AM
  • User984760449 posted

    I think you are on the right track with the reset tool box.  That resolved the issue for me.  Here is what I did:
    1 - Right-clicked on the AJAX tool box, selecte RESET TOOLBOX and the AJAX toolbox listing completely cleared.
    2 - I downloaded  the latest toolbox from : http://www.codeplex.com/AjaxControlToolkit/Release/ProjectReleases.aspx?ReleaseId=16488
        a - I chose the AjaxControlToolkit-Framework3.5SP1-NoSource.zip  since I am not a programmer.
    3 - Downloaded the package into a temp file and unzipped the package.
        a - Installed the AjaxControleExtender.vsi by double clicking on it.
        b - This also creates a AJAX Sample web site.  You will need this  for step 8.
    4 - Now you can load the new tool kit into VWD from the AJAX Sample web site that is part of the download package.
    5 - Create a new web page(any page will do.) so you can access the toolbox listings.
    6 - Create a new tab - I used AJAX Tool Box(or whatever)
    7 - Right click inside the new tab and select BROWSE
    8 -
    Browse to the AJAX Sample Website "bin" directory.
    9 - Locate the "AjaxControlToolKit.dll" and click open.  This will load the toolbox with the updated files.

    To test:  create an AJAX enable web page, add a button control.  Then drag a AJAX ConfirmationControlExtender onto the button.
    If you go to the source vie you should see something like this:
    <asp:Button ID="Button1" runat="server" Height="23px" Text="Button"  Width="226px" />
    <cc1:ConfirmButtonExtender ID="Button1_ConfirmButtonExtender" runat="server"
    ConfirmText="Are yo sure you want to commit ?" TargetControlID="Button1">

     Hope this helps someone..

    Monday, November 24, 2008 6:53 PM
  • User1407828493 posted

     Yes,This is what I mentioned.This is working Properly.

    Monday, November 24, 2008 10:07 PM
  • User-77694393 posted

    I found that there are many situations where you might get this error.

    There are around 7 solutions. But I couldn't post all of them here.

    I have tried to list most of them here.

    Solution: Invalid FORMATETC structure

    P.S. One of my blog reader also found a solution.

    Wednesday, February 4, 2009 9:39 AM
  • User188029144 posted

    This error can occur when one has added the ajaxcontroltoolkit assembly to the tools pane and subsequently moved the referenced ajaxcontroltoolkit assembly.  I encountered this error after re-organizing my project files.  If you attempt to "choose items" to reset the toolbox, you may find that Visual Studio crashes.  At least I did.  To get around the error, you can move the referenced assembly back to where it was, or follow these steps to reset the tools and re-add the ajax control toolkit:

    1. Inside the toolbox, Right-click on the AJAX Extensions menu and select  "reset toolbox".  Click "ok" at the warning dialog.
    2. Your ajax tools will now dwindle to just a few System.Web 3.5 core tools
    3. Now right-click on the AJAX Extensions menu again and select "Choose Items".
    4. Browse to the location of your AjaxContorlToolkit.dll assembly and add the controls back in.

    Good luck!


    Wednesday, January 6, 2010 12:30 PM
  • User-46330738 posted


    I am facing the same problem " The Operation could not be completed. Invalid Formatetc structure ". But i overcome the problem, so for that what i did, just remove the ajax dll and then add it. It will work fine.

    Here i am using the autocompleteextender control in ajax. so now it is fine.

    Happy coding

    Wednesday, June 8, 2011 1:45 AM