none
GET, POST work fine, but IIS responds with 403 error on PUT request RRS feed

  • Question

  • Hi,

     

    Newbie question: I have installed ADO.Net Data services CTP1 and created a webservice on a database. GET and POST requests with application/json work very nicely. However a PUT (update) request results in an 403 response.

     

    Is this an IIS configuration issue?

     

    Your help appreciated!

     

    Luc

     

     

    Wednesday, January 23, 2008 11:44 PM

Answers

All replies

  • Add PUT verb on svc extention on IIS Admin

     

    Thursday, January 24, 2008 11:20 AM
  • Thanks Pierlag, this tip worked!
    Thursday, January 24, 2008 3:22 PM
  • How to do that---Add PUT verb on svc extention on IIS Admin
    Anyone kindly help me?
    Tuesday, June 9, 2009 12:07 PM
  • I need to add MERGE also.  Here was my scenario.  Almost all the object that I Updated to the database were done in a batch process and worked fine.  It was very rare for me to just update one object without updating others, or adding others.

    I had one table where I simply needed to update that information, and I kept getting the

    "You have attempted to execute a CGI, ISAPI, or other executable program from a directory that does not allow programs to be executed." - 403.1 error

    After chasing down the log files and going through them very carefully, it was MERGE that was being used to update one table.

    Just an FYI!!

    Friday, May 21, 2010 7:21 PM