locked
Azure Data Factory Copy Data failed for large tables RRS feed

  • Question

  • I had to move 1TB data from Azure SQL data warehouse to SQL Server 2016 on premises. Created Gateway, linked serves and tried to copy tables. Large tables failed to copy data.Is there any limitation on the size of the tables to use Copy Data Wizard? I appreciate information related to this.
    Tuesday, December 6, 2016 4:06 PM

All replies

  • Could you please share the error message
    Tuesday, December 6, 2016 4:28 PM
  • I didn't save the error message. But the pipeline in Ready state for 5 hours and then failed.

    As an alternative I copied flat files with table data to local storage. Visual studio Integration service worked fine to load data.

    I tried ADF copy data to load data from flat files in local on-prem directory to On-prem SQL Server via gateway. When mapped columns got 'Incompatible data type' error. Is there a way that we can fix these incomaptibility issues by changing the data type as in Visual Studio? I just unchecked box next to that column with error and finish the pipeline setup. Execution failed with error "Copy Activity encountered a user error at Source side".

    Thanks for your reply!

    Tuesday, December 6, 2016 8:10 PM