locked
Getting premade 3d objects (.obj, .xaml) into Expression Blend RRS feed

  • Question

  • Hi, I'm very new to Expression Blend and have a few questions.

    First of all, I'm using the trial version of Expression Blend 3 and I believe it's more or less correctly installed along with .NET 3.5 Sp1.

    What I'm having difficulty with is integrating a 3d object designed in Blender into EB.  I've imported the object as both .obj and .xaml (using the Blender -> XAML plugin), and I can add both of them into EB using "Add Existing Item", but I can't figure out how to get it onto a canvas, either through dragging and dropping or using the "Insert" feature (dropping doesn't work, and "Insert" is unclickable). Like I said, I'm a total newbie to Expression Blend, so maybe I'm overlooking something basic.

    I'd really appreciate any help. Thanks

    Monday, May 24, 2010 12:23 AM

All replies

  • I don't know if this is related or not, but when I try to open the 3d .xaml object in EB it gives a barrage of errors of the type 'the name "..." does note exist in the namespace "http://schemas.microsoft.com/client/2007"' (the "..." includes Viewport3d and PerspectiveCamera and about ten or so other names). I checked the code for the .xaml and the xmlns and xmlns:x reference "http://schemas.microsoft.com/winfx/2006/xaml/presentation" and "http://schemas.microsoft.com/winfx/2006/xaml". I'm a bit befuddled about this, since following a tutorial it looked like I should be able to open the 3d .xaml object directly in Blend without any fuss
    Monday, May 24, 2010 12:38 AM
  • Ah, I figured it out--I was working on a Silverlight project under the assumption that Silverlight could do true 3d. I feel pretty foolish now.

    Monday, May 24, 2010 2:12 AM
  • you can select all and right click to put it in a canvas.

    right click-> group into-> canvas(or other).

    Sunday, May 30, 2010 9:16 AM
  • hey, since u r working with 3d objects, do you know how to view through the inner of the 3d objects???
    Sunday, May 30, 2010 9:18 AM
  • Could you please explain how you have resolved this issue, I am also getting the same error: The name "Viewport3D" does not exist in the namespace "http://schemas.microsoft.com/client/2007". and can not find any work around for that!

    I am using Expression blend 4 and Visual Studio 2010 (Silverlight 4 application).

    thanks.

    Monday, October 4, 2010 2:51 PM