locked
Adding Property to ActiveX Plugin for Powerpoint RRS feed

  • Question

  • I am trying to figure out properties and how Powerpoint and ActiveX plugins communicate.  I am having problems getting properties to show up inside Powerpoint, and am having a very difficult time finding documentation.  I downloaded a sample (control123) from the web, and tried to add a new string property "TestString" and it doesn't show up in Powerpoint. (see attached project).  Do you know what's wrong?  I did exactly what the MS documentation online says to use the "Add Property Wizard" (http://msdn.microsoft.com/en-us/library/khbc069h.aspx)   I am using Office 2010 and Visual Studio 2010.

    My sample project is at: http://www.blainebell.org/contral123.tar

    Thanks for your help.

    Blaine

    Thursday, October 17, 2013 1:13 PM

All replies

  • Hi Blaine,

    Thank you for posting in MSDN forum.

    Many Microsoft Windows applications — including many of those from Microsoft itself, such as Internet Explorer, Microsoft Office, Microsoft Visual Studio, and Windows Media Player — use ActiveX controls to build their feature-set and also encapsulate their own functionality as ActiveX controls which can then be embedded into other applications.

    Can you get properties to show up inside other applications such as Word, Excel etc.?

    I have downloaded the file you provided, what’s the suffix of this file?

    I cannot register it in PowerPoint 2013(both .ocx and .dll).

    Does the MFC project build successfully?


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, October 18, 2013 10:13 AM
  • I figured this out.  Powerpoint caches some binary representation of the IDL in some weird AppData directories that was preventing me to see new properties:

    http://social.msdn.microsoft.com/Forums/office/en-US/d935f9c4-4e3f-44d9-a334-e8bb208d17ca/custom-activex-control-missing-properties?forum=exceldev

    I just deleted the files in C:\Users\bell\AppData\Local\Temp\PPT11.0 and it worked.

    This is insane.  At the very least it should check the timestamp to see if the ocx has changed...

    • Proposed as answer by George Hua Monday, October 21, 2013 1:50 AM
    • Marked as answer by George Hua Wednesday, October 23, 2013 4:12 PM
    • Unmarked as answer by Blaine Bell Friday, December 20, 2013 7:20 PM
    Friday, October 18, 2013 5:20 PM
  • Well, I have run into this problem again.  My original solution was to change the library name of my ActiveX component (i.e., in the idl file), so that my new version will have a different named cache file in the directories above (and the properties will be found).  However, this does not take into account reading in previously created powerpoint files that have an old version of our ActiveX plugin embedded (i.e., backwards compatibility).  It amazes me that its difficult to get this information (I believe this post has my similar problem http://social.msdn.microsoft.com/Forums/vstudio/en-US/d736ec16-2707-444d-ad0d-0d2af2497586/comclass-and-backward-compatibility but its very difficult to decipher the solution, since I have no idea where the ComClass fits into my project, is it my COleControlModule?).  If anyone has had this problem before and can help, or point me in the right direction, please do.

    Thanks,

    Blaine


    Blaine Bell

    Friday, December 20, 2013 7:25 PM
  • This solution, how so simple, is to change the GUID.  You should change the GUID for every version of your plugin.  This will trigger the rewriting of this cached file so that new properties can be seen.

    Blaine Bell

    Wednesday, February 5, 2014 9:23 PM